locked
Distribution list issues RRS feed

  • Question

  • Exchange 2016 organization having distribution list problems. Non dynamic distribution lists, most members are not getting messages.

    Organization was an SBS 2003 organization.. groups were "upgraded" with: 

    Get-DistributionGroup | Set-DistributionGroup -ForceUpgrade

    mailboxes "upgraded" with Get-Mailbox | Set-Mailbox -ApplyMandatoryProperties

    when I run Get-DistribututionGroupMember -identity "All Email" I get a list of 58 users.

    when I send an email & Get-MessageTrackingLog for that message I see an Recipient count of 7 (not 58 as expected).

    group scope is set as universal, group type distribution. I've tried creating new Distribution list with the same results. If you "break" the group in outlook and send all 58 users recieve the message. Anyone have ideas on how to resolve this issue

    Tuesday, August 16, 2016 12:21 PM

All replies

  • Hi,

    It’s recommended try to specifically point out a DC in your domain.com domain as an expansion Server with the following command:

    Set-DistributionGroup -Identity <YourDistributionGroup> -ExpansionServer <DC in yourExchange domain>

    Set-DistributionGroup

    Hope it helps.

    Best regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jason Chao
    TechNet Community Support

    • Edited by Jason.Chao Wednesday, August 17, 2016 3:01 AM
    • Proposed as answer by Jason.Chao Monday, August 22, 2016 1:44 AM
    Wednesday, August 17, 2016 3:01 AM
  • Hi,

     

    Would you please provide us with an update on the status of your issue? If the solution helped, if so, please help to mark as answer, it'll be helpful and easily to search for others, thanks for your time.

     

    Best regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jason Chao
    TechNet Community Support

    Monday, August 22, 2016 1:44 AM
  • I have done as you suggested however the issue remains..

    any other ideas?

    Monday, August 22, 2016 12:13 PM
  • Hi,

    You can check the all members of the message from the message tracking via the following command to see if only 8 users:

    Get-messagetrackinglog -Server "servername" -messagesubject "message subject" -resultsize unlimited| select @{n="Recipients";e={$_.Recipients}} | FOREACH {$_.REcipients} | FL

    Please also help to verify if any failure (NDR) happens during delivery to the DL.

    If you can see any error message when you ran the command : get-queue | fl after you had send a message to this DL.

    You can also check the maxrecipientsPermessage via the following command:

    Get-receiveconnector <connectorname> | fl maxre*

    Hope it’s helpful.

    Best regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jason Chao
    TechNet Community Support

    Tuesday, August 23, 2016 2:29 AM
  • I have given up on this issue, I have varies other address list issues going on as well. it appear to be a all from the 2003 sbs migration. I'm creating a new domain, new exchange install etc... I'm starting new...

    Jason

    Thursday, September 1, 2016 5:26 PM
  • Ok, if you have any other issues, please feel free to post out. Thanks.

    Best Regards,

    Jason Chao
    TechNet Community Support


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 2, 2016 2:37 PM