none
DPM 2012 SP1 powershell recovery fails RRS feed

  • Question

  • There is a major problem with command-line recovery in DPM2012SP1.

    I've installed a new Win2012 standard, new DPM2012SP1, installed Rollup 1, and created a brand new recovery point.

    now...

    $ds = get-datasource -dpmservername <server>
    
    $sa = new-searchoption -searchstring "Windows" -fromrecoverypoint 07.07.2008 -torecoverypoint 08.08.2008 -searchdetail filesfolders -searchtype contains -recursive -location "C:\"
    
    $r0 = Get-RecoverableItem -datasource $ds[0] -SearchOption $sa

    Powershell fails...

    Of course, I've tried different dates, different datasources, and different search strings. I even downloaded the vhd trial version of DPM2012SP1 - same result.

    Since the work of a whole team is based on proprietary program that utilizes dpm powershell for item recovery, this functionality is crucial.

    Has anyone experienced anything like it or has a solution?

    Monday, April 1, 2013 3:14 AM

All replies

  • Can you please post the failure error?
    Thursday, April 4, 2013 2:48 PM
  • Sure

    Powershell has stopped working

    Problem signature:
      Problem Event Name:    PowerShell
      NameOfExe:    powershell.exe
      FileVersionOfSystemManagementAutomation:    6.2.9200.16434
      InnermostExceptionType:    System.NullReferenceException
      OutermostExceptionType:    System.NullReferenceException
      DeepestPowerShellFrame:    unknown
      DeepestFrame:    bject+GetRecoverableObjectSyncManager.ProcessEvent
      ThreadName:    unknown
      OS Version:    6.2.9200.2.0.0.272.7
      Locale ID:    1049

    I assume that the given script works flawlessly in your environment...

    Thursday, April 4, 2013 2:56 PM
  • Have you tried current dates, 03.1.2013 to 04.1.2013?

    I saw you're trying a year worth of data. May be to much to processes at once.

    What dates have you tried?

    Thursday, April 4, 2013 3:09 PM
  • previously it worked with several years worth of data. In any way if it's not an error in code or some compatibility issue, powershell should react with some kind of regular error not with a crash.
    Thursday, April 4, 2013 3:18 PM