locked
Getting access denied error message when running Activity monitor RRS feed

  • Question

  • Hi All first time posting on Technet, I have tried couple of solutions found on the forums but non of them worked. 

    A user is getting access denied message while trying to run Activity monitor.

    Error: The activity Monitor is unable to execute queries against server PROD1. Activity Monitor for this instance will be placed in paused state. Use the context menu in the overview pane to resume the Activity Monitor.

    Additional Information: Access is denied. (Exception from HResult: 0X8000XXXXXX(E_Accessdenied))(mscorlib) 

    He is a Sysadmin on SQL 2012   but a regular user on windows 2008 R2 server. If i make the user admin on the server everything works fine. So far i have tried the following. 

    1. Assign access to "Performance monitor group"

    2. I followed the following blog post here regarding Dcom access which didn't help either.

    http://blogs.msdn.com/b/sqlagent/archive/2013/02/07/activity-monitor-in-sql-server-2012-sp1.aspx 

    Any ideas what could be an issue, any assistance is greatly appreciated.

    Thursday, August 14, 2014 3:47 AM

Answers

  • Please check this post...

    https://connect.microsoft.com/SQLServer/feedback/details/770897/after-installing-sp1-sql-server-2012-activity-monitor-gives-access-denied

    Look at this hotfix, since it addresses the issue: http://support.microsoft.com/kb/932370

    If you’re getting Access Denied – unfortunately the only way is to either enable DCOM permissions as it was suggested in the workaround,

    http://support.microsoft.com/lifecycle/search/default.aspx?sort=PN&alpha=windows+server&Filter=FilterNO

    ============

    Are you remotely accesing to a server? This issue could have occured if you don't have remote access to the computer through DCOM. Typically, DCOM errors occur when connecting to a remote computer with a different operating system version. If this is the case, please try give the user Remote Launch and Remote Activation permissions.

    Please follow the steps:

    1. Click Start, click Run, type DCOMCNFG, and then click OK.
    2. In the Component Services dialog box, expand Component Services, expand Computers, and then right-click My Computer and click Properties.
    3. In the My Computer Properties dialog box, click the COM Security tab.
    4. Under Launch and Activation Permissions, click Edit Limits.
    5. In the Launch Permission dialog box, select your user and group in the Group or user names box. In the Allow column under Permissions for User, select Remote Launch and select Remote Activation, and then click OK.
    6. Under Access Permissions, click Edit Limits and give Remote Access to your user.
    7. Go to DCOM Config(Expand My Computer), find "Windows Management Instrumentation", right-click and select Properties
    8. In the Security tab, click on Edit under Launch and Activation Permissions, and give your user Remote Launch and Remote Activation.

    For more information, see Securing a Remote WMI Connection
    http://msdn.microsoft.com/en-us/library/windows/desktop/aa393266(v=vs.85).aspx

    ========


    Raju Rasagounder Sr MSSQL DBA

    Thursday, August 14, 2014 4:04 AM

All replies

  • Please check this post...

    https://connect.microsoft.com/SQLServer/feedback/details/770897/after-installing-sp1-sql-server-2012-activity-monitor-gives-access-denied

    Look at this hotfix, since it addresses the issue: http://support.microsoft.com/kb/932370

    If you’re getting Access Denied – unfortunately the only way is to either enable DCOM permissions as it was suggested in the workaround,

    http://support.microsoft.com/lifecycle/search/default.aspx?sort=PN&alpha=windows+server&Filter=FilterNO

    ============

    Are you remotely accesing to a server? This issue could have occured if you don't have remote access to the computer through DCOM. Typically, DCOM errors occur when connecting to a remote computer with a different operating system version. If this is the case, please try give the user Remote Launch and Remote Activation permissions.

    Please follow the steps:

    1. Click Start, click Run, type DCOMCNFG, and then click OK.
    2. In the Component Services dialog box, expand Component Services, expand Computers, and then right-click My Computer and click Properties.
    3. In the My Computer Properties dialog box, click the COM Security tab.
    4. Under Launch and Activation Permissions, click Edit Limits.
    5. In the Launch Permission dialog box, select your user and group in the Group or user names box. In the Allow column under Permissions for User, select Remote Launch and select Remote Activation, and then click OK.
    6. Under Access Permissions, click Edit Limits and give Remote Access to your user.
    7. Go to DCOM Config(Expand My Computer), find "Windows Management Instrumentation", right-click and select Properties
    8. In the Security tab, click on Edit under Launch and Activation Permissions, and give your user Remote Launch and Remote Activation.

    For more information, see Securing a Remote WMI Connection
    http://msdn.microsoft.com/en-us/library/windows/desktop/aa393266(v=vs.85).aspx

    ========


    Raju Rasagounder Sr MSSQL DBA

    Thursday, August 14, 2014 4:04 AM
  • "Edit Limits" buttons are disabled on Windows Server 2016

    Wednesday, March 27, 2019 6:39 AM