locked
Editing Word doc from SharePoint Online opens Notepad RRS feed

  • Question

  • I have an issue whereby every time I attempt to edit a Word document from an Office 365 SharePoint Online site it opens Notepad with the message "Cannot find the .txt file. Do you want to create a new file". If I answer yes it creates a file called .txt on the desktop.  It seems to have lost its association with Word, but only when opening from SP Online.  This is happening for any Word document in any doc. library in the site.

    The Word documents open and edit in Word Online fine.  I can open Word desktop and open the file from Backstage no problem.

    It only occurs when I try to edit the file directly from the SharePoint team site.

    I have checked all associations and they look fine to me.  Opening .docx files from the file system open in Word no problem. Other Office programs open normally from SP Online - Excel, OneNote, etc. - only .docx files have the issue. I am using Word 2013 installed from O365.  I have repaired and re-installed Office 2013 with no change.

    When I try to edit a Word document from OneDrive for Business, nothing happens.  Editing other Office programs from OFB works fine.

    Any help much appreciated. 


    Wednesday, March 2, 2016 3:02 AM

All replies

  • Hi,

    Please check the following settings:

    1. Open IE and click "Manage add-ons" in the Settings.
    2. Click "All add-ons" (lower left corner)
    3. Locate the "SharePoint OpenDocuments Class" add-on and make sure it is enabled.

    Also change a computer and confirm if other users can open the document from SharePoint Online with Word application on Windows client.

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Winnie Liang
    TechNet Community Support

    Thursday, March 3, 2016 11:01 AM
  • Yes that Add-in is enabled.  The problem is still occurring.

    This was not an issue until recently, but it is now an issue for all users on all workstations (10) in this office network using the same Office 365 tenancy.

    It is also happening in multiple browsers (IE 11 and Chrome).

    Thanks.


    Thursday, March 3, 2016 11:26 PM
  • Hi,

    Please check the following settings:

    1. Open Control Panel, click View by Small icons.
    2. Click Default Programs.
    3. Click Associate a file type or protocol with a program.
    4. Under Protocols part in the list, click MS-WORD, make sure the Current Default is set to Office (desktop).

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Winnie Liang
    TechNet Community Support

    Friday, March 4, 2016 5:53 AM
  • Yes, it is already.  Clicking on a Word document in the file system does open Word and the document opens correctly.

    Friday, March 4, 2016 5:56 AM
  • Hi,

    Please also try:

    1. Open the SharePoint Online library in the Windows Explorer.
    2. Select a Word document, right-click it > click Open with > Choose another app.
    3. Select Microsoft Word as the default open programs. Also make sure "Always use this app to open .docx file" is checked.

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Winnie Liang
    TechNet Community Support

    Friday, March 4, 2016 6:10 AM
  • Have this exact problem.  This seems to be the only reference to this problem I can find so is probably quite obscure!  Have tried all of the above suggestions but the local device launches notepad, as described above.  Any further suggestions?
    Monday, January 15, 2018 10:00 AM
  • Hey, were you ever able to solve this? I am having the same issues now with 0365 ProPlus.

    Thanks,

    Jody

    Thursday, October 17, 2019 1:49 PM
  • Sorry, that was back in 2016 so can't remember the exact resolution, but think it resolved itself after further Office and/or Windows updates.  I can't remember ever taking an action myself to fix it.

    Colin

    Thursday, October 17, 2019 10:04 PM