Unable to delete VM RRS feed

  • Question

  • I'm trying to move a number of Virtual Machines from one disk to another. Basically, we've install a new and faster drive (SAN, RAID 10), and we need to migrate all of our VMs to this new drive.

    In order to do this, I export the VM to the new location, but when I then try to delete the VM, I get an "failed to delete" error. It says:

    VM_Name failed to delete
    VM_Name failed to delete configuration: General access denied error (0x8007005)
    VM_Name failed to delete. (VM ID 51xxx...)
    VM_Name failed to delete configuration: General access denied error (0x8007005) (VM ID 51xxx...)

    The first thing I looked at was file and directory access. Do I have the rights to delete the files in question, and yes I do. I've done a "Effective Permission" check on each and every file in the VM_Name directory structure (the folders, the .xml file and the .vhd file), but I still cannot delete the VM, and I'd rather not have duplicates of each machine showing in the Hyper-V manager.

    Can anyone point me in the right direction to troubleshoot this?

    To make matters more confusing, I have been able to delete a botched imported VM, even though I did get the same error the first time around. I simply changed that ACL on the directory structure to allow me to delete, and I was then able to delete it. But I'm not having any luck with the next WM that I am working on moving...
    Wednesday, June 3, 2009 3:45 PM


  • All of a sudden today it worked. I RDP'ed in to the server, opened the Hyper-V manager, and deleted the VM without issue. I have no idea why it worked today and not yesterday. No other changes have been done to the system in the meantime. Maybe some file was locked by some thread and/or process, and this suddenly ended and allowed access to the file. Well, either way, problem solved, I guess...

    Thursday, June 4, 2009 6:28 PM