none
Getting INET_E_RESOURCE_NOT_FOUND error when trying to access a virtual host RRS feed

  • Question

  • I am a web application developer, and I use the virtual host feature of the Apache web server to have local copies of several web sites on my PC. This has worked for years under Windows XP, Windows 7 and also Windows 10 - until installing the Creators Update, since when I can only access one of my virtual hosts with Internet Explorer. I can access all of them with Edge, Firefox, and Opera, but all but one of them give me the INET_E_RESOURCE_NOT_FOUND error with IE.

    I have tried the suggested fixes I have found in numerous posts, but none of them work. Any ideas?

    Friday, July 7, 2017 8:29 PM

Answers

  • I do not use a proxy server. In Internet Options>Connections tab>LAN Settings>Proxy Server settings it is set to "Automatically detect settings".

    Rather than setting all security zones to their default I went into Internet Options>Security and added each of these problem URLs to the Trusted zone. THEY NOW WORK!!! Why did this update require this change?.

    • Marked as answer by tony32 Thursday, July 13, 2017 8:32 AM
    Thursday, July 13, 2017 8:31 AM

All replies

  • Hi,

    Patch Tuesday is coming, next week.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions.


    Rob^_^

    Saturday, July 8, 2017 9:26 PM
  • Hi, 

    July update has been released to fix several IE issues, please install it to check this issue again; 

    https://support.microsoft.com/en-za/help/4022716


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 11, 2017 6:19 AM
    Moderator
  • I have downloaded and installed this update, but the problem is still there. Of all the URLs which I have set up using the Apache VirtualHost facility I can only access one of them using IE - all the others give me an INET_E_RESOURCE_NOT_FOUND error. I do not have the same problem with Edge and Firefox.
    Tuesday, July 11, 2017 12:22 PM
  • Hi,

    " I can access all of them with Edge, Firefox, and Opera, but all but one of them give me the INET_E_RESOURCE_NOT_FOUND error with IE."

    What's different then?

    see https://social.msdn.microsoft.com/Forums/windows/en-US/3afb3932-4d8b-408b-9ea4-fad1cf810de3/ineteresourcenotfound-when-navigating-with-net-webbrowser-control?forum=winforms

    INET_E_RESOURCE_NOT_FOUND == "The server or proxy was not found".

    Internet Options>Connections tab>LAN Settings>Proxy Server settings.

    IE File>Properties menu will tell you which IE security zone a host is mapped to.

    Internet Options>Security tab, click "Reset all zones to default", will reset the security zone settings to their default.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions.


    Rob^_^

    Thursday, July 13, 2017 12:01 AM
  • I do not use a proxy server. In Internet Options>Connections tab>LAN Settings>Proxy Server settings it is set to "Automatically detect settings".

    Rather than setting all security zones to their default I went into Internet Options>Security and added each of these problem URLs to the Trusted zone. THEY NOW WORK!!! Why did this update require this change?.

    • Marked as answer by tony32 Thursday, July 13, 2017 8:32 AM
    Thursday, July 13, 2017 8:31 AM
  • Windows 10 Pro x64 10.0.15603 Build 15063
    IE 11

    I have the same problem on a number of public web sites (i.e. usps.com).  The update you linked to says: "The update that this article describes is no longer available and has been replaced by a newer update. It is recommended that you install the most current cumulative update, KB4025342."  I have KB4025342 installed.

    I tried resetting all security settings to the default.  Didn't help.

    I tried adding https://*.usps.com to trusted sites but that didn't help.

    How do I get IE 11 working again?

    P.S. I noticed that the bottom of the Internet Options\Advanced tab says: "Some settings are managed by your system administrator."  What does that mean and why is it showing up?  How do I get rid of it?  I am they system administrator and I did not set any restrictions on IE settings.


    http://www.saberman.com

    Sunday, July 23, 2017 7:06 PM
  • @saberman

    I visited usups.com but encountered no error messages... (Please include screenshots or the text of any messages with your questions).

    P.S. I noticed that the bottom of the Internet Options\Advanced tab says: "Some settings are managed by your system administrator."  What does that mean and why is it showing up?  How do I get rid of it?  I am they system administrator and I did not set any restrictions on IE settings.

    Your Company system/network administrators manage client settings through Group Policy, not Internet Settings.

    Do other computers on your company network have the same problem as you with usups.com? Does the problem persist if you create a new user account on the machine?

    The first step in troubleshooting any web browser issues is to test in noAddons mode. You should in the first instance contact your company network administrators to resolve your profile configuration of the machine you are using.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions.


    Rob^_^

    Sunday, July 23, 2017 9:34 PM
  • >I visited usups.com but encountered no error messages...
    Try usps.com.  After playing around awhile I was able to reach usps.com.  But when I clicked on the tracking link I got the DNS error.  It appears it could not resolve tools.usps.com.  Trying to ping tools.usps.com returned a not found message.  Today it appears to be working.

    >Your Company system/network administrators manage client settings through Group Policy, not Internet Settings.
    I think you missed my statement that I am the only administrator for this system and I did not make any Group Policy changes.  The latest update apparently did.  This is not the first time that an update changed Group Policy settings.  It would be nice if Microsoft would bother to list the Group Policy settings that the update changed so I could change them back.

    >Do other computers on your company network have the same problem as you with usups.com?
    The other computers on my LAN did not have the problem.  This is a small LAN without a domain controller.

    Finally, please note that I am the only user on this LAN.  I normally log into the workstations with a super user id not an administrator id.


    http://www.saberman.com

    Monday, July 24, 2017 9:52 PM