locked
Windows 7 64-bit Corrupting (Altering) Large Files Copied to External NTFS Drives RRS feed

All replies

  • Kindly elaborate on the description. Does it occur when the same files are copied using Linux? Also, does the issue occurs even when any other similar device is used? Does the issue occur if the same storage device is connected to any other computer?

    Try this:

    Copy the files and use Safely Remove option to remove the device. If the issue is absent, then it means that, previously, you have removed the device while copying. Doing so will naturally corrupt the files. Closing of the file transfer progress dialog doesn't mean the copying file has been successfully transferred. Either see the device activity/indicator light or use Safely Remove option.

    Saturday, May 4, 2013 10:06 AM
  • no need to safely remove, once the file is copied, I made a compare using winhex, there are always differnt bytes, usualy around 50kb are differnet, when copy the same files using linux ubuntu 12.04 in the same laptop there are no problems when copying to external hard disk. it is for sure a windows 7 x 64 bug

    I tried to copy large avi files, arround 2GB size, there are no difference, only in exe, zip, 7z, and large size above 100MB

    I am usig wester digital my passport 3.0, 1 tera. I have toshiba satelite L 655 , with latest bios and latest driver, windows 7 x64 sp1 all updates are installed, I even intsall http://support.microsoft.com/kb/2581464

    Saturday, May 4, 2013 11:23 AM
  • Kindly try safely remove and then check.

    Balaji Kundalam

    Saturday, May 4, 2013 4:06 PM
  • sir, I tried the safely remove with no success, I even installed a new windows to check, installed the latest drivers, the problem still exist, I confirm again no such problem in linux

    Thursday, May 9, 2013 8:06 PM
  • can someone help how to contact miscrosoft support, i couldn't find it

    Friday, June 28, 2013 1:47 PM
  • Did you check the file space as size or size on disk? Size on disk varies with different storage devices. Only the size remains the same. Additionally, note that as long as the files work correctly, there is no issue with the file size when copied to external storage devices.

    For Microsoft support, you can follow the link:

    http://support.microsoft.com/contactus/?ln=en-us


    Balaji Kundalam

    Friday, June 28, 2013 2:07 PM
  • the file size is the same, again there is no such problem in linux, I have an WD exteranl with lock works only in windows, and I use windows more often than linux, I have lost of important file, due to this bug in windows :(

    the cotact option doesn;t work with my product ID, it says it needs money

    I think this bug will not be fixed ever in windows 7, I should try windows 8.1 now hope it is OK

    Monday, July 1, 2013 3:10 PM
  • maybe you can help me in this, I found that Intel rst driver ( mine now is 12.6.3.1000 ) added the file iaStorF.sys ( Intel rst filter driver ) to all the disks drive in device manager, including the external USB hard disk, and USB flash, and the SD card, although they are not connected to Intel Chip, could it make a problem running these USB disks?


    • Edited by paradis Tuesday, July 2, 2013 2:24 AM missing words
    Tuesday, July 2, 2013 2:22 AM
  • the file size is the same, again there is no such problem in linux, I have an WD exteranl with lock works only in windows, and I use windows more often than linux, I have lost of important file, due to this bug in windows :(

    So, the issue has been solved. As far as the file size remains the same, and the the files are working correctly, you need not worry about it.

    And, Intel Rapid Storage Technology (Intel RST) is for RAID configurations only and won't impact non-RAID configurations.


    Balaji Kundalam

    Tuesday, July 2, 2013 2:30 AM
  • no the size is the same, but there are some different bytes, hashes always different, I uninstall Intel rts driver and did some tests, same to be OK, but I installed it again cause it is a main driver, I think the problem from the driver iaStorF.sys, not 100% sure, I just wish that someone can confirm
    • Edited by paradis Tuesday, July 2, 2013 2:50 AM correct
    Tuesday, July 2, 2013 2:48 AM
  • getting sick of this problem, I uninstalled Intel RST and did copy lots of files to the external NTFS hard disk with no problems at all.

    I will send feedback if I have this problem again without RST, so 100% sure the problem from Intel RST in my laptop

    Thursday, July 4, 2013 2:36 AM
  • Ok, lets be brief.

    This problem is annoying me for years. It is totally reproducible although random. It happens when copying to external drives (mainly USB) when they are configured for "safe removal". I have had issues copying to NTFS and FAT32 partitions. I have had issues using 4 different computers, from 7 years old to brand new ones, using AMD or intel chipsets and totally different USB controllers, and using many different USB sticks, hard disks, etc. The only common thing in those computers is Windows 7 x64 and the external drives optimization for "safe removal". Installing Teracopy reduces the chances of data corrpution, but does not eliminate them completely. The only real workaround (tested for 2 years) is activating the write cache in the device manager properties of the drive. In that way, windows uses the same transfer mechanisms as for the internal drives, and everything is OK.

    MICROSOFT guys, there is a BIG BUG in windows 7 x64 external drives data transfer mechanism. There is a bug in the cache handling mechanism of the safe removal function. Nobody hears, I've been years talking about this in forums. It is a very dangerous bug because it is silent, and many non professional people is experiencing random errors in their backup data. PLEASE, INVESTIGATE THIS. YOU NEED TO FIX SUCH IMPORTANT BUG. IT IS UNBELIEVABLE THAT IT IS STILL THERE SINCE 2009!!!

    Hope this helps.

    Friday, April 11, 2014 6:13 PM
  • Well, it's been almost two years. I couldn't find any significant, more recent information on this. Wondering if you've learned anything since. Are you still experiencing the problem? I encountered it a few years ago, but have not been able to test since then. So since then I've always done a file comparison (or hash check) after any copy to an external drive.

    Now, though, I want to use an external drive to create a Windows Backup backup image, and have realized that there is no way that I can ensure the integrity of it, since there is nothing that I can compare it to.

    Tuesday, January 19, 2016 4:33 PM