locked
UAG can't save configuration file to TMG storage RRS feed

  • Question

  • Hi,

     

    Now when I activate UAG, there is an error message "Configuration file could not be saved to TMG storage".

    If I only apply setting in TMG, no problem.

    How to troubleshooting it?

     

    PS: I already restart server.

     

    George


    邁格行動 技術顧問 George 小顧 部落格: http://www.magg.com.tw/blog/
    Monday, April 25, 2011 8:07 AM

Answers

  • It appears your TMG storage may be corrupted. If you made any manual changes to your TMG config, that may be the cause. Start by removing ANY rules or changes you made to TMG, and try to activate again. If this does not help, it may be possible to clean up the TMG config completely, but we don't have a published procedure for that, and so I suggest creating a support case with Microsoft.


    Ben Ari
    Microsoft CSS UAG/IAG Support
    Sammamish, WA
    • Marked as answer by Erez Benari Wednesday, May 4, 2011 11:39 PM
    Wednesday, May 4, 2011 11:39 PM

All replies

  • It appears your TMG storage may be corrupted. If you made any manual changes to your TMG config, that may be the cause. Start by removing ANY rules or changes you made to TMG, and try to activate again. If this does not help, it may be possible to clean up the TMG config completely, but we don't have a published procedure for that, and so I suggest creating a support case with Microsoft.


    Ben Ari
    Microsoft CSS UAG/IAG Support
    Sammamish, WA
    • Marked as answer by Erez Benari Wednesday, May 4, 2011 11:39 PM
    Wednesday, May 4, 2011 11:39 PM
  • Hi, Ben,

     

    After several try, no use.

    So I decide to install a new server and migrate setting from old to new server.

    Everything is fine.

    Only one thing I can report to you that when I import setting, I found the Network connector IP address pool did not import to new server.

    I am not sure why. So maybe you can see is it bug or not.

    The UAG is SP1.

     


    邁格行動 技術顧問 George 小顧 部落格: http://www.magg.com.tw/blog/
    Thursday, May 5, 2011 2:16 PM
  • Have you tried HKEY_LOCAL_MACHINE\SOFTWARE\WhaleCom\e-Gap\Common\Conf

    IgnoreTMGStore - 0 off 1 on reg key. (set to 1) (dword)

    Then save and activate configuration in UAG, then change reg key back to 0.

    I used to take backups of UAG and TMG separately, but I wondered if the backup took in UAG contains a backup of TMG, you could just roll back to a previous with the key set to 1. The backup sizes seem to look like the uag backup would contain tmg

    I have been through all this loads of times but the above seems to always get me out of a hole, prior to this I was rebuilding all the time.

    Monday, May 9, 2011 12:48 PM