none
Message Rejecting from Exchange server 2013 EDGE Server

    Question

  • We have a hybrid environment Exchange Online and are using Exchange 2013 EDGE Server as hybrid server. We have an application that submits emails to Exchange using SMTP and sends emails from noreply@smtpdomain.com. Since almost half of our user base is already in Exchange Online, many of these emails which are generated on-premises need to be routed to Exchange Online. This configuration has been working for months. On 24/06/2014, the emails from this application stopped getting delivered. 

    On examination of message tracking logs, I found SMTP FAIL events - excerpt below.

    ConnectorId             : Outbound to Office 365
    Source                  : SMTP
    EventId                 : FAIL
    InternalMessageId       : 39560943768623
    RecipientStatus         : {[{LRT=};{LED=550 5.1.8 Access denied, message rejected (AS3)};{FQDN=};{IP=}]}

    Doing a search for the error in recipient status did not return anything but doing a search for "access denied" did return results that suggested a scenario when a user in Exchange Online would be prevented from sending outbound email after having been identified as sending spam - see http://technet.microsoft.com/en-GB/library/dn458545(v=exchg.150).aspx

    It seems our on-premises Exchange 2013 server has enacted a similar block on our noreply address which sends out a lot of emails. I have been able to confirm that if the 'from address' is changed to something like noreply123@smtpdomain.com, all emails from the application get delivered successfully.

    I now need to find out how I can unblock our noreply address so these emails can be sent with the original from address.

    Appreciate all help I can get on this one.


    Shyam

    Wednesday, September 28, 2016 8:36 AM

Answers

  • Hi Shyam,

    You could use the below command to add the sender address.

    $list = (Get-ContentFilterConfig).BypassedSenders
    $list.add(“noreply@smtpdomain.com”)
    Set-ContentFilterConfig -BypassedSenders $list

    For the rollback, please use the below:

    Set-ContentFilterConfig -BypassedSenders @{Remove=”noreply@smtpdomain.com”}

    Let me know for any questions.

    Thanks,

    Biswa

    Thursday, September 29, 2016 5:11 AM

All replies

  • Hi Shyam,

    You can run the below command on your on-premises Exchange to bypass scanning.

    "Set-ContentFilterConfig -BypassedSenders noreply@smtpdomain.com"

    Let me know if this resolves the issue.

    Wednesday, September 28, 2016 8:50 AM
  • Hi,

      I need rool back plan also  . I mean after adding how to remove it.  It's Prod server, need roll backup options when doing something.
     I did google but failed to get remove option.


    Shyam


    • Edited by Shyam89 Wednesday, September 28, 2016 11:15 AM
    Wednesday, September 28, 2016 11:13 AM
  • Hi Shyam,

    You could use the below command to add the sender address.

    $list = (Get-ContentFilterConfig).BypassedSenders
    $list.add(“noreply@smtpdomain.com”)
    Set-ContentFilterConfig -BypassedSenders $list

    For the rollback, please use the below:

    Set-ContentFilterConfig -BypassedSenders @{Remove=”noreply@smtpdomain.com”}

    Let me know for any questions.

    Thanks,

    Biswa

    Thursday, September 29, 2016 5:11 AM