none
Project Server 2013 SSRS with Project Site RRS feed

  • Question

  • Hi All,

    We are using Project Server 2013. We have developed a SSRS report by accessing Project Site lists. It was working fine for some time, now when we try to access the report it is showing loading. The data source itself is not working, we used http://<servername>/PWA as URL for the data source . The reports developed without Project Site list are working fine. 

    After 5 to 10 minutes it is showing the below error.

    An error has occurred during report processing. (rsProcessingAborted)
    Query execution failed for dataset 'dtRisk'. (rsErrorExecutingCommand)
    An error occurred when accessing the specified SharePoint list. The connection string might not be valid. Verify that the connection string is correct. (rsSPDataProviderError)
    For more information about this error navigate to the report server on the local server machine, or enable remote errors

    When we try to test the datasource connecting string, after 5 minutes showing the below error.

    An error occurred when accessing the specified SharePoint list. The connection string might not be valid. Verify that the connection string is correct. (rsSPDataProviderError) Get Online Help For more information about this error navigate to the report server on the local server machine, or enable remote errors 

    Below connection setings


    Thanks in advance , Taj




    • Edited by arun_2014 Monday, June 9, 2014 12:37 PM
    Sunday, June 8, 2014 3:17 PM

All replies

  • Hi Taj, 

    Your list is in PWA? is a global list?, if not, try to make a connection with http://server/PWA/SiteProject may this can resolve, because when you do some DS with a SPList, your need to stablish that connection directly at site path where you have the list.

    I hope this help


    Ray


    • Edited by Ray Chapa Monday, June 9, 2014 1:36 PM
    Monday, June 9, 2014 1:36 PM
  • Hi Raymundo,

    Actually we need to get the Project Site list items. We have created a datasource for PWA site and get the each project site list items from the data set. It was working fine, suddenly we are facing the issue.


    Thanks in advance

    • Edited by arun_2014 Tuesday, June 10, 2014 11:59 AM
    Monday, June 9, 2014 1:48 PM