none
Agent Unavailable - Although Protected server DPMRA service starts. RRS feed

  • Question

  • I've protected a server for a long time. Last night I ran Windows Updates and updated the NIC drivers. This morning the Agent is Unavailable. 

    When I refresh the agent on DPM, the DPMRA service starts on the protected server but DPM Management console displays the following errors:

    Protection agent version:	4.2.1205.0
    Error:	Data Protection Manager Error ID: 308
    	The protection agent operation failed because DPM could not communicate with the Protection Agent service on shc-data02.shootershill.ac.uk.
    Detailed error code:	The RPC server is unavailable (0x800706BA)
    Recommended action:	If you recently installed a protection agent on shc-data02.shootershill.ac.uk, the computer may be restarting. Wait a few minutes after restarting the computer for the protection agent to become available. If the problem persists, do the following:
    1) Verify that shc-data02.shootershill.ac.uk is remotely accessible from the DPM server.
    2) If a firewall is enabled on shc-data02.shootershill.ac.uk, verify that it is not blocking requests from the DPM server. 
    3) If shc-data02.shootershill.ac.uk is a workgroup server the password for the DPM user accounts may have changed or expired. To resolve this error, run SetDpmServer with the -UpdatePassword flag on the protected computer and Update-NonDomainServerInfo.ps1 on the DPM server.
    4) Restart the DPM Protection Agent service on shc-data02.shootershill.ac.uk. If the service fails to start, uninstall the protection agent by using Add or Remove Programs in Control Panel on shc-data02.shootershill.ac.uk. Then in the Management task area, on the Agents tab, in the Actions pane, click Install to reinstall the protection agent on shc-data02.shootershill.ac.uk.
    

    I have checked all of the above and reinstalled the agent... still no luck!

    Thursday, March 17, 2016 11:07 AM

All replies

  • BUMP.
    Thursday, March 17, 2016 3:33 PM
  • Hi,

    1. If protected server not domain member - check if password is expired

    2. Manually reinstall agent:

    - on protected server uninstall agent, and install using files from DPM server agents dir

    - and run: SetDPMServer.exe -DPMServerName dpm.mydomain.internal

    if protected server not domain server run: 

    SetDPMServer.exe -DPMServerName dpm.mydomain.internal -IsNonDomainServer -UserName "backup_user"

    and then on DPM server: 

    Update-NonDomainServerInfo.ps1 -dpmservername dpm.mydomain.internal -psname protected_server backup_user_password

     

    Tuesday, March 22, 2016 6:11 AM
  • This happens due to wrong update as well so check if updates installed are correct... Also check if communication is happening between both machines...

    Try to uninstall updates & then check if still same issue occurs?

    Thanks


    Mayank Dhama

    Tuesday, March 22, 2016 6:45 AM