locked
ConfigMgrRCMQueue - Still have deleted Secondary site vaules - No Replication RRS feed

  • Question

  • Good morning all.

    ConfigMgrRCMQueue - Still have deleted Secondary site values - (Still visible in Console - status=deleting for last 24 hours) resulting in all replication between CAS and PRI to be halted

    So much so the ConfigMgrRCMQueue stays disabled. Ho do I get rid of this error and my SCCM 2012 deployment working 100% again?

    Tuesday, July 17, 2012 6:40 AM

Answers

  • Here goes.

    From the CAS console:

    Ran replication Link Analyzer on Primary and found that it failed with error message.

    ConfigMgrRCMQueue is in disable state.

    If I enable the queue in Child Primary Site again it goes in disable state.

    I found that many messages were stuck in queue.

    On the PRI Database.

    Run the following query:

    exec spDiagDRS – This gave me more diagnostic info

    select is_broker_enabled, * from sys.databases where name = db_name()  - To determine if the Broker is up and running

    select * from sys.dm_exec_requests – To get some task status

    select * from sys.transmission_queue – To view queue

    I saw that 6 messages, this included jobs another secondary site S08 which is also uninstalled. (S08 and S28)

    Ran “END CONVERSATION '149DB2CF-93B6-E111-A0D4-0017A4770834'” , this removed references to S08 but we still see few more coming up. The long number is the conversation_handle if I remember correctly.

    I still have the message for S28 queued up in ConfigMgrRCMQueue.

    Deleted the queued messages from ConfigMgrRCMQueue for Secondary site S28,  after that issue was resolved.

    Also note when deleting a site from the console you can execute the following from the prompt on the PRI site.

    Preinst /delsite S08

    This ensures no clutter left behind.

    Good Luck.


    • Marked as answer by Otto Rogowski Thursday, August 2, 2012 7:39 AM
    • Edited by Otto Rogowski Saturday, August 4, 2012 7:22 PM Spelling
    Thursday, August 2, 2012 7:39 AM

All replies

  • The pictures aren't displayed. So what's the exact issue? You deleted a secondary and it still shows up as a replication partner? How have you deleted the secondary? Or have you deleted a primary?

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, July 17, 2012 6:48 AM
  • Good Morning Torsten.

    I have deleted a Secondary Site - Still displays in console.

    Replication still refers to deleted site - We have lost all link status with all the Secondary Sites and the PRI

    ConfigMgrRCMQueue does not want to enable.

    Tuesday, July 17, 2012 6:59 AM
  • What does the replication link analyzer tell you when examining CAS <--> PRI?

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, July 17, 2012 8:05 AM
    1. That the Replication queue ConfigMgrRCMQueue on the SQL box is disabled.
    2. That the Replication queue ConfigMgrRCMQueue on the PRI is disabled.
    3. Database inconsistency for the SITE
    4. Link Failed on SITE

    When running

    SELECT TOP 1000 *, casted_message_body =
    CASE message_type_name WHEN 'X'
      THEN CAST(message_body AS NVARCHAR(MAX))
      ELSE message_body
    END
    FROM [CM_PRI].[dbo].[ConfigMgrRCMQueue] WITH(NOLOCK)

    I receive one entree only of a pending replication referring to the Deleted Site.

    I assume this is halting the database sync.

    Also

    On the CAS database the deleted site is listed in dbo.sites

    under the PRI database not.

    If I restart the Queue I get an error referring to a site S28(deleted Site). I do not see this site in the console, but it seems to be in the DB, I found a reference to it in the queue. It seems that the site has been deleted, but the replication queue does not seem to know about it.

    Tuesday, July 17, 2012 8:22 AM
  • Any ideas how to purge the ConfigMgrRCMQueue
    Wednesday, July 18, 2012 8:31 AM
  • Here goes.

    From the CAS console:

    Ran replication Link Analyzer on Primary and found that it failed with error message.

    ConfigMgrRCMQueue is in disable state.

    If I enable the queue in Child Primary Site again it goes in disable state.

    I found that many messages were stuck in queue.

    On the PRI Database.

    Run the following query:

    exec spDiagDRS – This gave me more diagnostic info

    select is_broker_enabled, * from sys.databases where name = db_name()  - To determine if the Broker is up and running

    select * from sys.dm_exec_requests – To get some task status

    select * from sys.transmission_queue – To view queue

    I saw that 6 messages, this included jobs another secondary site S08 which is also uninstalled. (S08 and S28)

    Ran “END CONVERSATION '149DB2CF-93B6-E111-A0D4-0017A4770834'” , this removed references to S08 but we still see few more coming up. The long number is the conversation_handle if I remember correctly.

    I still have the message for S28 queued up in ConfigMgrRCMQueue.

    Deleted the queued messages from ConfigMgrRCMQueue for Secondary site S28,  after that issue was resolved.

    Also note when deleting a site from the console you can execute the following from the prompt on the PRI site.

    Preinst /delsite S08

    This ensures no clutter left behind.

    Good Luck.


    • Marked as answer by Otto Rogowski Thursday, August 2, 2012 7:39 AM
    • Edited by Otto Rogowski Saturday, August 4, 2012 7:22 PM Spelling
    Thursday, August 2, 2012 7:39 AM
  •  Will you please elaborate How to delete Queued messages from ConfigMgrRCMQueue..???

    Thanks in Advance..

    Sunday, September 16, 2012 12:00 PM
  • How did you remove the queued entries from ConfigMgrRCMQueue ?
    Sunday, February 9, 2014 11:36 AM
  • I used a query as supplied by Microsoft Support - this will be custom and site dependent. Best is to upgrade to the SP1 as this also resolves the issue.
    Monday, February 10, 2014 8:24 AM
  • requesting to use the hierarchy maintenance tool to delete the secondary site.

    configuration manager installation directory\bin\x64\00000409\preinst.exe /delsite xxxx

    XXX- Site code of secondary

    also requesting to verify the replication status between CAS and Primary site. Make sure primary site is not in maintenance mode. also verify the firewall exception for SQL broker port and SQL port.


    Bhavani Y

    Wednesday, July 29, 2015 10:06 AM
  • requesting to use the hierarchy maintenance tool to delete the secondary site.


    This thread is more than 1 year old so I doubt that the issue is still present. 

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, July 29, 2015 10:24 AM