none
IOS 13 skype for business RRS feed

  • Question

  • Dear all,

    After we upgraded to ios 13 our iphones skype for bussines doens not work. Our server is skype for bussines 2019. Some logs are below

    2019-10-08 07:05:34.296 0000000105545840 INFO APPLICATION CClientTelemetryProvider.cpp:623 Sending telemetry event<failed_request> with parameters: (AutodiscoveryState:ADUserGetRequestSent IsAnonFallback:false IsAnonymousSession:false ServerDeploymentInfo:Unknown ServerResponseCorrelationId:4ff23bfc-b408-44dc-bdb4-df2d9aaf39bf ServerResponseDate:Tue, 08 Oct 2019 07:05:33 GMT ServerResponseStatusCode:200 SignInCorrelationId:E55A019B-9207-4150-8029-7A622356A239 UcwaSessionState:IsAutoDiscovering )  [viz]
    2019-10-08 07:05:34.296 0000000105545840 INFO APPLICATION CClientTelemetryProvider.cpp:426 Sending telemetry to ARIA for type(SignInAutoDiscoveryTransition) signatureName() errorCode(E_ConnectionError (E2-2-1)) description() diagnosticLevel(0) [viz]
    2019-10-08 07:05:34.296 0000000105545840 INFO APPLICATION CClientTelemetryProvider.cpp:623 Sending telemetry event<SignInAutoDiscoveryTransition> with parameters: (AutodiscoveryState:ADUserGetRequestSent HasAppEverSignedIn:No HasUserEverSignedIn:No InitiationPoint:SignInButton IsAnonFallback:false IsAnonymousSession:false ServerDeploymentInfo:Unknown SignInCorrelationId:E55A019B-9207-4150-8029-7A622356A239 SipUriSetBy:DiscoverUcwaUrlsForUser Substep:AuthUserGet_Failure SuspensionState:SuspensionCompleted UcwaSessionState:IsAutoDiscovering UseInternalUcwaUrl:true UserEnabledProxy:false UserEnteredPassword:true UserEnteredUsername:false UsernameMatchesSip:true )  [viz]
    2019-10-08 07:05:34.296 0000000105545840 INFO APPLICATION CUcwaAutoDiscoveryService.cpp:1407 Raising Autodiscovery event with status (E_ConnectionError (E2-2-1)) for eventType (0) AD in progress (0), NL in progress (0)
    2019-10-08 07:05:34.296 0000000105545840 INFO APPLICATION CClientTelemetryProvider.cpp:426 Sending telemetry to ARIA for type(SignInAutoDiscoveryEnd) signatureName() errorCode(E_ConnectionError (E2-2-1)) description() diagnosticLevel(0) [viz]
    2019-10-08 07:05:34.296 0000000105545840 INFO APPLICATION CClientTelemetryProvider.cpp:623 Sending telemetry event<SignInAutoDiscoveryEnd> with parameters: (AutodiscoveryState:ADUserGetRequestSent HasAppEverSignedIn:No HasUserEverSignedIn:No InitiationPoint:SignInButton IsAnonFallback:false IsAnonymousSession:false ServerDeploymentInfo:Unknown SignInCorrelationId:E55A019B-9207-4150-8029-7A622356A239 SipUriSetBy:DiscoverUcwaUrlsForUser SuspensionState:SuspensionCompleted UcwaSessionState:IsAutoDiscovering UseInternalUcwaUrl:true UserEnabledProxy:false UserEnteredPassword:true UserEnteredUsername:false UsernameMatchesSip:true )  [viz]
    2019-10-08 07:05:34.297 0000000105545840 INFO APPLICATION CUcwaAutoDiscoveryServiceRetrialWrapper.cpp:405 Received event for type 0 with status E_ConnectionError (E2-2-1)
    2019-10-08 07:05:34.297 0000000105545840 INFO APPLICATION CUcwaAutoDiscoveryServiceRetrialWrapper.cpp:527 Autodiscovery scheduled retrial timer. Timer 0.000000 seconds
    2019-10-08 07:05:34.297 0000000105545840 INFO APPLICATION CAlertReporter.cpp:64 Alert received! Category 1, Type 201, level 0, error E_ConnectionError (E2-2-1), context '', hasAction=false
    2019-10-08 07:05:34.297 0000000105545840 INFO APPLICATION CTransportRequestRetrialQueue.cpp:731 Response received for req. GET-AuthenticatedUserGetRequest (0x0x109b4eff0); Stopping resend timer.
    2019-10-08 07:05:34.297 0000000105545840 INFO UI SFBUIAlertMapper.mm:35 Mapping error code = 0x22020001, context = , type = 201
    2019-10-08 07:05:34.297 0000000105545840 INFO UI SFBUIAlertMapper.mm:2003 Mapped error message is 'We can’t connect to the server. Check your network connection, advanced options and try again. 
    2019-10-08 07:05:34.297 0000000105545840 INFO UI SFBTelemetryTracingProvider.mm:20 Telemetry Service Tier:IPATelemetryPrivacyTier2, event:AlertRaised, Attributes:{

    Tuesday, October 8, 2019 8:13 AM

Answers

All replies

  • Hi Pantoskom,

    Does anyone else in IOS 13 has the same problem?

    According to the logs provided, it may be related to mobility.

    You can try to set up the Discovery Address manually in Advanced Options:

    1.Internal discovery

    Address: https://webdir.online.lync.com/Autodiscover/autodiscoverservice.svc/Root

    2.External discovery

    Address: https://webdir.online.lync.com/Autodiscover/autodiscoverservice.svc/Root

    In addition, you could try to navigate to General > Reset > Reset Network Settings for your Iphone.


    Tuesday, October 8, 2019 9:32 AM
    Moderator
  • Hi Sharon,

    I noticed that OAuthTokenIshuer certificate has expired and i renew it today. But for some reason skype for business on our old iphones works and only on new ios13 doesnot work. I will restart also services today and let you know tomorrow if that was the issue

    regards

    pantelis

    Tuesday, October 8, 2019 11:44 AM
  • Hi Pantoskom,

    with iOS 13 apple has changed some certificate requirements.

    trusted Certificates must not be valid for a longer period than 825 days

    https://support.apple.com/en-us/HT210176

    kind regards

    Tuesday, October 8, 2019 1:37 PM
  • Hi Pantoskom,

    Is there any update on this case?

    Please feel free to drop us a note if there is any update.

    Have a nice day!


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, October 11, 2019 2:41 AM
    Moderator
  • I think I have to migrate the certificate server from sha1 to sha2 based on the new ios13 requirements

    regards

    pantos

    Monday, October 14, 2019 1:02 PM
  • Hi Pantoskom,

    Do you know how to actually do it ?
    If you know, can you share the way? 

    Lync certificate sh1 -> sh2

    I also have the same problem.  Thanks you :)

    Monday, October 21, 2019 6:58 AM
  • After upgrading my iPhone to iOS 13, skye for business crashed after opening. I uninstalled it, installed it again (latest version, the same I already had) and problem solved!
    • Edited by Zuritxo Wednesday, October 30, 2019 8:31 PM
    Wednesday, October 30, 2019 8:30 PM
  • Here I will provide a brief summary of this post. This will make answer searching in the forum easier.

     

    <Issue Symptom>:

    After upgrade to IOS 13, user can’t sign in Skype for Business Client.

     

    <(Possible) Cause>:

    It seems related to certificate.

     

    <Solution>:

    IOS 13 has changed some certificate requirements. TLS server certificates must have a validity period of 825 days or fewer.

     

    <Reference Links>:

    https://support.apple.com/en-us/HT210176

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Thursday, October 31, 2019 7:58 AM
    Moderator
  • I havenot done yet it because its not so important for us but you can search on the web and find it. You have to upgrade your root certificate server first to sha2 and reissue certificates

    regards

    pantos

    Tuesday, November 5, 2019 12:31 PM