locked
Autoattendant unable to forward calls to local extensions RRS feed

  • Question

  • I have Lync 2010, single server configuration, setup with Exch 2010 UM. I can make and receive inbound calls just fine.  Local extensions can call the AA and SA. HOwever the Autoattendant is unable to forward calls either outside calls or local extension calls to other extensions.  I am not seeing any errors on exch or the lync systems. Where should I be looking to solve this issue?

    Thanks in Advance.

    John


    John K Scott
    Friday, March 25, 2011 12:08 AM

Answers

All replies

  • I can add some more info to this issue, I have done a couple of network captures on the traffic between the UM server and Lync. Basically it appears the UM server is sending packets to the Lync when it tries to forward the call but the LYnc just doesn't respond.  Maybe I have a listening port issue on the Lync side.  Any advice here would be appreciated.

     

    John


    John K Scott
    Friday, March 25, 2011 1:58 AM
  • Let me add some more info to this issue, my setup is a single server, VM, with 2 NIC's. One on the local lan and the other with a public IPaddress assigned. Calls in and out are working, calls ext to ext work, calls to the AA from the extensions work as does checking voice mail. The only thing not working is any calls transferred from the AA to an extension. This occurs all the time whether the inbound call is from the outside or another extension. Also getting an error on the Exchange server indicating sending an MWI indicator to any user cannot connect.

    From looking at various network captures and the Lync logging tool it appears that there is communication occuring between the Exch and LYnc.

    Any responce would be nice.

    John 

     


    John K Scott
    Sunday, March 27, 2011 4:40 PM
  • I am disappointed that I never got any advice on this issue. So have opened up a MS incident to figure this out. 

     

     


    John K Scott
    Friday, April 1, 2011 4:58 PM
  • John,

    If you have not resolved the issue by now, check you Trunk Configuration. You must have at least one Rule inserted (Match Pattern   ^\+(\d*)$   translated to $1 should be sufficient.)

     

    Drago

     


    http://ocsdude.blogspot.com
    Saturday, April 2, 2011 8:13 PM
  • Hello Drago,

    Glad to get a reply to my posts.  I did insert the trunk rule you provided, but still won't work.  The MS tech has some logs we collected the other day and has referred this to "the engineers". The review he did indicated some sort of permissions issue and the Lync server wasn't accepting the AA calls. I am hoping to have something on this by early this week. Trying to get this system fully up and operational.  Everything else seems to be working fine.

    Any other ideas that you can think of?

    John


    John K Scott
    Saturday, April 2, 2011 8:51 PM
  • The other thing that comes to mind - make sure (Again on Trunk configuration) "Enable Media Bypass" and "Enable refer Support" are both unchecked. If you want, log such attempted transfer (S4 and SIPStack) on Lync server and email it to me - dragomir at gmc.cc.ga.us

    Please send me the .etl files, you will find them in C:\Windows\Tracing

     

    Drago


    http://ocsdude.blogspot.com
    Sunday, April 3, 2011 12:41 AM
  • Ok, the answer to this issue is that Exch 2010 sp1 apparantly has an issue with transferring calls from the Auto Attendant. After a complete reinstall setup of my lab I ran into the same issue, then found this article, made the change and it connected ok internally. 

    http://ucmadeeasy.wordpress.com/2010/08/29/exchange-um-auto-attendant-key-mappings-not-transferring-calls-after-sp1


    John K Scott
    • Marked as answer by John K Scott Thursday, April 14, 2011 9:09 PM
    Thursday, April 14, 2011 8:04 PM