locked
Error: "The request to list features available on the specified server failed" - Can't install Server roles on Server2012r2 RRS feed

  • Question

  • I tried to install the WSUS role and it fails. When I try to again I get the error "The request to list features available on the specified server failed" on the "Select destination server" section on Add Roles and Features Wizard.

    I have rebooted numerous times and still the same issue. I tried the DISM command " DISM /Online /Cleanup-Image /RestoreHealth". It completes and the component corruption was repaired. Still does not work.

    Any suggestions?

    Wednesday, December 2, 2015 1:53 AM

Answers

  • Hi,

    Are you able to install other roles? If this issue only occur on installing WSUS role, please follow the steps below to re-install the WSUS server:

    • Romove WSUS, IIS roles and WID feature.
    • Rename Update Services, inetpub, inetsrv, WID folders.
    • Re-install the WSUS role.

    If this error occurs on installing every roles, the system may be broken, please try to inplace upgrade to recover the system:

    https://support.microsoft.com/en-us/kb/2255099

    If it still doesn't work, re-building the OS may be a simpler way to fix this issue.

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Steven_Lee0510 Monday, December 28, 2015 2:54 PM
    • Marked as answer by Steven_Lee0510 Thursday, January 7, 2016 12:30 PM
    Thursday, December 3, 2015 5:53 AM