Installing SCCM 2012 and unable to connect WSUS to database server on a remote computer RRS feed

  • Question

  • Hell0 all!

    I am installing sql server 2008 r2 but I have encountered the followig error message on the WSUW wizard:

    Failed to connect to SQL server


    [DBNETLIB][ConnectionOpen (ParseConnect Params().]Invalid connection

    Click back to try another database configuration

    I changed authentication on the DB properties>Security> changed server authentication from windows Authen mode to SQL server and
    windows authenticaiton but still cant connect my WSUS server to the sql server. This is my first time installing SQL and I did not pay attention to the instance name so I didnt know that I would have to recall it later. I am thinking its mssqlserver or MSSQL10_50.MSSQLSERVER. So when I try to connect the WSUS server to the SQL server in the WSUS wizard i use the name od the sql server \ instance name   in my case  vm-sql-sccm\mssqlserver and I tried vm-sql-sccm\MSSQL10_50.MSSQLSERVER

    Other actions performed:

    - I added to the WSUS server to the local admin group on the SQL server itself
    - I was unable to ping the sql server from the WSUS server so I disabled the firewall and was thenable to ping but i still cannot
      connect the WSUS server to the SQL server.

    Also, I chose to install sql on a seperate vm and sccm/wsus on another vm. Since I am practicing in anticiption of a migration from SCCM 2007 to SCCM 2012 I wanted to simulate an enterprise enviorment as much as possible.

    - I created an Inbound rule on the firewall on the sql server to open port 1433.
    - When I could not ping between the two vms i disabled the firewall on both, restarted the vms and then I was able to ping but still unable to connect wsus to sql
    - WSUS and SQL are on two separete vms
    - I am using WSUS 3.0 and sql server 2008r2.
    - i am able to ping the SQL server from the WSUS server and also connect via remote desktop
    Side: During the install of sql on the screen Server configuration where you would configure the Service accounts I think I may have screwed up here
      It seems that this is an authentication issue.

    Nothing seems to be resolving the problem

    Please help         

    Sunday, November 18, 2012 2:24 PM


All replies