none
strange keyboard problem on a Sony VAIO laptop RRS feed

  • Question

  • I have a Sony VAIO laptop VPCEA4S1E running Windows 7 Home Premium (64bits).

    Since a couple of days I have a strange keyboard problem: some keys (1, 3, 5, 7, 8, 9, p, Backspace, F1, F3, F5, F7, F8, F10, F12) are not working as expected.

    I have installed the tool ShowOff to display every keystroke.

    Pressing the following keys results in some different (series of)keystrokes:

    1 -> F1 1 F1
    3 -> F3 3 F3
    5 -> F5 5 F5
    7 -> F7 7 F7
    8 -> F8 8 F8
    9 -> F10 9 F10
    p -> F12 p F12

    Backspace -> Backspace Insert Numpadlk
    F1 -> F1 1 F1
    F3 -> F3 3 F3
    F5 -> F5 5 F5
    F7 -> F7 7 F7
    F8 -> F8 8 F8
    F10 -> F10 9 F10
    F12 -> F12 p F12

    I tried uninstalling/reinstalling the keyboard in device manager.
    I tried booting in safe mode.
    I reinstalled SONY drivers.
    I did a system restore before the day that this problem came up.
    Nothing solves my problem.

    Virtual onscreen keyboard is working fine.

    Hoes anybody any further suggestions? Thanks!

    Wednesday, January 9, 2013 8:41 PM

Answers

  • You have a hardware problem and probably need to have the keyboard replaced.  Suggest you either take it to a computer repair shop to have it checked or contact Sony for assistance.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    • Marked as answer by il_belgium Thursday, January 10, 2013 8:03 PM
    Wednesday, January 9, 2013 9:21 PM
  • Hi


    Since this issue not occurred after using the external USB-keyboard, it is better to contact the manufacturer to change this keyboard.


    Regards,


    Vincent Wang
    TechNet Community Support

    • Marked as answer by il_belgium Saturday, February 2, 2013 4:23 PM
    Friday, January 11, 2013 2:32 AM
    Moderator

All replies

  •  

    Perhaps you have 'NumLock' activated.

    On some laptops this is less obvious than on desktop keyboards.

    
    Wednesday, January 9, 2013 9:10 PM
  • You have a hardware problem and probably need to have the keyboard replaced.  Suggest you either take it to a computer repair shop to have it checked or contact Sony for assistance.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    • Marked as answer by il_belgium Thursday, January 10, 2013 8:03 PM
    Wednesday, January 9, 2013 9:21 PM
  • I have checked this, and `NumLock` is not activated.
    Thursday, January 10, 2013 8:01 PM
  • Thanks for the tip, I will try this suggestion. In the meantime I have installed an external USB-keyboard, which works fine. This means that there is a good chance that I need a replacement of the keyboard.
    Thursday, January 10, 2013 8:05 PM
  • Hi


    Since this issue not occurred after using the external USB-keyboard, it is better to contact the manufacturer to change this keyboard.


    Regards,


    Vincent Wang
    TechNet Community Support

    • Marked as answer by il_belgium Saturday, February 2, 2013 4:23 PM
    Friday, January 11, 2013 2:32 AM
    Moderator
  • Hi all,

    I have contacted Sony Technical Support and they have replaced my keyboard.

    Problem solved!  Thanks all

    Saturday, February 2, 2013 4:25 PM
  • Hi,


    Glad to hear this issue has been solved.


    Regards,


    Vincent Wang
    TechNet Community Support

    Monday, February 4, 2013 1:52 AM
    Moderator
  • hey, I have the same problem too...My alt button is not working, remaining all keys are working properly. How did u contact Sony Tech Support. How much did it cost?

    Tuesday, August 13, 2013 6:26 PM
  • I went to the shop where I bought my Sony. I didn't pay anything, because still under waranty.
    Tuesday, August 13, 2013 7:28 PM
  • i am also facing the same issue>
    it happens after  installation of windows 10. now it isn't resolve the issue.

    i think its software issue plz find out any solution.


    Thursday, September 12, 2019 4:53 AM