locked
Windows Explorer view doesn't open in Windows 7 RRS feed

  • Question

  • We are on MOSS 2007 Standard 64 bit installed on Windows 2008 R2 64 bit. WebDav is disabled in IIS on the server.

    The document libraries do not open when 'Open with Windows Explorer' is clicked from Windows 7 systems.  On the Windows 7 systems we have Web Client service DISABLED because of the workflow issues that got resolved by disabling this service.

    I have found lot of site and articles talking about enabling this service but we can't.

    Please advise a viable and working solution. Thanks in advance.

    Friday, September 7, 2012 8:04 PM

Answers

  • Hi,

    Then if your requirement is to only copy past your documents directly to doc libraries you can use sharepoint designer as well. You can navigate to the document library and can paste your documents on it. 

    I hope this will help you out


    Thanks, Rahul Rashu

    • Marked as answer by Emir Liu Friday, September 14, 2012 2:47 AM
    Wednesday, September 12, 2012 4:15 AM
  • Hi Amod,

    We need these 2 protocols both enabled to use Windows Explorer feature: WebDAV and FPRPC. So we will be unable to use the Windows Explorer when you have WebDAV disabled. And please read this whitepaper for the details.
    http://www.microsoft.com/en-us/download/details.aspx?id=9981

    Workaround is to use other ways/tools to upload the document just as Rashu suggested.

    Thanks & Regards,
    Emir Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tnmff@microsoft.com.


    Emir Liu

    TechNet Community Support

    • Marked as answer by Emir Liu Friday, September 14, 2012 2:46 AM
    Wednesday, September 12, 2012 6:23 AM
  • Hi All,

    Emir is correct you need to enable the Web Client Service on the Windows 7 systems. Also, as a best practice WebDAV should not be enabled on the Servers hosting SharePoint 2007 (Windows 2008 R2 x64) as per KB2171959 http://support.microsoft.com/kb/2171959/en-us.

    I would look into the Workflow issue. As long as the forms are browser based forms and the only reason to be opening the form locally is due to the users having InfoPath installed then you can force the InfoPath form to be rendered as a Webpage.

    InfoPath Form Settings

    In InfoPath Designer make sure your form is browser enabled (Tools ->  Form Options -> Compatibility). The "Design a form that  can be opened in the browser" is checked and selected. After publishing the form to a Forms Library or as a Content Type.

    Forms Library Settings

    • Form Library Settings > Advanced settings .
    • Opening browser-enabled documents  > choose Display as a Web  page. The default setting is to Open in Client Application if it is installed and If it is not installed then the documents will always be displayed as Web pages in the browser

    Applications Settings InfoPath Forms Server

    • In Central Administration > Application Management > InfoPath Forms Services, click Configure InfoPath Forms Services.
    • User Browser-enabled Form Templates, check Render form templates that are browser-enabled by users and Allow users to browser-enable form templates

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.

    • Marked as answer by Emir Liu Friday, September 14, 2012 2:46 AM
    Wednesday, September 12, 2012 10:05 AM

All replies

  • We are on MOSS 2007 Standard 64 bit installed on Windows 2008 R2 64 bit. WebDav is disabled in IIS on the server.

    The document libraries do not open when 'Open with Windows Explorer' is clicked from Windows 7 systems.  On the Windows 7 systems we have Web Client service DISABLED because of the workflow issues that got resolved by disabling this service.

    I have found lot of site and articles talking about enabling this service but we can't.

    Please advise a viable and working solution. Thanks in advance.
    • Merged by Emir Liu Wednesday, September 12, 2012 1:46 AM
    Friday, September 7, 2012 8:05 PM
  • Hi,

    Try mapping your document library as a network drive. It works in the similar way.

    I hope this will help you out.


    Thanks, Rahul Rashu

    Sunday, September 9, 2012 7:28 AM
  • Interesting problem.  What was the Workflow Issue, which was resolved by disabling Web Client service?

    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.

    Sunday, September 9, 2012 5:53 PM
  • It used to error out when an InfoPath form is submitted from Windows 7 systems. It works from Windows XP or Windows 2003 though. To fix that issue we had to disable the Web Client service.
    Tuesday, September 11, 2012 2:36 PM
  • Thanks for the reply Rahul. However, that didn't help either. It gives this error message-

    'The folder you entered does not appear to be valid.  Please choose another.'

    However when I start the Web Client service , it maps fine. The issue remains the same since we can not enable/start this service.

    Tuesday, September 11, 2012 6:57 PM
  • Hi,

    Then if your requirement is to only copy past your documents directly to doc libraries you can use sharepoint designer as well. You can navigate to the document library and can paste your documents on it. 

    I hope this will help you out


    Thanks, Rahul Rashu

    • Marked as answer by Emir Liu Friday, September 14, 2012 2:47 AM
    Wednesday, September 12, 2012 4:15 AM
  • Hi Amod,

    We need these 2 protocols both enabled to use Windows Explorer feature: WebDAV and FPRPC. So we will be unable to use the Windows Explorer when you have WebDAV disabled. And please read this whitepaper for the details.
    http://www.microsoft.com/en-us/download/details.aspx?id=9981

    Workaround is to use other ways/tools to upload the document just as Rashu suggested.

    Thanks & Regards,
    Emir Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tnmff@microsoft.com.


    Emir Liu

    TechNet Community Support

    • Marked as answer by Emir Liu Friday, September 14, 2012 2:46 AM
    Wednesday, September 12, 2012 6:23 AM
  • Hi All,

    Emir is correct you need to enable the Web Client Service on the Windows 7 systems. Also, as a best practice WebDAV should not be enabled on the Servers hosting SharePoint 2007 (Windows 2008 R2 x64) as per KB2171959 http://support.microsoft.com/kb/2171959/en-us.

    I would look into the Workflow issue. As long as the forms are browser based forms and the only reason to be opening the form locally is due to the users having InfoPath installed then you can force the InfoPath form to be rendered as a Webpage.

    InfoPath Form Settings

    In InfoPath Designer make sure your form is browser enabled (Tools ->  Form Options -> Compatibility). The "Design a form that  can be opened in the browser" is checked and selected. After publishing the form to a Forms Library or as a Content Type.

    Forms Library Settings

    • Form Library Settings > Advanced settings .
    • Opening browser-enabled documents  > choose Display as a Web  page. The default setting is to Open in Client Application if it is installed and If it is not installed then the documents will always be displayed as Web pages in the browser

    Applications Settings InfoPath Forms Server

    • In Central Administration > Application Management > InfoPath Forms Services, click Configure InfoPath Forms Services.
    • User Browser-enabled Form Templates, check Render form templates that are browser-enabled by users and Allow users to browser-enable form templates

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.

    • Marked as answer by Emir Liu Friday, September 14, 2012 2:46 AM
    Wednesday, September 12, 2012 10:05 AM