HTML Help Windows 7 and Office 2010 - blank pane with invisible content RRS feed

  • Question

  • Issue: Office 2010 help (F1 or ?) display help window but window appears blank. Also chm files no longer display content.

    I know there is a wealth of information out there and on this site regarding similar issues but none appear relevant to Windows 7 64 bit OS or Office 2010. So before someone advises I read http://support.microsoft.com/kb/896358/en-gb - I have followed all recommendations relevant to 64 bit OS and IE. (Note IE version 10 in use.)  I have spent considerable time restoring and installing various Microsoft recommended fixes (including winhlp32.exe which turns out is not relevant to the problem and now I appear to be stuck with it) nothing appears to work.

    If a help window is opened on any application the help window appears as a blank space, with the exception of table of contents and search info, however, right click on the right hand pane and request view source, it transpires the help content is there you just can't see it. The exact same situation occurs with chm files. Note everything was working fine until recently and I can not see any relevant MS updates which may have caused the problem. I have attempted a work-around by altering the registry in accordance with above referenced article but it does not work. I have also compared the registry settings with another PC and can find no reason for this very annoying and time consuming issue. (Note I have also attempted to reset IE settings in the hope it was a security issue - still no joy.)

    If someone can advise I would greatly appreciate guidance preferably a solution which does not involve winhlp32 which clearly is not the source of the problem.

    To be clear no error messages appear and HTML Help appears to open the appropriate links you just can't see the result in the right hand pane?

    Sunday, July 28, 2013 3:36 PM


All replies

  • I have exactly the same problems as Hutch_62 with ANY program HELP (F1) or ANY *.chm file with Win-7 Pro x64 EN.

    The right help pane stays empty!

    It seems that many people have the same problem.

    I did also the same fixes as mentioned by Hutch_62, but no results up to now.

    I have followed all recommendations by microsoft and other sites like tomshardware or at YT a video about this subject "Can't Read Content in CHM file on WIndows 7" .

    This has cost me several days, but without results.

    If someone can advise I would also greatly appreciate your help. Thanks!

    Sunday, July 28, 2013 10:58 PM
  • Thanks for the contribution HERB205 - I forgot to mention one other point in my original post, which may be important?

    During Windows start-up, if I am quick enough, I can open a CHM file while the start-up process is progressing and view the file without difficulty, which indicates to me that some other setting or software is the cause of the problem. This may however be a distraction from the real issue(s) and it has no bearing of MS Office 2010 HTML Help.

    I have also spent may days trawling support forums for a solution to an apparently simple issue and as I have another PC, with same OS and software, which is up to date I do not believe this is due to a security setting or update?


    Monday, July 29, 2013 11:12 AM
  • Hi,

    From your post, I know that your HTML help and chm file cannot display content properly.

    Regarding current situation, please try following steps to check the issue:

    Step 1: Remove IE temp files:

    How to delete the contents of the Temporary Internet Files folder


    Step 2: Check Windows update and install security updates for IE:

    Install Windows updates in Windows 7


    For .chm issue, please check this:

    Some .CHM files may not render properly on Windows Vista and Windows 7


    If above steps didn’t work, please help to do following test and let me know the results:

    Test in New user account:

    Create a user account


    Test in Safe Mode with network:

    Start your computer in Safe Mode:


    Note: please choose Safe Mode with networking under advanced options screen.

    Hope these could be helpful and look forward to your response.

    Best Regards, StarSprite

    • Marked as answer by Cloud_TS Friday, August 9, 2013 5:30 AM
    Wednesday, July 31, 2013 5:03 AM
  • Many thanks for this response StarSprite, here are the results of your suggestions:

    Step 1: Remove IE temp files:

    IE Temp files removed

    Result: No difference

    Step 2: Check Windows update and install security updates for IE:

    Checked Windows update including any hidden updates (none) noted last update for IE was a cumulative Security update on the 11 of July. Similarly security update for Office 2010 on same date. (May be relevant?)

    PC Up to date – no updates required.

    Result: No difference

    Some .CHM files may not render properly on Windows Vista and Windows 7

    Checked this again for a number of chm files on pc all okay. Note the CHM files in question have been successfully accessed and read numerous occasions e.g., php_enhanced_en.chm

    Result: No difference

    Test in New user account:

    Created new user account and activated Guest account. Opened as if new PC, similarly Office Word 2010 opened as if first install requested updated scenario and file format. Clicked ? and no joy.

    Result: No difference.

    Test in Safe Mode with network capability:

    Started computer in Safe Mode and Windows 7 HTML Help Window opened with all panes containing content. Tested a number of links with success. Opened 3 CHM files all displayed content, tested various links with success.

    Tried MSOffice 2010, as system reported it was unable to verify license in safe mode was unable to verify Office HTML Help.

    Result: Overall conclusion success in safe mode.

    Restarted PC again and logged in to my account and found both HTML Help and CHM files did not display content in results pane. TOC displays fine but no content in right hand pane as originally specified in thread start.

    Hope this helps, Hutch_62

    Wednesday, July 31, 2013 10:33 AM
  • Many thanks for the response StarSprite

    My System: Win Pro 7 x64 EN. Newest updates. McAfee antivirus Plus. Advanced SystemCare 6.3 Pro, IObit. fast SSD, 975CPU, 6GB RAM, Asus MB.

    Almost the same results as Hutch_62 except Save mode. Total Results: No difference.

    Step 1: Removed IE temp files: and default settings.
    Result: No difference

    Step 2: Check Windows update and install security updates for IE:
    PC is daily Up to date.
    Result: No difference

    Step 3: Some .CHM files may not render properly on Windows Vista and Windows 7
    All of my .chm files will show an empty right hand pane.
    My .chm Properties, General, window below the advanced button has NO unlock button.
    Result: No difference

    Step 4: Test in New user account: no time to do so. Maybe later.

    I downloaded the free ExtraCHM   chm reader. This reader gives the same results as WinHlp32.exe. 

    Step 5: Test in Safe Mode with network capability:
    Result: No difference with both applications.
    Probably it is not the application but maybe a security program McAfee or IObit, I don't know.

    Up to now: no difference.
    While Hutch_62 has good results in Save Mode, maybe this can point to a security issue.
    I will test this later after my Holiday and will temporally remove (uninstall) all my security programs and see what happens.
    Thursday, August 1, 2013 5:30 PM
  • Hi,

    From your response, I know that help files can appear without problems.

    In order to narrow down the root cause whether it can be 3<sup>rd</sup> part security program, I suggest we first test this issue in Clean boot mode:

    How to perform a clean boot to troubleshoot a problem in Windows 8, Windows 7, or Windows Vista.


    Note: After clean boot troubleshooting, please follow steps under “How to reset the computer to start as usual after clean boot troubleshooting” in above article.

    Please reply back and let us know if this helps and keep post.

    Kate Li TechNet Community Support

    Monday, August 5, 2013 1:29 AM
  • Dear Kate,

    Thank you very much for your response.

    Before I explain the results of the test you may like to know that Bing Desktop news and weather links also resulted in blank white panes. (As side note for information, I also installed Aptana Studio 3 at the weekend and as it displays HTML via web services, as a result of the problem the application start page and HTML help services also displayed blank white pages/panes, despite actually containing the associated content?)

    Nevertheless, with specific regards to your suggestion. MSConfig took some time to apply the required settings and I was forced to perform a forced restart of the PC, which appeared to resume in “clean boot mode”. (Note: Avast antivirus and other services appeared to be operating as normal.) However HTML help worked fine, as did Bing Desktop links and reading of various CHM files. That said the PC did appear to have difficulty starting applications which took an excessive time to start, if at all. I had to reboot twice each time I did I received a message advising 16bit applications have too many files open please alter the FILES setting in config .sys? (Not at all sure if this is relevant but I am giving you the entire picture in case it points to the source or other potential related issues. If you think increasing the FILES parameter in config.sys would help please advise?)

    Rebooted in safe mode and reset MSConfig back to original settings and on restart for reasons unknown I can now access HTML help and other HTML services such as Bing Desktop, and I can open and read CHM files. I hope this state remains and the problem will not re-occur?

    So many thanks for the suggestion, if you can identify the source of the issue please let me know in case of future problems. I don’t know if this information helps, I am more than willing to assist by conducting further tests if it would help you or provide additional system info if required. If I find anything else that may help I will update this thread.

    Really grateful for the input given the result.




    Monday, August 5, 2013 11:47 AM
  • Hi Lain,

    Since this issue didn’t happen in clean boot mode. It appears that third part software or service can be the root cause.

    I am not sure if you missed some items in resuming PC back from clean boot mode, but that’s can be the cause of your issue. You can determine which one can be the cause by using dichotomy in MSconfig. Checking on half of Non-Microsoft service and restart, determining which half of the services cause the issue and repeating to check half of the problematic half services.

    For detailed steps, refer to step “How to determine what is causing the problem by performing a clean boot” in this article:

    How to perform a clean boot to troubleshoot a problem in Windows 8, Windows 7, or Windows Vista.


    Also, starting in safe mode and restarting in normal mode can help PC reload more related service and drivers, that could be the fix sometime.

    I am glad your issue is resolved now. Have a nice day.

    Kate Li

    TechNet Community Support

    Thursday, August 8, 2013 1:25 AM
  • Hi Kate,

    I have examined the various selected items in MSCONFIG and found nothing different. I agree it looks like third party software was the source of the fault, I can only assume the clean boot cleared or reset something somewhere as I am very pleased to advise all appears to be okay after a couple of days use.

    I will keep looking and if I find anything worthy of note I will let you know.


    • Marked as answer by Cloud_TS Friday, August 9, 2013 5:30 AM
    Thursday, August 8, 2013 6:15 PM
  • Hutch_62,

    I just had the same thing happen. They were .CHM files that were in a ZIP file unzipped to a local directory. When I went to view them, the table of contents and search panes had content inside them but the right side content (details?) window was nothing but a white background.

    I right-clicked the .CHM file, went to properties, General, and hit the "Unblock" button as the content came from an external source.

    Not sure if this is your problem or the fix or not, but it worked for me!

    Good luck!

    David Soussan

    David Soussan

    Monday, March 7, 2016 1:29 PM