locked
How to remove "Read Only" attribute on folders RRS feed

  • Question

  • Hi

    I am logged in with my User account which has full control over my folders.<o:p></o:p>

    I have a folder that I tried to add modifications to, however i could not do so because the folder was classified as read only. I have full permissions to this folder. Previously the app that uses this folder could write to it quite happily, but today it fails. <o:p></o:p>

    The 'attributes' for the folder shows a solid square in the read-only box. If I 'un-box' the read-only and apply > ok, when I look at the attributes again the box is still checked.<o:p></o:p>

    So my question is, if it's not (which it shouldn't be) some sort of protected Windows folder, and I have full permissions on the folder (supposedly), why does Windows not respect my wishes, get out of the way, and let me set it to what I want it to be?<o:p></o:p>

    I have tried the following methods to fix this issue, but none of them work:<o:p></o:p>

    • -Adjusting permissions and control, and changing security options<o:p></o:p>
    • -Using a third party application such as "clear read only" to remove the check on the box<o:p></o:p>
    • -Using the "attrib" function on the CMD prompt<o:p></o:p>
    • -Boot Scan for virus/malware that is affecting folder attributes<o:p></o:p>
    • -Running applications and CMD as administrator<o:p></o:p>

     

    I have heard that if using a NTFS harddrive, then all folders will be automatically “Read Only” and that it is impossible to change that attribute. I find this hard to believe, as all folders should have some way of being modified, regardless of what HDD I’m using. I obviously cannot change to FAT32, so how else can I get my folders to get rid of this ridiculous error!

    <o:p>I have also noticed that this problem is very common amongst Windows users. If this problem has been around for a while, how is it possible that no solution has presented itself. Regardless, we need a solution to it, because i can't do the things i need to while the Read Only attribute remains a constant on my folders. I thought it may be a virus, but my avast anti-virus did not pick up any infected areas when the scan was done. I have searched the internet, and no "fix" has solved this issue. The only fix i have not found is a reg edit that could completely remove this read only attribute from all folders. Though i feel this is not neccesary, as i only need the attribute to be removed from certain folders. Please kindly assist me with this issue, hopefully it will help many others too...</o:p>

    Many thanks.

    Monday, January 20, 2014 8:03 PM

Answers

All replies

  • All NTFS folders in a windows environment do show as read only. That's not generally an issue. What application is using to write data? What is the path to the folder - does it live in a protected folder of its own. Is there a file inside the folder that it is trying to read or write. What account is used? What errors do you get?
    Monday, January 20, 2014 8:26 PM
  • Have you taken ownership of the folder? Please first take ownership of the folder, then change the security options

    Take Ownership of a File or Folder

    http://technet.microsoft.com/en-us/library/cc753659.aspx

    If you have already did this, then run a scan with this tool,

    Malicious Software Removal Tool

    http://www.microsoft.com/en-in/download/malicious-software-removal-tool-details.aspx

    or copy this folder to another location, test again.

    Regards


    Yolanda
    TechNet Community Support

    • Marked as answer by Roger Lu Wednesday, January 29, 2014 1:41 AM
    Wednesday, January 22, 2014 5:17 AM