locked
Changing CN attribute for Offline Address Book RRS feed

  • Question

  • I am trying to run the Get-GlobalAddressList | Update-GlobalAddressList but in turn I get the following error:

    [PS] C:\Windows\system32>Get-GlobalAddressList | Update-GlobalAddressList
    WARNING: The recipient "contoso.local/Microsoft Exchange System Objects/Offline
    Address Book - \/o=Contoso\/cn=addrlists\/cn=oabs\/cn=Default " is invalid and
    could not be updated.

    It turns out that the the CN name has some spaces and I cannot delete the spaces in ADSI edit. The attribute I am trying to change is this:

    Offline Address Book - /o=Contose/cn=addrlists/cn=oabs/cn=Default

    How can I delete the space after the default while the attribute is owned by the SYSTEM and do I need to delete other spaces in the name?

    Any help would be apprciated.

    Thanks,

    Wednesday, April 11, 2012 3:53 PM

Answers

  • I can tell you exactly why you are getting this warning message.

    System folder for Default offline address list  is mail enabled in your exchange organization and thus it has created an object under Microsoft Exchange System object. Because its mail enabled public folder, When you try to update the Global address lists its trying to update this mail enabled public folder as well

    You can either Mail disable this folder by using Public folder management console or

    1. Open up Active directory users and computers

    2. Expand the Domain Partition
    3. Expand Microsoft Exchange System Objects
    4. Remove this mail enabled Public Folder object


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Hasnain Shaikh| My blogs: http://messagingserversupport.com

    • Proposed as answer by Xiu Zhang Thursday, April 12, 2012 8:50 AM
    • Marked as answer by ThatGuy Thursday, April 12, 2012 5:40 PM
    Wednesday, April 11, 2012 11:13 PM