locked
Slow File-copying playing video. RRS feed

  • Question

  • I have a really annoying problem. When copying files either from WHS2003 or from partitions on my computer the speed is normally 40-80 MB/s.

    But the moment I start a video file in WMP either from same harddisk as operation or any other harddrive the speed immediately slows down to between 400KB/s - 1.8 Mb/s.


    This also happens if I start a flash video from youtube. Is this some sort of driver issue with the motherboard or a known 7 64 Ultimate problem?

     

    Edit: All harddrives are connected to intel ICH10 SATA controller.


    Gigabyte GA-X58A-UD3R,i7-930, Corsair XMS3 DDR3 1333MHz 12GB CL9,MSI GeForce GTX 480 1536M, Crucial RealSSD C300 128GB, CORSAIR HX 750W ATX12V 2.2 / EPS12V, SEAGATE BARRACUDA 7200.12 1TB 7200RPM SATA/300 32MB.
    Saturday, November 6, 2010 8:59 PM

Answers

  • You may try to upgrade the network adapter driver. If the issue still occurs, please check if there is any BIOS and hard drive upgrade.

    There are several changes you can made to resolve the issue.

    Disable IPv6:

    How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and Windows Server 2008

    Disable auto-tuning:

    Please refer the steps in the following article.

    Network connectivity fails when you try to use Windows Vista behind a firewall device 

    Disable Remote Differential Compression:

    Please refer:

    Slow Network File Copy issues in Windows 7 caused by Remote Differential Compression

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Disable Task Offload settings. Please refer:

    Slow Network copy and connection drops in Windows 7

    Disable Flow Control:

    1. Click Start, enter “ncpa.cpl”.
    2. Open the “Properties” of the network you are using.
    3. Click "Configure", then "Advanced" tab.
    4. Choose "Flow Control" and disable it.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Wednesday, November 24, 2010 9:36 AM
    Wednesday, November 10, 2010 5:44 AM
  • Problem was fixed by disabling power saving functions for the Gigabit network card. Looks like it activates power saving functions when starting a video file in any player (VLC, Mediaplayer classic, WMP and flash online.)
    Gigabyte GA-X58A-UD3R,i7-930, Corsair XMS3 DDR3 1333MHz 12GB CL9,MSI GeForce GTX 480 1536M, Crucial RealSSD C300 128GB, CORSAIR HX 750W ATX12V 2.2 / EPS12V, 2x SEAGATE BARRACUDA 7200.12 1TB 7200RPM SATA/300 32MB.
    • Marked as answer by Arthur Xie Wednesday, November 24, 2010 9:36 AM
    Saturday, November 20, 2010 11:34 PM

All replies

  • You may try to upgrade the network adapter driver. If the issue still occurs, please check if there is any BIOS and hard drive upgrade.

    There are several changes you can made to resolve the issue.

    Disable IPv6:

    How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and Windows Server 2008

    Disable auto-tuning:

    Please refer the steps in the following article.

    Network connectivity fails when you try to use Windows Vista behind a firewall device 

    Disable Remote Differential Compression:

    Please refer:

    Slow Network File Copy issues in Windows 7 caused by Remote Differential Compression

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Disable Task Offload settings. Please refer:

    Slow Network copy and connection drops in Windows 7

    Disable Flow Control:

    1. Click Start, enter “ncpa.cpl”.
    2. Open the “Properties” of the network you are using.
    3. Click "Configure", then "Advanced" tab.
    4. Choose "Flow Control" and disable it.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Wednesday, November 24, 2010 9:36 AM
    Wednesday, November 10, 2010 5:44 AM
  • Would the 'Multimedia Class Scheduler' service causes this?  (gives top cpu priority to media playing)

     

    Wednesday, November 10, 2010 6:36 PM
  • Problem was fixed by disabling power saving functions for the Gigabit network card. Looks like it activates power saving functions when starting a video file in any player (VLC, Mediaplayer classic, WMP and flash online.)
    Gigabyte GA-X58A-UD3R,i7-930, Corsair XMS3 DDR3 1333MHz 12GB CL9,MSI GeForce GTX 480 1536M, Crucial RealSSD C300 128GB, CORSAIR HX 750W ATX12V 2.2 / EPS12V, 2x SEAGATE BARRACUDA 7200.12 1TB 7200RPM SATA/300 32MB.
    • Marked as answer by Arthur Xie Wednesday, November 24, 2010 9:36 AM
    Saturday, November 20, 2010 11:34 PM