none
"Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)" RRS feed

  • Question

  • Hi,

    I experiance the exact situation described in this hotfix, but I am not able to apply it to my server.

    I do have a server 2008R2 sp1 with Windows 7 sp1 workstation loging with terminal services.

    https://support.microsoft.com/en-us/help/2585233/stop-0x000000ab-session-has-valid-pool-on-exit-error-when-a-client-log

    We have this problem since few day only. Any help?


    Thursday, March 29, 2018 12:20 PM

All replies

  • Me too; have a look at

    KB4089344 and KB4088875

    it's a know issue.


    Thursday, March 29, 2018 4:59 PM
  • To evaluate the BSOD please post logs for troubleshooting.

    Using administrative command prompt copy and paste this whole command:

    Make sure the default language is English so that the logs can be scanned and read.

    https://www.tenforums.com/tutorials/3813-language-add-remove-change-windows-10-a.html

    The command will automatically collect the computer files and place them on the desktop.

    Then use one drive or drop box to place share links into the thread for troubleshooting.

    https://support.office.com/en-us/article/Share-OneDrive-files-and-folders-9fcc2f7d-de0c-4cec-93b0-a82024800c07

    This command will automatically collect these files:  msinfo32, dxdiag, mini dumps, drivers, hosts, install, uninstall, services, startup, event viewer files, etc.

    Open administrative command prompt and copy and paste the whole command:

    copy %SystemRoot%\minidump\*.dmp "%USERPROFILE%\Desktop\"&dxdiag /t %Temp%\dxdiag.txt&copy %Temp%\dxdiag.txt "%USERPROFILE%\Desktop\SFdebugFiles\"&type %SystemRoot%\System32\drivers\etc\hosts >> "%USERPROFILE%\Desktop\hosts.txt"&systeminfo > "%USERPROFILE%\Desktop\systeminfo.txt"&driverquery /v > "%USERPROFILE%\Desktop\drivers.txt" &msinfo32 /nfo "%USERPROFILE%\Desktop\msinfo32.nfo"&wevtutil qe System /f:text > "%USERPROFILE%\Desktop\eventlog.txt"&reg export HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall "%USERPROFILE%\Desktop\uninstall.txt"&reg export "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components" "%USERPROFILE%\Desktop\installed.txt"&net start > "%USERPROFILE%\Desktop\services.txt"&REM wmic startup list full /format:htable >"%USERPROFILE%\Desktop\startup.html"&wmic STARTUP GET Caption, Command, User >"%USERPROFILE%\Desktop\startup.txt"

    There is 1 file for you to find manually:  memory dump file:

    C:\Windows\MEMORY.DMP

    Use file explorer > this PC > local C: drive > right upper corner search enter each of the above to find results.

    Sometimes the dxdiag file needs to be found and saved manually:  In the left lower corner search type:  dxdiag > When the DirectX Diagnostic Tool opens click on the next page button so that each tab is opened > click on save all information > save to desktop > post one drive or drop box share link into the thread

    Please remember to mark the replies as answers if they help.


    Thursday, March 29, 2018 6:05 PM
  • Hi,

    As you had mentioned that problem happens recently, please open PowerShell, and type “get-hotfix” to list all installed update/hotfix.

    Then, based on the installation time, please try to manually un-install the update/hotfix which has been installed just before problem happened. Then, re-start system and confirm that if problem happens again.

    If un-install specific update is helpful, please just hide such update and wait to next mouth update rollup. 

    You can use below command to un-install specific update:
    Wusa /uninstall /kb:<kb number>

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 30, 2018 6:50 AM
    Moderator
  • Microsoft has an update dated March 29, 2018 that may fix the problem:

    https://support.microsoft.com/en-us/help/4099467/stop-error-0xab-when-you-log-off-a-windows-7-sp1-or-windows-server-200 

    Please post results into the thread so we know the outcome. 

    Friday, March 30, 2018 9:15 AM
  • Thanks, I hit you back on April 3 PM with results. I am 99% sure it will fix the problem.
    Friday, March 30, 2018 12:30 PM
  • Hi,

    Please click “Mark as answer” if any of above reply is helpful. It would make this reply to the top and easier to be found for other people who has the similar problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 2, 2018 10:43 AM
    Moderator
  • Hi,

    Is there any update?

    Please click “Mark as answer” if the reply is helpful. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 4, 2018 1:47 AM
    Moderator
  • There looks to be a patch for this per KB4099467

    Wednesday, April 4, 2018 5:33 PM
  • The patch is not working. The problem still exists.
    Monday, April 16, 2018 5:39 PM
  • To add to this point further, if you apply KB4099467, it might actually cause the problem.

    April's patches (both Security-Only and the full rollup patch) cause this problem also.

    Tuesday, April 17, 2018 2:38 PM
  • i have got the exact same problem on 4 of my terminal servers.   uninstalling all april updates only fixed 3 of them.   i am proceeding to uninstall all updates from march also now to see if it fixes this issue.    is there any word yet on what is the exact KB thats causing this??
    Tuesday, April 17, 2018 9:14 PM
  • Thanks Microsoft, for a lot of work because your shit update policy!

    What KB is now the problem for BSOD?!KB 4099467 didnt help, March updates are deinstalled!

    Thursday, April 19, 2018 11:13 AM
  • Would be interesting to see, which anti-virus is installed on your servers and if it is a farm or standalone host.

    My environment uses Sophos and is a farm with 4 session hosts.

    Friday, April 27, 2018 8:40 AM
  • Here the same problem, also using Sophos.

    Wednesday, May 2, 2018 1:11 PM