none
Creating receive connector on exchnage 2013 for Oracle EBS not working

    Question

  • Hi All,

    I wanted to configure a receive connector for company's EBS which uses IMAP ,i am aware exchnage 2013 uses only secured connection and it will work on imaps ,i created the connector and set the below permission but its not working.

    i get the below error when i do telnet form the server

    Regards

    JAck

     


    TechGUy,System Administrator.

    Sunday, October 23, 2016 4:33 PM

Answers

  • The Exchange server will not receive mail using IMAP because IMAP is a client mail retrieval protocol, not a transport protocol.  That is, IMAP allows clients to pull mail from Exchange mailboxes.  You can't send mail using IMAP.  If the Oracle server uses IMAP, I believe it will be to retrieve mail from a mailbox on your server, not to send mail to it.

    A receive connector will use SMTP.  If you assign port 995 to a receive connector, it will allow mail to be sent to the Exchange server using SMTP over port 995, not IMAP.

    I suspect you're going to need to create a new receive connector, and it's best to do this with PowerShell.  You're going to want to configure it with:

    • Bindings set to port 25.
    • RemoteIPRanges set to the IP address the Oracle EBS server uses to send SMTP.
    • PermissionGroups set to AnonymousUsers

    Then you'll need to configure the Oracle EBS to send mail to the IP address of the Exchange server.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!


    Sunday, October 23, 2016 5:00 PM
    Moderator

All replies

  • The Exchange server will not receive mail using IMAP because IMAP is a client mail retrieval protocol, not a transport protocol.  That is, IMAP allows clients to pull mail from Exchange mailboxes.  You can't send mail using IMAP.  If the Oracle server uses IMAP, I believe it will be to retrieve mail from a mailbox on your server, not to send mail to it.

    A receive connector will use SMTP.  If you assign port 995 to a receive connector, it will allow mail to be sent to the Exchange server using SMTP over port 995, not IMAP.

    I suspect you're going to need to create a new receive connector, and it's best to do this with PowerShell.  You're going to want to configure it with:

    • Bindings set to port 25.
    • RemoteIPRanges set to the IP address the Oracle EBS server uses to send SMTP.
    • PermissionGroups set to AnonymousUsers

    Then you'll need to configure the Oracle EBS to send mail to the IP address of the Exchange server.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!


    Sunday, October 23, 2016 5:00 PM
    Moderator
  • Thanks Ed,

    will try this out and update you.


    TechGUy,System Administrator.

    Sunday, October 23, 2016 5:02 PM
  • Hi Ed,

    The emails would be authenticated emails sent from an specific exchnage mailbox ,do i still need to check AnonymousUsers ,and what authentication needs to be selected form the below option.


    TechGUy,System Administrator.

    Monday, October 24, 2016 9:27 AM
  • Yes That is correct ..


    Mihir Nayak If a post is helpful, please take a second to vote


    Monday, October 24, 2016 9:46 AM
  • I made the connector as below but it does not seems to be working is there any mistake in this configuration

    Regards

    Jack


    TechGUy,System Administrator.

    Monday, October 24, 2016 5:06 PM
  • You have more Authentication and Permission groups than you need for an anonymous connection, but that isn't your problem.

    Does Oracle EBS authenticate?  Do you know how it's trying to connect?  You should find that information out before futzing around with connectors any further.

    You can up the logging on the new connector and on Default Frontend to Verbose and then look at the protocol log to see if the connection is coming in.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Tuesday, October 25, 2016 8:05 PM
    Moderator