locked
DCom and Com+ issues RRS feed

  • Question

  • This has been a comedy of errors - I don't know if they all tie in, but I'll start from the beginning all the same;

    My first issue arose when I had problems with windows installer. Certain applications use the installer applet fine, and some fail (for instance, running patches for games like singularity as a .msi file or phsyx patch will call up the error: 'windows installer service could not be accessed. Please contact your support personnel to verify it is properly registered and enabled).

    After doing some digging through forums and playing around with the windows installer service I found a forum post suggesting I look into access permissions, authentication level and impersonation level in DCom.

    So I fire up Dcomcnfg and have a peek inside - lo and behold, 'Enable Distributed COM on this computer' was unchecked. So I try and check the box and set the impersonation levels and authentication levels, but the drop downs don't have any selectable options available. Clicking apply causes mmc to crash, and clicking default protocols causes mmc to crash. Trying to expand COM+ Applications gives the error 8004E00F - COM+ was unable to communicate to the Microsoft Distributed Transaction Coordinator.

    I dug a bit deeper on the forums and tried to play around with MSDTC, uninstalling, deleting reg keys, reinstalling, I tried to stop the service, delete the msdtc.log file and restart it, resetting the log file as I go and nothing seems to make any difference. MSDTC seems to startup fine and run fine from what I can see - I don't think that's the problem at this point.

    From some of the posts I've read my suspicion is that there is an issue with account/group permissions somewhere down the line, but I'm not well versed enough with the security policies to know where I should be looking.

    Regardless of if this will fix the windows installer issue or not, something is definitely wrong with the dcom/com+ setup on my machine, so I'd like to fix that first. If anyone has any ideas, thoughts, etc on this issue I'd be grateful.

     

     Edit: Almost forgot; I'm on a Vista Extreme edition 32bit box

     

     

     

    Monday, July 26, 2010 6:30 PM

All replies

  • What's the deal here? do I smell bad? did I offend the pope? did I unknowingly post this in the wrong place and automatically become the forum idiot? after 9 hours, 41 views and not so much as a blanket answer, suggestion or reprimand I'm quite confused;

    But anyway, just a quick update: I did some playing around with security permissions using secedit, and reset the permissions to default. This hasn't seemed to do much, and the problem still persists. There were some errors in the log, but nothing that (at first glance) looks like the cause of this problem. Hopefully that provides a little more info

     

    Tuesday, July 27, 2010 8:16 AM