/skipprereq:silverlight.exe not working RRS feed

  • Question

  • Hi

    After successfully upgrading from SCCM 2012 R2 CU2 to SCCM 1606, I ran a test Server (2016) build using our existing command line install via an MDT Task Sequence as always (no we haven't moved to SCCM OSD yet!) but with updated client source, and all was good - as in, 1606 client installed with no Silverlight (intentionally excluded for security reasons).

    I then upgraded SCCM 1606 to 1610 (using Updates and Servicing), updated the client source in my MDT server again, then built a clean machine...then hit this issue:

    ccmsetup.exe /skipprereq:silverlight.exe is not being honoured!

    Does anyone know if this is a bug with 1610?  I have tried to remove/reinstall the 1610 client multiple times, and I can see the /skipprereq:silverlight.exe command at the start of the log, but it installs Silverlight anyway!  Tried to capitalise it too but no good.

    Usually there is an entry in the log such as "Item 'i386/Silverlight.exe' is excluded by the '/skipprereq:' switch. Ignore it."

    Here is the exact command we use (less the domain FQDN): ccmsetup.exe /skipprereq:silverlight.exe /MP:kbdvcfgmgr01.corp.xxx/retry:1 /noservice SMSMP=KBDVCFGMGR01 FSP=KBDVCFGMGR01 SMSSITECODE=K01 DNSSUFFIX=kbdvcfgmgr01.corp.xxx

    Thanks in advance!


    • Edited by Kiwifulla2 Thursday, December 22, 2016 1:55 AM
    Thursday, December 22, 2016 1:25 AM


All replies