locked
Can't add groups to Exchange room resource calendar/Can't modify calendar permissions via Powershell RRS feed

  • Question

  • Hello all,

    we have the following situation:

    We have a room mailbox which works fine. I set all necessary permission via Outlook (Import room with full access rights, change permissions).

    Now I wanted to change some calendar permissions via Powershell and add a security group. But no. It keeps saying that the box couldn't be found (Only when I try to use the calendar).

    I have a screenshot:

    You can see the ":\Calendar" after the resource name. If I leave it out, the command works, but at the wrong place. Same goes with permission changes on the calender -> Couldn't be found.

    How does it keep saying "couldn't be found"?

    Best regards,
    Phillip

    Monday, August 24, 2015 8:16 AM

Answers

  • Hi,

    One reason of this error is the default folder language setting on this room mailbox. Default folder language is decided by the language of the client used when opening the mailbox for the first time.

    You can use Get-MailboxRegionalConfiguration cmdlet to check and use set-MailboxRegionalConfiguration -language en-US to configure or use OWA to change the regionalsettings.

    Similar thread for reference:

    https://social.technet.microsoft.com/Forums/exchange/en-US/301183be-dc29-4aec-b611-4c1a0016a78b/setmailboxfolderpermission-cant-fond-object?forum=exchange2010

    Best Regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Lynn-Li
    TechNet Community Support


    • Edited by Lynn-Li Tuesday, August 25, 2015 3:16 AM
    • Proposed as answer by Lynn-Li Monday, September 7, 2015 6:53 AM
    • Marked as answer by Lynn-Li Wednesday, September 9, 2015 6:27 AM
    Tuesday, August 25, 2015 3:14 AM

All replies

  • Hi,

    Please check if you are able to view the mailbox by using Get-Mailbox command.

    Also, if you are unable to view the calendar then use the below command first and then try to view the calendar/room mailbox.
    Set-ADServerSettings -ViewEntireForest $true

    At last, please use the below command to provide permission.

    Add-MailboxFolderPermission -Identity CalendarEmailAddress:\Calendar -User GroupEmailAddress -AccessRights "Required Access Rights"

    Monday, August 24, 2015 8:45 AM
  • Hi,

    One reason of this error is the default folder language setting on this room mailbox. Default folder language is decided by the language of the client used when opening the mailbox for the first time.

    You can use Get-MailboxRegionalConfiguration cmdlet to check and use set-MailboxRegionalConfiguration -language en-US to configure or use OWA to change the regionalsettings.

    Similar thread for reference:

    https://social.technet.microsoft.com/Forums/exchange/en-US/301183be-dc29-4aec-b611-4c1a0016a78b/setmailboxfolderpermission-cant-fond-object?forum=exchange2010

    Best Regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Lynn-Li
    TechNet Community Support


    • Edited by Lynn-Li Tuesday, August 25, 2015 3:16 AM
    • Proposed as answer by Lynn-Li Monday, September 7, 2015 6:53 AM
    • Marked as answer by Lynn-Li Wednesday, September 9, 2015 6:27 AM
    Tuesday, August 25, 2015 3:14 AM
  • Dear Somnath,

    Thank you for your answer. Before setting the ADServerSetting, I checked the current status: It is already set to true.

    I tried the Add-Mailbox... cmdlet with the room email-adresses, unsuccessfully.

    To verify this: I tried another mailbox (with email-address) and it worked. I get the feeling that something is broken in these boxes. Should I delete these boxes and create them again?

    I planned to create a "dummy-box", to play around and test.

    Any suggestions?

    Best regards,
    Phillip

    Tuesday, August 25, 2015 2:31 PM
  • Hi,

    This seems that Exchange is unable to get the mailbox while providing permission. Please let me know if you are able to find the mailbox through the command Get-mailbox -identity "EmailAddress". 

    Tuesday, August 25, 2015 3:04 PM
  • Hi Somnath,

    Yes, that worked:

    Wednesday, August 26, 2015 6:09 AM
  • Hi,

    This issue seems to be with the language of the mailbox. Please check the default/user level language settings. Exchange folder is unable to find the calendar folder as the language is something different and hence the folder name be something different.

    Wednesday, August 26, 2015 9:23 AM