none
YouTube increasingly hostile towards IE RRS feed

  • Question

  • A few months (April of '16) ago I had a problem that suddenly popped up where none of our users could render YouTube videos on IE11.  I tried bypassing our proxy, resetting settings, clearing cache / cookies / history, etc.  No joy
    You would get something unhelpful like the following:

    As a workaround, I pushed out a group policy to render youtube.com videos in Flash, instead of HTML5 by enforcing compatibility mode on that domain.  Crisis averted.
    However, now IE gets stuck on the following message, whereas in the past this would flash briefly before proceeding to the video.


    So I have now unenforced this group policy and went back to HTML5.  We still get the generic error message.  However, if users just refresh the page and wait 5 seconds the video will eventually play.  I'm getting more and more people on Win 10 / Edge and Edge doesn't have this issue as far as I can tell.  However, certain websites (I'm looking at you government websites) still require IE.  Anyone else experiencing this? 

    Monday, August 1, 2016 9:29 PM

Answers

  • Hallo @ all,

    there is a workaround for this problem:

    - navigate to a 1080p (or higher) YouTube website,

    - add &nohtml5=1 at the end of the YouTube adress,

    - now you can see the video without restrictions.

    Dont forget to put YouTube.com out of the IE compatibility list, else this trick wont work.

    Sorry for my bad english.

    Black Widowmaker



    Wednesday, August 17, 2016 3:16 AM

All replies

  • I should add.  The issue is on Windows 7 / Internet Explorer 11
    Monday, August 1, 2016 9:31 PM
  • We are hitting the same issue in our work environment - Win 7 - IE 11
    Monday, August 1, 2016 9:38 PM
  • I just kicked one of our machines out of the domain, reset IE settings - now Youtube works.

    I'm guessing they have caught up to HTML5 and the compatibility view settings are no longer needed.

    Monday, August 1, 2016 9:58 PM
  • Interesting.  So if the machine rejoins the domain does YouTube work? I really hope the solution doesn't involve having every machine leave and then rejoin the domain...haha
    Monday, August 1, 2016 10:15 PM
  • Nope, back to the same issue.  We didn't remove the policies that put youtube in compatibility mode though.

    We also manually removed the two registry entries that dictate compat. mode and it still wouldn't work.

    Must be a couple settings working in conjunction to cause this issue.

    Monday, August 1, 2016 10:35 PM
  • I just kicked one of our machines out of the domain, reset IE settings - now Youtube works.

    I'm guessing they have caught up to HTML5 and the compatibility view settings are no longer needed.

    File>Properties menu to find out which IE security zone a domain is mapped to.

    You should not map public domains to the IE Trusted sites or Intranet sites zone....

    By default the domains in the IE Trusted sites and intranet sites, use the legacy x86 versions of Adobe Flash, youtube should be mapped to the Internet zone where x64 flash is loaded...

    Tools>Manage Addons>Show all addons>locate the Adobe Flash (ActiveX) components and make sure both the x86 and x64 versions are installed and enabled.

    The MOST COMMON cause for youtube issues is "ActiveX Filtering". Tools>ActiveX Filtering to toggle AX filtering for the CURRENT SITE.. see Internet Explorer Help (f1).

    To debug website specific issues, on a client machine,

    first Tools>Internet Options>check "Always record developer console messages". Save changes.

    navigate to a web site, then press f12 to display the developer tool,

    the Console tab, now lists warnings and errors for blocked content and activeX filtering.

    on the Emulation tab, you will find which document rendering emulation IE11 is using for that page and how it was established....

    on domain networks, generally only intranet sites will need backward compatibility tweaking.... this should be done with Enterprise Site Mode Lists, not with Group Policy.

    You could use GPO to disable user modification of the trusted and intranet security zone default settings (eg. prevent users from adding sites to the intranet and trusted security zones)

    To help pple answer your questions please include links to any website you are having problems with your questions.. (in the case of youtube, copy and paste the web address from the browser address bar)... this allows us to visit the exact/same web page as you..... https or http....

    You can troubleshoot public websites like yt by running in InPrivate Mode (Tools>InPrivate browsing) where cookies and browser addons (like the google toolbar) are disabled.... generally youtube will log a user straight on (account.google.com) and retrieve their preferences for video display (see the google documentation on the yt html5 test page).

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    Tuesday, August 2, 2016 5:45 AM
  • Looks like our solution will be to remove policies that play youtube in flash and reset IE for users as they call in....until we find a better solution.
    Tuesday, August 2, 2016 3:09 PM
  • Yeah, the problem I'm running into, which prompted the switch to playing in Flash to begin with, is that I still get the "an error occurred.  Please try again later" message with regularity.  I see it most on thin clients connected to Win2008r2.  Which should be basically Windows 7 / IE 11.  The weird thing is I've moved an actual Win7 machine into the same OU (so same policies) and the Win7 computer seems much better.  Just seems like with development stopped on IE11 it's a losing battle.  Compatibility mode was the saving grace that seemed to fix all problems. 
    Tuesday, August 2, 2016 3:24 PM
  • So for example...pull up YouTube video "an error occurred.  Please try again later"

    Click refresh "an error occurred.  Please try again later"...wait 5 seconds...video starts playing

    This has not been a productive week of troubleshooting

    Tuesday, August 2, 2016 3:27 PM
  • Update: I've narrowed down my issue with "an error occured. Please try again later"

    This happens on Remote Desktop Sessions, but if I log in directly from the server console with the same user account, the problem goes away.  So YouTube on IE11 seems to have stopped working on Win2008R2 when connected via remote desktop.  Sheesh

    Tuesday, August 2, 2016 5:26 PM
  • For those interested:

    My final solution was to install Chrome on my remote desktop servers so that users can view YouTube (argh). I used the group policy admx files to restrict settings as needed

    Tuesday, August 2, 2016 7:10 PM
  • Hi sallenk,

    According to your description, I suggest that we could try use the Compatibility mode. Also we could run Enterprise Mode. Please check the link below about the steps.

    http://www.howtogeek.com/184634/how-to-enable-and-use-internet-explorer-11s-enterprise-mode/

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    I hope the link below could helpful to you.

    https://forums.adobe.com/thread/1290412

    Also thank you for your feedback, we would better optimize the IE settings. Please keep updating.

    Hope it will be helpful to you


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 3, 2016 9:50 AM
    Moderator
  • No, compatibility mode is not the answer.  If you check the thread above compatibility mode gets stuck and prompts the user to install Adobe Flash, even if it is installed on the computer (see 2nd screenshot from the original post) and works on other websites that run flash.  I've read similar talk about headphones and there could be some truth to that.  However, even with audio redirected using a regular RDP connection videos don't play.  YouTube certainly doesn't like something about remote desktop into Win2008R2 / IE 11, but I'm moving on at this point rather than trying to figure out why.  Appreciate the suggestions though
    Thursday, August 4, 2016 4:26 PM
  • Hi sallenk,

    Thank you for your clarification. we would better optimize the IE settings. Please keep updating.

    Best regards,

    Carl Fan


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 8, 2016 9:13 AM
    Moderator
  • Hallo @ all,

    there is a workaround for this problem:

    - navigate to a 1080p (or higher) YouTube website,

    - add &nohtml5=1 at the end of the YouTube adress,

    - now you can see the video without restrictions.

    Dont forget to put YouTube.com out of the IE compatibility list, else this trick wont work.

    Sorry for my bad english.

    Black Widowmaker



    Wednesday, August 17, 2016 3:16 AM