none
Excel Web Access WebPart Filter values cached? Shows options not in workbook?

    Question

  • We have an Excel workbook, it is pulling data from a SP List. That part seems to work fine.

    We then setup the Excel workbook to display that data with a few charts and a formatted table with drop down filters.

    One of the filters is Name.

    The person "John Smith" is NO LONGER in the list nor the Excel Workbook.  However, clicking on Name and the drop down then Filter causes a Filter window to popup.

    Inside that it has select all and all the items selected and a search box.

    John Smith still shows up in that and I can select that person, but then after clicking OK no rows come back because the workbook has no rows for John Smith.

    Any thoughts on this issue?

    It seems to be caching the values for Filter somehow...but not sure how to fix this?

    Thanks!

    Wednesday, December 14, 2016 5:34 PM

All replies

  • Hi OneWithQuestions,

    I have done a test in my SharePoint 2013 and I cannot reproduce your issue.

    I do the following:

    1. Export a SharePoint list to excel.
    2. Upload the excel file to a document library in SharePoint.
    3. Create a page and add a Excel Web Access web part to page, connect the Excel Web Access web part to the excel file.
    4. If I delete an item from the excel file, the Excel Web Access web part filter values is updated.

    Try to Refresh All connections:

    If I misunderstanding of you, feel free to let me know.

    Best Regards,

    Lisa Chen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, December 15, 2016 7:53 AM
    Moderator
  • Thank you for the help, I finally tracked down what was causing the issue.

    Inside the Excel sheet itself, I had to right click on the Pivot Table go to Pivot Options and then under the Data tab set it to cache or save NONE of the data items.

    Not sure why interaction with SP caused it to behave that way, but.... at least it is working now.

    Thanks!

    Thursday, December 15, 2016 1:31 PM
  • Hi OneWithQuestion,

    I am glad to hear that the issue is solved.

    Since your issue is solved, Please remember to mark the reply as an answer.

    Have a nice day!

    Best Regards,

    Lisa Chen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, December 19, 2016 11:36 AM
    Moderator