none
Build team shows resources in PWA but not in MS Project RRS feed

  • Question

  • Hi

    When using Build Team in PWA (Project Server 2013 on prem) we can see the resources that the RBS says we should see (those on the same node).

    But when using MS Project, there are no resources available to add in Build Team From Enterprise.

    If we use PWA to add them to the project, then they are there on the team in MS Project to be assigned to tasks.

    I cannot find a permission that would cause this, or understand why PWA and MS Project would have such different functionality. This can only be something to do with categories/RBS though I am sure, as we are not using the standard out of the box groups.

    Any ideas please? I am going nuts!

    Ryan

    Tuesday, August 5, 2014 4:05 PM

Answers

  • Hi,

    Does it happen for all users who can connect to MS Project Pro? What does exactly happen? The "build team from enterprise" option on the resource tab is greyed out? Or when the resource pool dialog box is just empty? As soon as users has the following global permissions, they should be able to add resources they have visibility on in the project team in MS Project Pro:

    • Log on to Project Server from Project Professional
    • Build Team on New Project

    Also ensure that the permissions at the crossing between group and category are correctly set:

    • Build Team On Project
    • View Enterprise Resource Data

    I guess that you ensured that Project Pro was correctly connected to Project Server.

    Also ensure that you don't have any filter in the resource pool dialog box.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Tuesday, August 5, 2014 4:26 PM
    Moderator

All replies

  • Hi,

    Does it happen for all users who can connect to MS Project Pro? What does exactly happen? The "build team from enterprise" option on the resource tab is greyed out? Or when the resource pool dialog box is just empty? As soon as users has the following global permissions, they should be able to add resources they have visibility on in the project team in MS Project Pro:

    • Log on to Project Server from Project Professional
    • Build Team on New Project

    Also ensure that the permissions at the crossing between group and category are correctly set:

    • Build Team On Project
    • View Enterprise Resource Data

    I guess that you ensured that Project Pro was correctly connected to Project Server.

    Also ensure that you don't have any filter in the resource pool dialog box.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Tuesday, August 5, 2014 4:26 PM
    Moderator
  • In MS Project you can see the button and press it to Build Team From enterprise. The box opens up, but on the left where you would normally see resources, it is all grey and there are no resources. It is just empty.

    It must be some permission, but I can't understand why it works in PWA but not in MS Project?

    Tuesday, August 5, 2014 4:33 PM
  • Indeed you should see the same projects and resources in PWA and MS Project Pro.

    When you have more than 1000 resources, oyu'll be prompted with an pre-filter dialog box. If you want to retreive all resources (you can see), you have to click on ok without configuring any pre-filters and neither check the "resource name" checkbox.

    Are you sure you do not have any filters (existing or customized)? Neither availability dates entered?


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Tuesday, August 5, 2014 4:57 PM
    Moderator
  • I'm not getting the pre-filter box, we don't have 1000 resources luckily!

    There is no filter, it shows All resources (No Filter) the same as your example. The Show resource availability checkbox is clear.

    There is one more clue I have been alerted to. When the PM's open the project they get a box popping up telling them they do not have permission to see the following resources, which is the list of resources already on their project. This to me is something to do with the RBS. But these listed resources are there in the project and can be assigned to tasks.

    Also, the user cannot see any resources in Resource Centre, which is by design. But they can add them in PWA.

    Tuesday, August 5, 2014 5:05 PM
  • As an Administrator I can see the resources, so it must be something to do with the way I have set up the group and categories related to the RBS, but I am not sure why they can see them in PWA.
    Tuesday, August 5, 2014 5:08 PM
  • If the resources in question do not respect the rules set with the RBS in the category (for example if they are not in the same branch), then the PM will be prompted with the message you mentionned. Can you check if the PM is allowed to see those resources based on his RBS? It could be possible that an admin (or any user with the appropriate visibitlity) added the resources to the project. Thus those resources are in the project but the PM is not allowed to assign them on tasks. It seems like the PM cannot see any resources based on his RBS/category.

    The issue would rather be on the PWA side where he shouldn't be allowed to see those resources. That being said, can you please check the different views (build team view, resource center views) to ensure there are no filters predefined in the view settings?


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Tuesday, August 5, 2014 5:12 PM
    Moderator
  • In PWA the resources visible are those on the same RBS level.

    There is one group (PM Group with RBS) and there is one category (Projects I Own and Can Edit) associated to this group.

    In that category ALL the resource checkboxes are ticked. So it is Only Include the selected resources (no specific resources are selected) and then below that all the Additionally, dynamically include resources in this category are selected.

    So that would tell me that they should see everything on their node or below?

    Tuesday, August 5, 2014 5:28 PM
  • Indeed if the PM belongs to a group associated to a category which has all resources checkboxes checked, he should see everybody on their node or below. 

    Be also aware that if the PM belongs to multiple groups, ie associated with multiple categories, it might impact his visibitlity causing your issue.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Tuesday, August 5, 2014 5:35 PM
    Moderator
  • One little checkbox. You were right at the beginning Guillaume. It was the View Enterprise Data checkbox.

    So although the error looks like it is RBS related, it is actually saying, and it does if you read it in a particular way, saying that the user can't see the details of those resources. A side effect seems to be you can't see the resource at all.

    Now that that is fixed, the real issue starts. The reason that was not checked was because they don't want anyone to see the details of resources, due to privacy issues.

    BUT I have just tested that and they can see them but not open them.

    Sorted!

    Guillaume, if you are in Atlanta or ever in Brisbane let me know and your dinner is on me!

    Ryan

    Tuesday, August 5, 2014 5:36 PM
  • We finally get it!

    You're more than welcome and I'll take you at your word for the dinner!


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Tuesday, August 5, 2014 6:06 PM
    Moderator