none
An unknown error has occurred; while managing users, permissions, security groups & security categories. RRS feed

  • Question

  • Hello,

    I'm receiving "an unknown error has occurred" message, while trying to manage users / groups / permissions and even if I want to access Enterprise Project Types page.

    My Permissions:

    I am member of Administrators, Portfolio Managers, Project Managers and Team Members. No security category is assigned to me individually, I'm associated with my respective groups' categories.

    Kindly suggest if there are any recommendations.

    Thanks in Advance!

     


    Asif Allauddin, MBA, PMP
    Friday, August 19, 2011 1:51 PM

All replies

  • Asif,

    It is difficult to diagnose the error with this information. You will need to pull up the ULS Logs for more specific error using the correlation ID given in this 'Unexpected Error' message. That would probably give us some clue.


    Prasanna Adavi, PMP, MCTS http://thinkepm.blogspot.com
    Friday, August 19, 2011 8:52 PM
    Moderator
  • Asif,

    Edit your user account and remove your account from all other groups except administrator and then try.

    Adding a user to multiple groups can restricts the user to minimum user role based on some configurations.

     

    Faisal Masood – PMP

    www.FaisalMasood.com | www.Softvative.com | www.epmadmin.com

    Blog | Twitter | YouTube 

    Monday, August 22, 2011 10:02 PM
  • Hi Faisal,

    Thanks for the suggestion but I'm getting same error message when I try to remove my name from other groups.

    Thanks


    Asif Allauddin, MBA, PMP
    Tuesday, August 23, 2011 10:19 AM
  • Hi Asif,

    Did you see the same while you remove yourself from other groups & keeping yourself only in out of box Administartors group?
    Also, Would agree with Prasanna's advice to find the exact issue in ULS on server.
    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    Tuesday, August 23, 2011 10:38 AM
  • Asif,

    As other suggested, try to review the ULS logs. Try using this codeplex tool http://sharepointlogviewer.codeplex.com/

    Do you have any other administrator account without membership to all other groups?

    Faisal Masood – PMP

    www.FaisalMasood.com | www.Softvative.com | www.epmadmin.com

    Blog | Twitter | YouTube 

    Tuesday, August 23, 2011 2:23 PM
  • Faisal,

    ULS log is also not reflecting anything about this issue.
    No, I don’t have any administrator account that is not associated with any other group.

    Regards,


    Asif Allauddin, MBA, PMP
    Tuesday, August 23, 2011 4:57 PM
  • Hi Asif,

    There are a number of potential causes of this error and I am suprised that there is nothing showing in the ULS logs when this occurs.  How many servers do you have in your farm?  Did you check all the ULS logs?  Possible problems I have seen relate to unpatched servers, checked-out resources, problems with enterprise custom fields or even calendars.  I don't think it is related to your account but more likely the data that it is trying to save.  When did this start to occur?

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Wednesday, August 24, 2011 3:18 PM
    Owner
  • Hi Guys , and Asif Allauddin

    Look , When you say you get unknown error, this error screen right? if it is, then the best bet is to turn off custom errors and enable the stack trace. this will let you see on the error screen a little more information as to what is going wrong.

    In the web.config for your Web App, find the following lines:-

    <SafeMode MaxControls="200" CallStack="False" DirectFileDependencies="10" TotalFileDependencies="50" AllowPageLevelTrace="false">

    Set CallStack to True

    <customErrors mode="On" />

    Set this to RemoteOnly (some people put Off, but either works)

    So , tell me anything about that and any news. ^^


    Erick Gutiérrez PMI Membership #ID 2089740 MTCS - Microsoft Project Server Managing Projects

    Thursday, February 9, 2012 7:40 PM
  • Asif-

    You acn quickly try to delete your permission from the root site and then again adding your AD account. It might be corrupted by any chance.


    Dev EPM Consultant

    Friday, February 10, 2012 7:40 AM
  • Hello,

    I realize the original post is old, but I received the same error using Project Server 2013.

    After verifying that I had permissions to view the content (as site collection admin), I was able to resolve the problem with an iisreset on the SharePoint server.

    Hope this helps anyone who encounters this issue in the future.

    Jeff

    Wednesday, January 27, 2016 2:19 PM