Steadystate pc's dates and times changing randomly?!?! RRS feed

  • Question

  • Hello,


    Been using steadystate for a year or so now and it's very good apart from one major issue I've had.


    In one of the centres I support, I'll go there and all the computers will have different, seemingly random times. Actually the minutes seem to stick roughly on time but one computer's time will be 20:18, another will be 04:18, another 11:19, another 10:17, another 17:20 etc. Same thing happens with date, they will never be more than a day forward or behind the actual date though.


    I thought I defeated this problem when I went into the bios of all machines a few months ago and set them correctly, I thought that the incorrect bios time was updating windows time. The time and date stayed correct for months!


    Now I'm back with the same problem again, all my dates and times different! So I went into the bioses of a few of them and the bios time is actually incorrect as well, matching the incorrect windows time! What's going on?

    A) Can windows communicate with the bios and set the time?

    B) How can I stop this?

    C)Anyone know what's going on with this? I'm not 100% sure it's related to steadystate but I strongly suspect it is.



    Friday, May 6, 2011 1:41 PM

All replies

  • Hi,


    According to your description, the issue should not related with Windows SteadyState. Windows SteadyState hase not the function to communicate or change BIOS settings.


    That a simple way to determine the issue if related with Windows SteadyState, just remove it and see if the same issue occurs.



    Leo   Huang



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Friday, May 13, 2011 8:32 AM
    • Unmarked as answer by Lazy D Thursday, August 29, 2013 4:35 PM
    Monday, May 9, 2011 1:55 AM
  • Lazy D.

    The same thing always happens to a lot of my public computers when daylight savings time changes. I think it is a steady state problem. Same model Dell staff computers without steady state never have this occur. Surely Windows can communicate with the bios. You can change the time in Windows without having to go into the bios.

    Does anyone else have this problem on Monday mornings after daylight savings time changes? I need a solution because I use  a batch file to run shutdown.exe 5 minutes before closing and when the time is off the computers shut down during the day. I have to touch each pc and correct the time to get this straightened out.


    Wednesday, May 18, 2011 2:09 PM
  • Librarytech, looks like you have exactly the same, or very similar problem to me.


    Leo - I've asked the centre about their other pc's that do not have steadystate and they have reported that those have never had a problem. I'm now 99.9% sure that this problem is related to steadystate.


    The issue of the bios time being wrong is secondary, I do not care what the bios time and date is as long as windows time is correct.

    Your simple solution to determine whether steadystate is causing this problem or not is not so simple. As I explained this problem is occuring in a centre that is used everyday, I cannot simply remove steadystate and let everyone wreck the computers (due to the nature of the IT courses they do, they do actually mess things up) and create hundreds of hours of work for myself, this will not work. As I also mentioned before, on occasion I have had to wait for months for this problem to reoccur, so even if I could remove steadystate I may end up having to wait for months to reproduce the issue which completely unfeasable, by then all pc's will either be blue screening or not booting.


    Does anyone have any other suggestions please, this is becoming a lot of work.

    Thursday, May 19, 2011 10:36 AM
  • Hi,


    There are some generally suggestion you can try to troubleshoot the issue:

    1 Set no restriction to the user

    2 Turn off WDP

    3 Disable schedule updates on Windows SteadyState




    Leo   Huang



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, May 20, 2011 1:27 AM
  • Wow, haha, thanks for your answer.


    So basically disable SteadyState? I mean, you're right, I think that would clear up the problem!


    Seriously, is that what you would suggest as a solution? Why stop there, why not uninstall SteadyState? I'm sure that would get rid of problems related to SteadyState too!


    Incidentally, I'm at the centre in question now that has this date & time problem. They are all fine, it's been a month since my last visit but we'll see what happens after October 30th (daylight Savings).


     In response to your 3 suggestions:


    1. Done, all profiles unlocked, no restrictions.

    2. Can't turn off WDP, that's what I use SteadyState for.

    3. I've done that.


    Friday, June 17, 2011 1:24 PM

    The issue of Windows writing local time to the hardware-clock (bios-battery backup) has caused problems for decades. An exahustive and oft quoted site on the issue is:

    IBM PC Real Time Clock should run in UTC (Universal Time)

    Markus Kuhn, Computer Laboratory, University of Cambridge

    A plea to the developers in charge of the real-time clock driver in Microsoft operating systems.



    The only reason I bring this up is that it has certain reghacks that may help solve your DST issues with SteadyState. May be worth a try...


    If you find a workaround or fix, be sure to post here before June 30, 2011, since Microsoft is probably going to remove the SteadyState forum website on that day. It might be worthwhile to move this discussion to a forum that won't disappear shortly!


    Monday, June 20, 2011 1:14 PM
  • Thanks for your reply, sorry my alerts are not working so only saw it now. I'll go look at that page now and post back if I get anywhere.
    Saturday, July 23, 2011 12:00 PM