none
FSIS post-installation scripts fails in a reinstallation RRS feed

  • Question

  • I was using FSIS and I was having some IMS issues, so I uninstalled it using the documentation steps for FSIS, IMS toolkit and FSIS Designer.

    I tried to install it again but post-installation script is throwing the following error.

     

    Standalone Host STSD-CPA-FSIS : Exception while clearing the key container.

    New-Object : Exception calling ".ctor" with "1" argument(s): "The profile for the user is a temporary profile."
    At C:\Program Files\FAST Search Server 2010 for Internet Sites\Installer\Scripts\Include\CertificateUtils.ps1:199 char:19
    +     $csp = new-object <<<<  System.Security.Cryptography.RSACryptoServiceProvider($cspParams)
        + CategoryInfo          : InvalidOperation: (:) [New-Object], MethodInvocationException
        + FullyQualifiedErrorId : ConstructorInvokedThrowException,Microsoft.PowerShell.Commands.NewObjectCommand

    Property 'PersistKeyInCsp' cannot be found on this object; make sure it exists and is settable.
    At C:\Program Files\FAST Search Server 2010 for Internet Sites\Installer\Scripts\Include\CertificateUtils.ps1:200 char:7
    +     $csp. <<<< PersistKeyInCsp = $false
        + CategoryInfo          : InvalidOperation: (PersistKeyInCsp:String) [], RuntimeException
        + FullyQualifiedErrorId : PropertyNotFound

    You cannot call a method on a null-valued expression.
    At C:\Program Files\FAST Search Server 2010 for Internet Sites\Installer\Scripts\Include\CertificateUtils.ps1:201 char:12
    +     $csp.Clear <<<< ()
        + CategoryInfo          : InvalidOperation: (Clear:String) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull

    Standalone Host STSD-CPA-FSIS : Configuration script FAILED due to an unrecoverable error. See log file C:\Program Files
    \FAST Search Server 2010 for Internet Sites\Installer\Logs\Install 2010-12-17 08-03-35.log for more information.

    Standalone Host STSD-CPA-FSIS : Installation script failed. Rollback starting. Please wait while the changes are being reverted ...

    Standalone Host STSD-CPA-FSIS : Adding custom snap-in: FsisPSSnapIn to current console ...

    Standalone Host STSD-CPA-FSIS : Error while setting ACL to directory: C:\Program Files\FAST Search Server 2010 for Internet Sites\Installer\Logs\

    Standalone Host STSD-CPA-FSIS : Rollback completed.

     

    I tried different installation options by using default security option, using a specific user, cleaning up some registry keys, etc. but the error is always the same.

     

    The script is failing at the following line:

    $csp = new-object System.Security.Cryptography.RSACryptoServiceProvider($cspParams)

     

    Thanks in advance for your help!!

    Iriana

    Friday, December 17, 2010 4:50 PM

All replies

  • Hi Iriana,

     

    It seems that the installer is failing at the point where it tries to set user read and execute access permissions on the FSIS installation directories under  “C:\Program Files\FAST Search Server 2010 for Internet Sites\...”.

     

    After completing the uninstall, did you log off or reboot the server?  Based on yoru results, I am guessing you did not.  This can sometimes leave the permissions in an unexpected state for the C:\Program Files\FAST Search Server 2010 for Internet Sites\ directory tree and also the C:\Users\<your FSIS user> directory tree.  In general, not doing a complete clean-up of the previously installed FSIS components can lead to issues when you get to the step of re-running the post install script in your re-installation.

     

    I would recommend doing is the following steps:

     

    1.       Reboot the server, or at least log out and log back in. 

    -          This should release any checks or holds on directories previously used by FSIS.

    2.       After #1, check to see if the “FSIS Users” and “FSIS Administrators” groups still exist under ‘Local Users and Groups>Groups’.  If they do, delete those groups. 

    -          They will be recreated by the FSIS post install script and can sometimes cause issues if they already exist.

    3.       Delete the FSIS directory structure under, C:\Users\<your FSIS user>\AppData\Local\. 

    -          This directory structure is what gets written out by the FSIS post install script and it can most definitely cause issues trying to overwrite it, if it already exists from a previous install attempt.

    4.       Delete the contents of your –secureStorageDir directory.  Just the contents not the directory itself.

    -          By default(using the flags recommended in the documentation) the post install script will try and create new security certificates when it is run.  If they already exist it will cause errors since they cannot be overwritten.  By design these are not deleted on an uninstall.

     

    Can you follow the above steps for the complete clean-up and then try and run the post install script again?  Assuming it is the same user who originally ran the install script and that account has local admin permissions, I would still expect that they should be able to install FSIS.

    Thanks!

    Rob Vazzana | Microsoft | Enterprise Search Group | Senior Support Engineer |http://www.microsoft.com/enterprisesearch

    Wednesday, December 29, 2010 10:05 PM
    Moderator
  • Thank you Rob!!!  Unfortunally, I can't follow your steps.  FSIS is now running in that server but I used a different windows user, not the same I used to install FSIS the first time.  After creating a new Administrator account, I was able to install FSIS using that account without any problem.

    Thank your for your help!!

    Friday, January 14, 2011 4:53 AM