locked
Move briefing books from ProClarity 6.0 to 6.3 RRS feed

  • Question

  • I have a new installation of ProClarity Analyitcs Server 6.3 on a new clean Windows 2003 server with a new installation of SQL Server 2005 (also on its own new server).  Our old environment included PAS 6.0 with a SQL 2000 back-end.

     

    Can I easily move the briefing books and pages from the old installation to the new installation?

    Tuesday, July 29, 2008 7:43 PM

Answers

All replies

  • Hello ckcampell,

     

    You should be able to restore your SQL 2000 repository onto your SQL 2005 server by performing a basic backup / restore operation.  There are a few caveats you'll want to watch out for regarding your cube migration though.  I have included further information specifically regarding ProClarity and how it handles cube migration in the below links:

     

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3105504&SiteID=17

     

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3115030&SiteID=17

     

    However, to answer your initial inquiry about database migration, you can simply backup / restore the ProClarity_PAS repository onto your 2005 server.  Please let us know if you have further questions.

     

    Amanda Ruffner

    Thursday, July 31, 2008 12:02 AM
  •  

    I was under the impression that the SQL 2000 repository from version 6.0 of the PAS was not compatible with the version 6.3 repository on SQL 2005.  Is that not correct?

     

    If I do as you suggest, will the new 2005 version of the repository be able to run in 90 compatibility mode in SQL 2005 or will it need to be left at 80?

     

    Regarding cube migration, I simply want to move the old 6.0 views over and leave them pointing to the old AS 2000 cubes while views are redeveloped using the new version of ProClarity against the new SSAS 2005 cubes so I don't think cube migration will be an issue.

     

    Thanks for the information,

     

    Chris

    Thursday, July 31, 2008 1:10 AM
  • I did as suggested and we backed up our ProClarity 6.0 PAS repository from SQL Server 2000 and restored it to the SQL Server 2005 instance for ProClarity 6.3 to access it.  Everything looks good with the briefing books and libraries.  The 6.0 client can open the 6.0 views and I am able to still browse my 2005 cubes with the 6.3 client so that all looks good.

     

    However, after the migration, there appears to be a problem with Users in the new Proclarity_PAS database.  All of the ProClarity roles came over but when I try to browse Users in the ProClarity Admin tool I receive the error "User Preferences Error.  XML Document must have a top level element".  Is there a way to fix the users after the transfer or will I need to delete and re-add all users?

     

    Thanks for any help you can offer.

    Tuesday, August 5, 2008 5:47 PM
  • Applying ProClarity Server Hotfix 2115 fixed the User Preferences Error.  Once this was done, all of my users and roles were working.  I can now browse my old ProClarity views against the 2000 cubes as well as publish and browse new views against my 2005 cubes with the 6.3 client.

     

    Tuesday, August 5, 2008 8:33 PM
  • I have the same problem with the User Preferences error after upgrading to 6.3 but i cannot find a hotfix 2115. I urgently need to resolve this so could some kind soul please point me in the right direction?
    Thanks
    Wednesday, April 22, 2009 5:38 PM
  • Hi Rachel,

    The SP2 hotfix is cumulative and includes all previous bits (including 2215):

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=d819745e-987c-468f-bf9c-feebf4a81ec1

    hth,
    Sean
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Rachel J Thursday, April 23, 2009 9:08 AM
    • Marked as answer by Sean_Flanagan Thursday, April 23, 2009 10:46 PM
    Wednesday, April 22, 2009 7:03 PM
  • Thank you so much Sean, SP2 has fixed the problem!
    Thursday, April 23, 2009 9:09 AM