none
Step for deploying Remote Desktop (Predefined) RRS feed

  • Question

  • Hi all,

    Can someone confirm me  that the steps to configure Remote Desktop (Predefined) are the following:

    1) Install UAG 2010 with all updates.

    2) Create an https trunk and assign a certificate.

    3) Install RD Gateway Role on the same server and assign the same certificate used for the trunk.

    4) Create the Portal and the Application "Remote Desktop (Predefined)"

    Did I forget something?

    Thanks!

    Sunday, February 10, 2013 10:01 AM

Answers

  • Hi Amig@. There is no need to install or configure RD Gateway. UAG will do it for you

    Regards


    // Raúl - I love this game

    Sunday, February 10, 2013 8:23 PM
  • Hi Amig@. As you may know,the /console switch was substituted by the /admin switch starting at Vista. The explanation is here http://blogs.msdn.com/b/rds/archive/2007/12/17/changes-to-remote-administration-in-windows-server-2008.aspx

    1) I would try first to diagnose if UAG is not getting the preferences or the problem is with the terminal server itself. Why don't you try with something that can be easily identified like screen mode id:i:1 for window or screen mode id:i:2 for full screen. If that works then go to next step

    2) The same that /console has been substituted by /admin the connect to console:i:1 has been replaced by administrative session:i:1

    Regards


    // Raúl - I love this game

    Wednesday, February 13, 2013 7:55 AM

All replies

  • Hi Amig@. There is no need to install or configure RD Gateway. UAG will do it for you

    Regards


    // Raúl - I love this game

    Sunday, February 10, 2013 8:23 PM
  • Hello RMoros,

    The first time UAG didn't it...so I installed but it didn't works. Now I decide to unistall and try to reinstall. Do you know if I have to uninstall also IIS services?

    Thank you!

    Monday, February 11, 2013 10:12 AM
  • Hi Amig@. The installation will add all the required roles, sub-roles and features. No need to pre-install. Review the installation logs in case there is an error http://technet.microsoft.com/en-us/library/ff607408.aspx

    Regards


    // Raúl - I love this game

    Tuesday, February 12, 2013 9:51 AM
  • Now all it seems that is ok, but I have a problem with the RDP parameters. I had copied the file rd-template with this parameters:

    remoteapplicationmode:i:0
    connect to console:i:1
    displayconnectionbar:i:1
    screen mode id:i:2
    username:s:administrator

    In this folder:

    C:\Program Files\Microsoft Forefront Unified Access Gateway\common\conf\CustomUpdate

    But the UAG don't pass the information to the client. The MAIN parameter I'm trying to make work is "connect to console:i:1" the others are primarily for testing purposes.

    If I connect to a Server 2008 R2 system I do indeed take the console connection, however if I connect to a Server 2003 system, I do noy get the console connection.  Is this by design, or is there a different parameter for Server 2003, or is there just no way to make it happen?

    Thank you again!

    Tuesday, February 12, 2013 5:47 PM
  • Hi Amig@. You have to add the Remote Desktop application to the portal after customizing the rd-template.txt file. UAG reads that file when adding the application to the portal. The settings are incorporated to the definition only once, when defined. So if you need to make changes you have to remove the application from the portal, change the rd-template file and then add the application again. Did you do it in the right order?

    Regards


    // Raúl - I love this game

    Tuesday, February 12, 2013 6:41 PM
  • Now yes! But nothing is change...Do you have any others ideas?

    Thanks!

    Tuesday, February 12, 2013 8:46 PM
  • Hi Amig@. As you may know,the /console switch was substituted by the /admin switch starting at Vista. The explanation is here http://blogs.msdn.com/b/rds/archive/2007/12/17/changes-to-remote-administration-in-windows-server-2008.aspx

    1) I would try first to diagnose if UAG is not getting the preferences or the problem is with the terminal server itself. Why don't you try with something that can be easily identified like screen mode id:i:1 for window or screen mode id:i:2 for full screen. If that works then go to next step

    2) The same that /console has been substituted by /admin the connect to console:i:1 has been replaced by administrative session:i:1

    Regards


    // Raúl - I love this game

    Wednesday, February 13, 2013 7:55 AM
  • Thank you very much!

    With administrative session:i:1 all works fine!

    Regards


    Wednesday, February 13, 2013 2:03 PM
  • Glad to help :)


    // Raúl - I love this game

    Wednesday, February 13, 2013 9:39 PM