none
Sysprep Loop RRS feed

  • Question

  • I have seen this problem listed many times but none with my current situation. On two separate machines I have done a fresh install of Windows 10 then run: "c:\windows\system32\sysprep\sysprep.exe /generalize /oobe /shutdown" (I have also done /reboot and /quit). Sysprep runs fine but on reboot I get

    "The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click "OK" to restart the computer, and then restart the installation."

    When the error displays I can use shift+F10 to get to a command prompt, run regedit and change HKLM\SYSTEM\Setup\Status\ChildCompletion\setup.exe to 3, then reboot and everything works fine but since I am building base images to use for deployment that isn't a palatable solution.

    Any ideas how to fix this? As I said, I have done fresh installs and sysprep has never been run before. There was no power loss and nothing out of the ordinary occurred but every time sysprep jacks it up.

    Thanks in advance for any help.

    Friday, August 18, 2017 7:07 PM

All replies

  • Hi John,

    To my knowledge, change registry value setup.exe from 1 to 3 is the most common way to deal with this error message. Besides this method, other users mentioned that check hard drive cables and reset BIOS settings and format the installation partition could fix problem.

    This error is usually caused by unscheduled reboot on the final stage of Windows installation process, or a corrupt registry hive during Windows upgrade process.

    Your Sysprep command is correct, what I can think of is your test machine’s system, you clean install system, but we need to make sure this iso image which used for clean install is completely healthy and original.

    I suggest to download original iso from Microsoft website, clean install, don’t install any software, sysprep again.

    I search online and find out a similar case, you could refer to it for some ideas

    win 7 sysprep imaged machine stuck in loop computer restarted unexpectedly

    https://www.experts-exchange.com/questions/27701780/win-7-sysprep-imaged-machine-stuck-in-loop-computer-restarted-unexpectedly.html

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Good luck.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 21, 2017 2:16 AM
    Moderator
  • Thank you for your response. The issue was due to having the FOG Project client installed on the machine. It was the only thing I installed after loading the system and would really like it in the image. I removed the client and tried sysprep and, BANG it worked. I will post something on the FOG forum and see if they can help.

    Thanks again for your help.

    Monday, August 21, 2017 6:49 PM
  • Very well, thanks for your sharing, this information an help other user who use FOG Project and want to execute Sysprep.

    Removing FOG Project client software is necessary before Sysprep, otherwise Sysprep will fall into restart loop, valuable information.

    Please mark your reply to close this case.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    Wednesday, August 23, 2017 4:22 AM
    Moderator
  • Were you able to get this resolved in the fog forum, I am having the exact same issue and I use FOG as well and Windows 10 Pro 1903, Any direction would be appreciated, I have been banging my head on the wall trying to figure this out. I had the image working fine in Window 10 pro 1803 . 
    Wednesday, September 11, 2019 11:20 PM