2 problems after updating to windows 8.1


  • I have 2 problems after updating to windows 8.1,

    1. My mouse does not work anymore, I`ve tried deleting the drivers and reinstalling them. But still doenst help the problem. Same goes for my external hardrive, the light goes on, so it`s provided with power but I cant make a connection with it.

    2. When i right-mouse click on for example my recycle bin to empty it. The screen flashes and all the active programs close. I thought i might fix this with and update to my graphics card, but that did`t work either.

    I`m using an:

    Asus notebook, N56V.
    Geforce GT630M
    Intel core I7
    Intel CPU

    Thanks allot in advance!

    Thursday, November 21, 2013 9:49 PM


All replies

  • Update:

    I`ve tried reinstalling the chipset and bios.
    I`ve also tried the troubleshooting tool and its solutions.
    The problems brought up is that the following devices are not working properly:

    Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26
    Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E2D
    USB xHCI - compatible hostcontroller

    If I uninstal these 3 devices and reboot, the problem keeps existing, even when I delete them and reinstal the chipset driver.

    Thursday, November 21, 2013 10:58 PM
  • And now my hotkeys have stopped working aswell...
    I could really use some help guys!
    Thursday, November 21, 2013 11:19 PM
  • Hi,

    According to your description,I suggest you update all drivers to the latest version by Asus website.

    Meanwhile,please update the Host Controller Driver by the following website.

    Keep post.


    Kelvin hsu
    TechNet Community Support

    Monday, November 25, 2013 2:49 PM
  • Hi.

    You should replace the CM_DEVCAP_REMOVABLE flag with the CM_DEVCAP_SURPRISEREMOVALOK for the device capabilities of the Fresco Logic device (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1B73&DEV_1000&SUBSYS_10391043&REV_04\...\capabilities)

    Take a look at your USB3 controller - guess that is a Fresco Logic Controller?

    If so, Microsoft is distributing not just an incompatible USB3 driver for that one in this case - but really, the device capabilities flags seem to be set wrongly for the removale capabilities of the Fresco Logic Device (Fresco Logic device or the Asus latop does not support the CM_DEVCAP_REMOVABLE - taking a look at the ASUS software package - ASUS is removing the  CM_DEVCAP_REMOVABLE flag and replacing that setting with the CM_DEVCAP_SURPRISEREMOVALOK).

    Simply, if set the CM_DEVCAP_REMOVABLE flag it will take down the Intel USB Enhanced Host Controller ... i.e. the yellow bangs.

    So start up regedit this way:

    1) ... goto (Microsoft fast download site, i.e. check and download the program psexec

    2) ... in order to change those protected flags .... psexec -i -d -s c:\windows\regedit.exe (-s starts up regedit with the system account taking advantage of the protected permissions setting of that part of the hierarchy in WinDB/registry)

    3) ... and goto HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1B73&DEV_1000&SUBSYS_10391043&REV_04\...\capabilities and remove CM_DEVCAP_REMOVABLE by setting Capabilities from 0x0000006 to 0x00000082 (ASUS setting: remove CM_DEVCAP_REMOVABLE + add CM_DEVCAP_SURPRISEREMOVALOK ... i.e. ASUS sets CM_DEVCAP_SURPRISEREMOVALOK instead of CM_DEVCAP_REMOVABLE. So ASUS must have tested CM_DEVCAP_SURPRISEREMOVALOK  to work more reliably than CM_DEVCAP_REMOVABLE with the Fresco Logic Controller?).

    #define CM_DEVCAP_EJECTSUPPORTED    (0x00000002)
    #define CM_DEVCAP_REMOVABLE         (0x00000004)
    #define CM_DEVCAP_SURPRISEREMOVALOK (0x00000080)



    Some more history on the reporting of this issue for laptops etc with a pre-Ivy chipset from Intel (i.e. 3rd party USB 3.0 controller - typically Fresco Logic in the Asus case):

    See my post on the my testing of this during the Win8 previews:

    See my post on this issue a few days before that:

    See more people about half a year after that having this kind of problem:

    Tuesday, December 03, 2013 10:33 AM
  • Take a look at my previous post in this thread for more details.

    Microsoft should replace the CM_DEVCAP_REMOVABLE flag with the CM_DEVCAP_SURPRISEREMOVALOK for the device capabilities of the Fresco Logic device ... i.e. 0x00000082 instead of 0x00000006.(HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1B73&DEV_1000&SUBSYS_10391043&REV_04\...\capabilities)

    ASUS found it nessecary to do this. No more yellow bangs.

    During any of the Win8 previews this also happened to make the controller work correctly.

    If not, the Fresco Logic device will for some reason put down the Intel ... USB Enhanced Host Controller with yellow bangs.

    Tuesday, December 03, 2013 11:00 AM
  • Hello, I have a similar problem with my Intel USB 3.0 eXtensible Host Controller -100 (Microsoft) I have an:

    Asus K55A Notebook

    Core i3-3110M

    Intel 7 Series/c216 Chipset

    8 GB DDR 3 Dual Channel (2x4 GB) 1600 MHz

    Samsung 840 250 GB SSD

    Windows 8.1 Pro (x64) RTM 9600 Build

    I have x1 USB 2.0 and x2 USB 3.0... Everything I connect to usb port 1 which is 2.0, shows up under Usb Root HUB (xHCI) The 3.0 controller... And nothing under the USB Enhanced Controller....  All my ports work, but at 2.0 speeds... The other USB Enhanced Controller has an integrated Asus USB2.0 Webcam under it and it works... The send USB EHCI Controller is what shows nothing connected to it only a root hub and generic usb hub... Also I noticed that the 3.0 Controller Hardware ID's are


    And Matching Device ID is: PCI\CC_0C0330... But this is what it show under Location Paths:


    And under capabilities I only have: 00000000 Windows updated to a new driver with a Nov. 2013 date and I can't even reinstall the original 3.0 driver that was installed during Windows clean install...

    Friday, January 24, 2014 1:20 AM
  • I have Asus X750LA. It upgraded to Windows 8.1, but Asus website has drivers only for Windows 8 yet.

    Loss of USB port was caused by USB charger plus (USBChargePlus_Win*_64_VER315), after installation and following restart. Uninstall of this solves the problem.

    Others also suggested to uninstall LiveUpdate of 8.1 to prevent losing ports again:

    • Edited by maria.g Thursday, June 26, 2014 10:42 PM
    Thursday, June 26, 2014 10:36 PM
  • Try something simpler...

    Right click on the Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26

    Select to update driver, then select Browse My Computer to locate driver and select To Manually select driver.

    You will get 2 option with compatible driver

    a. same Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26 and

    b. Standard Enhanced PCI to USB Host Controller. Select this one. Let it finish. It will remove any conflict, will fix all missing USB device not working (mouse etc) and re-install all connected devices to the controller...

    You can try same after all installed to put back specific driver (Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26 ) or leave as is... &

    • Proposed as answer by Spiro R Thursday, December 25, 2014 2:28 PM
    • Edited by Spiro R Thursday, December 25, 2014 3:17 PM
    Thursday, December 25, 2014 2:27 PM
  • Thanks, a lot.It solve my problem after few days 'googling'.

    Thursday, August 27, 2015 2:46 AM