none
Server 2008 and Windows 7 - Disable Search-encrypted indexing and Search- exchange folder indexing

    Question

  • Hello,

    I am trying to disable 'Search-encrypted indexing' and 'Search- exchange folder indexing' on a Windows Server 2008 R2 DC,

    I have been googling and searching forums,

    Any ideas?

    Thanks

    B.

    Thursday, February 05, 2015 3:31 PM

Answers

  • On the Server and Desktops I added the following:

    HKEY_LOCAL_MACHINE
    Subkey: \Software\Policies\Microsoft\Windows\Windows Search\
    Value Name: AllowIndexingEncryptedStoresOrItems
    Type: REG_DWORD
    Value: 0

    HKEY_LOCAL_MACHINE
    Subkey: \Software\Policies\Microsoft\Windows\Windows Search\
    Value Name: PreventIndexingUncachedExchangeFolders
    Type: REG_DWORD
    Value: 1

    Which worked.

    Thanks

    B.

    Monday, February 09, 2015 1:51 PM

All replies

  • Hi B.,

    >>disable 'Search-encrypted indexing'

    By this, do you mean you want to prevent encrypted files from being indexed? If yes, we can try to do this by disabling the following policy setting :

    Computer Configuration\Administrative Templates\Windows Components\Search\Allow indexing of encrypted files

    >>'Search- exchange folder indexing'

    I searched around and found the following article.

    Disable or enable Exchange Search

    https://technet.microsoft.com/en-us/library/aa996416(v=exchg.150).aspx

    If the above article doesn't help, for this question, in order to get better help, it's recommended that we ask for advice in the exchange forum.

    Exchange Server

    https://social.technet.microsoft.com/Forums/office/en-US/home?category=exchangeserver

    Best regards,

    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, February 06, 2015 11:42 AM
    Moderator
  • On the Server and Desktops I added the following:

    HKEY_LOCAL_MACHINE
    Subkey: \Software\Policies\Microsoft\Windows\Windows Search\
    Value Name: AllowIndexingEncryptedStoresOrItems
    Type: REG_DWORD
    Value: 0

    HKEY_LOCAL_MACHINE
    Subkey: \Software\Policies\Microsoft\Windows\Windows Search\
    Value Name: PreventIndexingUncachedExchangeFolders
    Type: REG_DWORD
    Value: 1

    Which worked.

    Thanks

    B.

    Monday, February 09, 2015 1:51 PM