locked
Prepare current Forest Fails - CSAdministrator already exists RRS feed

  • Question

  • Hello and good evening.
    I'm upgrading my 2010 SfB to a 2015 SfB using the side to side migration.
    I have come to the point that I need to prepare my AD.
    Prepare Schema - was already checked as "Complete."
    So I tried to "Prepare Current Forest" - but it has failed with the error message - the object "CSAdministrator already exists."
    I'm in Enterprise admin group and schema admin group, and the Functional level is well above 2003.
    Any of you encountered that?
    Tuesday, August 11, 2020 5:31 PM

Answers

  • I found a Solution.

    Someone change the group name in AD.

    I have changed it back to CSAdministrator and now it's working.

    • Marked as answer by Isar_NS Wednesday, August 12, 2020 7:29 AM
    Wednesday, August 12, 2020 7:29 AM

All replies

  • Hi

    This issue happened when you deployed Skype for Business 2015 server, right?

    Please make sure your Lync 2010 server and Skype for Business 2015 Server are not in the same machine.

    To my knowledge, if you have prepared forest in Lync Server 2010 before, you don’t need to prepare forest again when you deploy Skype for Business 2015. You can try to skip this step and complete the rest of the deployment steps.

    Besides, you can also try to upgrade Lync Server 2010 to Lync Server 2013, then you can create an In-place upgrade plan to upgrade to Skype for Business 2015. For more details, please refer to:

    https://docs.microsoft.com/en-us/skypeforbusiness/plan-your-deployment/upgrade

    This  Skype for Business Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Best Regards,

    Jimmy Yang


    Skype for Business forum will be migrating to a new home on Microsoft Q&A! We invite you to post new questions in the new forum.

    For more information, please refer to the sticky post.

    Wednesday, August 12, 2020 4:52 AM
  • Hey Jimmy, thank you for replying.
    This issue indeed happens when I try to deploy SfB 2015, and it is not on the same server with lync 2010.

    so I can skip the step and try to prepare my domain?  


    • Edited by Isar_NS Wednesday, August 12, 2020 5:25 AM more inforamtion
    Wednesday, August 12, 2020 5:25 AM
  • Hi Isar!

    Yes, you can have a try.

    This  Skype for Business Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Best Regards,

    Jimmy Yang


    Skype for Business forum will be migrating to a new home on Microsoft Q&A! We invite you to post new questions in the new forum.

    For more information, please refer to the sticky post.

    Wednesday, August 12, 2020 5:30 AM
  • I found a Solution.

    Someone change the group name in AD.

    I have changed it back to CSAdministrator and now it's working.

    • Marked as answer by Isar_NS Wednesday, August 12, 2020 7:29 AM
    Wednesday, August 12, 2020 7:29 AM
  • Hi!

    Here I will provide a brief summary of this post. This will make answer searching in the forum easier.

    <Issue Symptom>:

    Customer try to upgrade my Skype for Business 2010 to Skype for Business 2015 and met the following error:"Prepare Current Forest" - but it has failed with the error message - the object "CSAdministrator already exists."

    <Solution>:

    Someone change the group name in AD and changed it back to CsAdministrator

    <Reference Link>:

    https://docs.microsoft.com/en-us/skypeforbusiness/plan-your-deployment/upgrade

    This  Skype for Business Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Best Regards,

    Jimmy Yang


    Skype for Business forum will be migrating to a new home on Microsoft Q&A! We invite you to post new questions in the new forum.

    For more information, please refer to the sticky post.

    Wednesday, August 19, 2020 10:28 AM