locked
Task Scheduler not working!! RRS feed

  • Question

  • I did a fresh install of my Windows 7 x86 Ultimate on my new PC, and one of the many first things i like to do is to setup a few tasks in Task Scheduler, such as the clean ram intervals etc, i like to get those working before i start installing all my backed up files.

    Well, today I was a bit busy and was downloading drivers and other important updates from Windows Update, and so i didn't setup task scheduler first. I did open it and it loaded up the list of tasks fine, but i closed it since i had to restart for windows update, and i haven't managed to setup anything in task scheduler.

    After windows update, i got a bit sidetracked and started installing some of my other backed up files, and then i realized that i forgot to setup task scheduler, so i opened it again and this time it doesn't work anymore, it just shows "Reading Data Failed" under both 'Task Status' and 'Active Tasks'.

    There's no error code or anything so i couldn't find out anything on Google. 

    I ran services.msc and can see that Task Scheduler is running, but when i right click it, all the options such as start, stop, pause, resume and restart are grayed out. I then viewed its properties and all the clickable options in every tab are grayed out as well, so there's definitely something wrong with it.


    I haven't installed anything much btw, i'm now typing this only after 20 minutes since my Windows 7 installation, so i haven't done anything or installed anything to the system, and besides, all my backed up files never caused any conflict with the system either, i've had the same back ups and used them several times already.


    The only apps i've installed are Adobe Flash player, Pop Peeper, Internet Download Manager and a few other apps, none of those makes any changes to the system whatsoever.


    I haven't installed any antiviruses either so they couldn't be conflicting the system, and again, even if i did, those files worked fine for me all the time, i never had this problem.



    In my other systems, i have the exact same setup and same backed up files, and task scheduler works fine, and same with the windows updates, they shouldn't cause any problems either. So right now, i dunno what's the problem.
    Thursday, February 4, 2010 10:45 AM

Answers

All replies

  • Please let us know how you create the task, and if the task is created in other version of windows. It's better to post your deatail task settings, you can also post your task file to the public folder in the SkyDrive for analyzing. Please don't contain any personal information in it.

    As the Task Scheduler service, I would like to tell you that the option is gray by default, as it is running, you have no need to worry about the service.

    In my opinion, you can try to test your issue in a new account.

    Good luck!


    John
    Friday, February 5, 2010 5:29 AM
  • Hi thanks for the reply. As i've said, i have NOT created any tasks yet, so the problem does not lie there.

    I don't actually create any tasks either, i just edit a few tasks that already exists. For example, i use the program CleanRam, and i like to set the ram cleaning interval from the default 30 minutes to 10 minutes, and so i just use task scheduler and find the default task and edit it, but i can't remember what the tasks are called.


    Anyway, i did a sfc /scannow and chkdsk and it didn't solve the problem. And again, I have not created any tasks or edited anything in the first place.
    Friday, February 5, 2010 6:24 AM
  • I still don't know where the tasks come from. Please let us know where did you find the task after installing WIn7, can you collect a screenshot? As you can edit the task before install the Update, you can try system restore to restore your machine before installing the updates.

    After that, please let us now if you can find and edit the task.

    Good luck!
    John
    Monday, February 8, 2010 10:18 AM
  • The tasks come from Task Scheduler.....Click the start button and type "Task Scheduler" in the search box, launch the program and you will see a list of tasks that are ALREADY there. The system clean ram is just one of the many predefined tasks in the list, I DID NOT create any extra ones of my own. And since my problem is that Task Scheduler does not load the list of tasks as it shows the error "Reading Data Failed", that's why i'm asking for help, and also why i can't give you the precise name of the tasks that i'm trying to edit. 

    I can't do a system restore update, because i turned it off straight away after i installed Windows 7, i don't use it, i use Comodo Time Machine instead which is way better, but i did not do a snapshot of my system using it so i can't restore my system either.

    Is there no other way of reinstalling Task Scheduler?
    Monday, February 8, 2010 11:28 AM

  • Hi there,

    It seems that the related register info about Task Scheduler is corrupted and we can consider take the following steps:

    Use REGEDIT and delete all entries under the following key:-

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache]

    Note: You may wish to backup/export that key before deleting.

    Upon reboot, try to open task scheduler again, do you still have the same error message.

    If so, the error may cause by background program conflicts, and I suggest you use Clean Boot as a test, do you have this error in Clean Boot? If the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7
    http://support.microsoft.com/kb/929135

     

    • Proposed as answer by KyleBurnette Wednesday, October 26, 2011 8:45 PM
    Wednesday, February 10, 2010 1:11 AM
  • aww man.....still doesn't work. I tried both methods, nothing changes, i'm still getting the same error.......Just to be more precise, i deleted the registry key "TaskCache" and all its sub-entries, i did make a backup before i delete it.

    Then, i restart and opened task scheduler, same error occurs, so then i setup the clean boot in msconfig (i did this before btw) and when i startup, i can see only the Wifi and Sound icon in the traybar, which means it's working because all my other icons aren't there since i disabled them for using clean boot, and i opened up task scheduler and i get the same error......


    Wednesday, February 10, 2010 10:46 AM
  • Hi,

    Since Task Schedule (taskschd.msc) was based on MMC (mmc.exe), I suggest you try to rebuild it as a test:
    1. Run mmc.exe
    2. File -> Add/Remove snap-in
    3. Select and add “Task Schedule” from the available snap-ins list and click OK to confirm it
    PS: if it request a select, pls use “Local computer”
    4. File -> Save as and save it to your desktop

    Can you access Task Schedule via this new rebuild file?

    If it still not work, can you access other MMC based functions without issue? (e.g. Services.msc, diskmgmt.msc)

    Thursday, February 11, 2010 4:57 AM
  • Hi, it still doesn't work. Here is a screenshot i took. BTW is there an option to add an image so that it shows up in your post?? I've used tons of forums and they all have this option, but since i can't find it anywhere i'll just post the link to it:

    http://www.mediafire.com/imgbnc.php/8dd1087b89abef57d31eb5698deba3465g.jpg


    and services.msc as well as diskmgmt.msc works fine. 
    Thursday, February 11, 2010 5:57 AM

  • It seems that someone got this type of issue fixed by check the following keys

    HKLM\SOFTWARE\MICROSOFT\RPC\INTERNET
    HKLM\SOFTWARE\MICROSOFT\RPC\RPCPROXY

    If you have these keys, remove them and restart, do you still have the same issue now?

     

    Friday, February 12, 2010 7:30 AM
  • hmm both of those keys don't exist in my list, i only see these:

    ClientProtocols
    Extensions
    SecurityService
    Friday, February 12, 2010 11:03 AM

  • I’ve noticed that John has mentioned about New Account, do you have a try?

    Fix a corrupted user profile
    http://windows.microsoft.com/en-US/windows7/Fix-a-corrupted-user-profile

     

    Friday, February 12, 2010 11:23 PM
  • hmm but that means i must create a new account in order to create a new profile, but all the stuff i've installed will have to be reinstalled again on that new account then....that's like formatting my PC, except it's the part where you have to reinstall everything. Most of the stuff i installed were only installed for administrator, which is the only account i have on this PC, i don't use multiple accounts, so the stuff i installed won't be shared or shown if i create a new account...
    Saturday, February 13, 2010 4:28 AM
  • Hi there.

    I also had the problem with Task Scheduler not working. And like you Shadowz1337 I saw the instructions to delete these keys:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\Internet]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\Rpcproxy]

    but when I looked I couldn't find them, only the 3 keys that you listed. Eventually, after a bit of digging, I remembered I had been fidding around with my firewall software, tightening security. So I went to my firewall software (Outpost Firewall Pro 2009) and changed it back to how it was.

    I then went to: 

    Control Panel > Administrative Tools > Services > Task scheduler service > Start

    when I clicked on 'Start' the service now immediately started. Now, Task Scheduler itself worked again.

    The Task Scheduler service depends on the RPC service. When the Task Scheduler service starts at boot time it tries to open a listening port for this RPC service. If it can't do this because a firewall is blocking it or because the RPC service itself is not started or functioning properly--it can't and won't start.

    The point is, if you have installed 3rd party firewall software or have been mucking around with the windows one, this could easily break the Task Scheduler, especially if you don't always know exactly what you are doing (like me!)

    Perhaps:

    a. Try to start the Task Scheduler service manually

    b. Try uninstalling 3rd party firewall (temporarily), or

    c. Restore firewall settings to normal or low security level

    d. Try to start the Task Scheduler service manually again

    This may not be entirely relevant to you, but maybe it'll help someone with this problem ...

    Monday, March 1, 2010 6:57 AM
  • I keep getting a pop up on my screen saying Task Scheduler Engine has stopped working.

    A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

     

     

    It's been off for a week now.....what do i do?

    Thursday, December 23, 2010 3:09 AM
  • i've had this same exact issue to the letter, and there is no fix to be found on the entire world wide web!  i tried a repair install and that didn't even fix it.  very strange. very frustrating.

    • Edited by mrsteve0924 Friday, January 3, 2014 9:55 PM
    Friday, January 3, 2014 9:54 PM
  • The solution I found was to scrap the windows task scheduler and use FreeByte's task scheduler.  It worked the first time I tried it, no hassles and no problems.  
    Tuesday, February 25, 2014 6:37 PM