none
How do I debug this error "Error in Resource Control" RRS feed

  • Question

  • I am using MIM 2016 and it is patched to the latest hotfix roll out. Build 4.3.2266.0

    I have created my AD MA. I now want to create an Inbound/Outbound sync rule to provision to AD.

    When I access the scope tab, I can complete the Metaverse resource type drop down and the External system drop down BUT

    when I try to complete the External System resource type .. it just hangs and doesnt show any options, after furious clicks

    I get a popup saying Error in Resource control. But I can complete sync rules for other MAs, just not the AD MA.

    Event Viewer shows,  as a Warning!

    The portal was unable to complete a request and showed a user the default error page.

    An unhandled exception was caught.

    Check the product diagnostic log file and then check the SharePoint log file.

    So which "product diagnostic log file" should I be looking for?

    The SharePoint log doesnt seem to give any information why this error is shown.

    Friday, August 12, 2016 1:38 PM

Answers

  • Once your AD permissions are fixed, sometimes a refresh of the FIM MA schema is a helpful fixer too.

    Best,

    Jeff Ingalls

    • Marked as answer by HaroldHare Monday, August 22, 2016 7:42 AM
    Monday, August 15, 2016 6:12 PM

All replies

  • Hi,

    Interesting issue. Grasping here, so I apologize in advance. Did this just start after applying the patch? Any recent Windows updates?

    Best,

    Jeff Ingalls

    Saturday, August 13, 2016 11:44 AM
  • Hi

    Try to enter the credentials for the FIM MA in the sync engine. in doing so all informations on external systems will be updated in the portal.

    Monday, August 15, 2016 12:02 PM
  • I set up the AD MA before patching plus initial connectivity tests etc.

    I try to create the NEW sync rule after patching.

    Something now seems odd with the AD MA. Someone has removed a permission on the AD access account. *NOW* I receive the error Replication access denied, error code 8453 which never occurred before on an initial Full Import.

    I suspect that the inability to properly read AD confuses the RCDC about what object types to pick. I wait until I get proper permissions again.

    Monday, August 15, 2016 1:27 PM
  • Once your AD permissions are fixed, sometimes a refresh of the FIM MA schema is a helpful fixer too.

    Best,

    Jeff Ingalls

    • Marked as answer by HaroldHare Monday, August 22, 2016 7:42 AM
    Monday, August 15, 2016 6:12 PM
  • Thank you for your help.

    It seems that the MA itself was the culprit. I created a second AD MA when the correct permissions were granted and the Sync Rule creation had no problems with it.

    The original MA has been deleted and I put this down to "just one of those things".

    Monday, August 22, 2016 7:42 AM