none
IEAK11 msi not doing anything RRS feed

  • Question

  • I created a IEAK11 deployment package with all our corporate settings. It creates an exe and an msi.

    Exe works fine, msi does nothing. It runs, it completes (according to verbose log), but it doesn't modify the system in any way. After restart IE11 is not installed. Running it again just does the same thing.

    I recreated the package so it showed all the dialog boxes and as far as I can tell it comes up with IE installation dialog box, but it disappears and nothing else happens. msiexec keeps running for another 5 mins or so, but nothing else happens.

    I am at a loss. Me and my colleague recreated the package about 5 times so far, from scratch, and the issue is still the same.

    EXE works. MSI does nothing.

    Any help would be appreciated.

    Tuesday, April 29, 2014 5:44 AM

All replies

  • Hi,

    Which version of Internet Explorer is in the target computer? Did any error message appear when you click to run MSI file?

    Please upload the log file to OneDrive, and post the shared link in your next reply.

    The log file could be found in the following path:

    C:\Windows\IE11_main


    Karen Hu
    TechNet Community Support

    Wednesday, April 30, 2014 2:59 AM
    Moderator
  • There is no C:\Windows\IE11_main folder created when I run the MSI.

    I tried it on PCs with 8, 9 and 10. They all fail to update.

    Wednesday, April 30, 2014 4:14 AM
  • After trying once again I get this in the ie11_main log.

    01:03.103: INFO:    Service pack name:  Service Pack 1
    01:03.212: INFO:    Version Check for (KB2834140) of C:\Windows\System32\d3d11.dll: 6.1.7601.17514 >= 6.2.9200.16570 (False)
    01:03.212: WARNING: Checking version for C:\Windows\System32\api-ms-win-downlevel-user32-l1-1-0.dll.  The file does not exist.
    01:03.212: INFO:    Version Check for (KB2639308) of C:\Windows\System32\Ntoskrnl.exe: 6.1.7601.18229 >= 6.1.7601.17727 (True)
    01:03.228: INFO:    Version Check for (KB2533623) of C:\Windows\System32\api-ms-win-security-base-l1-1-0.dll: 6.1.7601.18229 >= 6.1.7601.17617 (True)
    01:03.228: INFO:    Version Check for (KB2731771) of C:\Windows\System32\conhost.exe: 6.1.7601.18229 >= 6.1.7601.17888 (True)
    01:03.228: INFO:    Checking for correct version of C:\Windows\Fonts\segoeui.ttf.
    01:03.243: INFO:    Version Check for (KB2786081) of C:\Windows\System32\taskhost.exe: 6.1.7601.18010 >= 6.1.7601.18010 (True)
    01:03.290: INFO:    Version Check for (KB2888049) of C:\Windows\System32\drivers\tcpip.sys: 6.1.7601.18203 >= 6.1.7601.18254 (False)
    01:03.337: INFO:    Version Check for (KB2882822) of C:\Windows\System32\tdh.dll: 6.1.7600.16385 >= 6.1.7601.18247 (False)
    01:06.098: INFO:    Download for KB2834140 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=303935 -> KB2834140_amd64.MSU.
    01:06.114: INFO:    Download for KB2670838 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=272391 -> KB2670838_amd64.CAB.
    01:06.114: INFO:    Download for KB2729094 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=258385 -> KB2729094_amd64.MSU.
    01:06.114: INFO:    Download for KB2888049 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=324542 -> KB2888049_amd64.MSU.
    01:06.114: INFO:    Download for KB2882822 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=324541 -> KB2882822_amd64.MSU.
    01:06.129: INFO:    Waiting for 5 prerequisite downloads.
    03:06.406: INFO:    Prerequisite download processes have completed. Starting Installation of 5 prerequisites.
    03:06.406: ERROR:   Error downloading prerequisite file (KB2834140): 0x800c0005 (2148270085)
    03:06.437: INFO:    PauseOrResumeAUThread: Successfully resumed Automatic Updates.
    03:06.437: INFO:    Setup exit code: 0x00009C47 (40007) - Required updates failed to download.
    03:06.453: INFO:    Cleaning up temporary files in: C:\Windows\TEMP\IE1D838.tmp
    03:06.468: INFO:    Unable to remove directory C:\Windows\TEMP\IE1D838.tmp, marking for deletion on reboot.
    03:06.468: INFO:    Released Internet Explorer Installer Mutex

    Problem is, that prereq it fails to download is not applicable to my computer when installed manually.

    Wednesday, April 30, 2014 4:36 AM
  • 03:06.406: ERROR:   Error downloading prerequisite file (KB2834140): 0x800c0005 (2148270085)

    Problem is, that prereq it fails to download is not applicable to my computer when installed manually.

    Why?  What version of  D3d11.dll  do you have?   Try finding all instances of it, since it might be the  WinSxS  version which is the problem, e.g. not the one that you have loaded.

    I actually tried helping someone check this module once...

    http://answers.microsoft.com/en-us/ie/forum/ie11-windows_7/internet-explorer-11-windows-7-update-failure/dcc4cee0-52b2-42b3-aa1f-36dedbc79f96?page=2



    Robert Aldwinckle
    ---

    Wednesday, April 30, 2014 9:34 PM
    Answerer
  • 4 instances of D3d11.dll present

    C:\Windows\System32\ - 6.1.7601.17514 - 769KB

    C:\Windows\winsxs\amd64_microsoft_windows-directx-direct3d11**** - 6.1.7601.17514 - 769KB

    C:\Windows\SysWOW64\ - 6.1.7601.17514 - 510KB

    C:\Windows\winsxs\x86_microsoft_windows-directx-direct3d11**** - 6.1.7601.17514 - 510KB

    Why would that be an issue anyway if EXE installed IE11 fine?

    Wednesday, April 30, 2014 11:54 PM
  • Why would that be an issue anyway if EXE installed IE11 fine?

    Who knows but obviously you need to fix it to get past that check.  What else do you have that is out-of-date?  MBSA might give you some clues.  We once could get exactly the answer from HFNetChk (from Shavlik) but later versions of MBSA made that option unavailable.  I don't know if anyone has tried creating an alternative, e.g. exploiting the .xml file that MBSA uses.  It sure would be useful.  I imagine it could be implemented as a Powershell script.   ; )



    Robert Aldwinckle
    ---

    Thursday, May 1, 2014 11:07 AM
    Answerer
  • Fix what? There is nothing to fix on the PCs themselves because the EXE install works. There is something broken in the IEAK11 or the MSI it creates.
    Thursday, May 1, 2014 9:44 PM
  • Any ideas?
    Wednesday, May 14, 2014 1:16 AM
  • Bump
    Friday, August 1, 2014 5:18 AM
  • Hi,

    According to your log file, the cause is that the prerequisite doesn't meet.

    Please check and install all available Windows Update. And then recreate the Windows Installer package to reinstall for test.


    Karen Hu
    TechNet Community Support

    Wednesday, August 6, 2014 2:16 AM
    Moderator
  • I have the same issue. I've managed to install IE11 no problems using the exe, but when I packaged the msi and deployed via sccm the logs tell me it worked, but in reality nothing has happened on the machine

    00:00.000: ====================================================================
    00:00.000: Started: 2014/08/06 (Y/M/D) 12:37:22.735 (local)
    00:00.000: Time Format in this log: MM:ss.mmm (minutes:seconds.milliseconds)
    00:00.000: Command line: C:\Windows\Temp\IXP000.TMP\IE-REDIST.exe  /ieak-full:C:\Windows\Temp\IXP000.TMP\ /no-default /quiet /norestart
    00:00.000: INFO:    Setup installer for Internet Explorer: 11.0.9600.16428
    00:00.000: INFO:    Previous version of Internet Explorer: 9.0.8112.16555
    00:00.000: INFO:    Checking if iexplore.exe's current version is between 11.0.9600.0...
    00:00.000: INFO:    ...and 11.1.0.0...
    00:00.000: INFO:    Maximum version on which to run IEAK branding is: 11.1.0.0...
    00:00.000: INFO:    iexplore.exe version check success. Install can proceed.
    00:00.000: INFO:    Operating System: Windows Workstation: 6.1.7601 (Service Pack 1)
    00:00.047: INFO:    IEAKPRXY>>[BEGIN] Call to IEAKInitialize()
    00:00.047: INFO:    IEAKPRXY>>IEAK_DLL: Date:8/6/2014 (M/D/Y) Time:12:37:22

    00:00.047: INFO:    IEAKPRXY>>IEAK_DLL: Install Engine - download directory set to C:\Windows\Temp\IXP000.TMP

    00:00.047: INFO:    IEAKPRXY>>IEAK_DLL: SetLocalCif :C:\Windows\Temp\IXP000.TMP\IESetup.CIF:

    00:00.063: INFO:    IEAKPRXY>>IEAK_DLL: IEAKInitialize : Successfully Inited
    00:00.063: INFO:    IEAKPRXY>>[END] Call to IEAKInitialize()
    00:00.063: INFO:    IEAKPRXY>>[BEGIN] Call to IEAKSetConfiguration()
    00:00.063: INFO:    IEAKPRXY>>IEAK_DLL: IEAKSetConfiguration: Successfully Set Configured
    00:00.063: INFO:    IEAKPRXY>>[END] Call to IEAKSetConfiguration(), return value: TRUE
    00:00.063: INFO:    Trying to extract ID: SetupDownloadList.txt (0) as "SetupDownloadList.txt"
    00:00.063: INFO:    Trying to extract ID: HardwareBlockingList.xml (0) as "HardwareBlockingList.xml"
    00:00.063: INFO:    Trying to extract ID: 7006 (0) as "IE11-neutral.Extracted.cab"
    00:00.219: INFO:    Trying to extract ID: 5501 (1033) as "Spelling_en.msu"
    00:00.219: INFO:    Extracted Spelling dictionary for en to C:\WINDOWS\TEMP\IE13DC.tmp\Spelling_en.msu.
    00:00.219: INFO:    Trying to extract ID: 5502 (1033) as "Hyphenation_en.msu"
    00:00.219: INFO:    Extracted Hyphenation dictionary for en to C:\WINDOWS\TEMP\IE13DC.tmp\Hyphenation_en.msu.
    00:00.219: INFO:    Trying to extract ID: 7128 (1033) as "IE11-support.cab"
    00:00.702: INFO:    PauseOrResumeAUThread: Successfully paused Automatic Updates.
    01:00.794: INFO:    The no reboot policy and supplemental files failed to download correctly. Default installation files will be used. Wait return value was 0x00000102 (258) [The wait operation timed out. ]
    01:00.872: INFO:    Launched program to check hardware: "C:\WINDOWS\TEMP\IE13DC.tmp\IE11-SUPPORT\IEXPLORE.EXE" /CheckHardware "C:\WINDOWS\TEMP\IE13DC.tmp\HardwareBlockingList.xml"
    01:00.919: INFO:    Hardware support check succeeded. Installation will continue.
    01:00.919: INFO:    Windows 7 operating system detected.
    01:00.919: INFO:    Service pack major: 1
    01:00.919: INFO:    Service pack minor: 0
    01:00.919: INFO:    Service pack name:  Service Pack 1
    01:00.934: INFO:    Version Check for (KB2834140) of C:\WINDOWS\System32\d3d11.dll: 6.1.7601.17514 >= 6.2.9200.16570 (False)
    01:00.934: WARNING: Checking version for C:\WINDOWS\System32\api-ms-win-downlevel-user32-l1-1-0.dll.  The file does not exist.
    01:00.934: INFO:    Version Check for (KB2639308) of C:\WINDOWS\System32\Ntoskrnl.exe: 6.1.7601.18205 >= 6.1.7601.17727 (True)
    01:00.950: INFO:    Version Check for (KB2533623) of C:\WINDOWS\System32\api-ms-win-security-base-l1-1-0.dll: 6.1.7601.18229 >= 6.1.7601.17617 (True)
    01:00.950: INFO:    Version Check for (KB2731771) of C:\WINDOWS\System32\conhost.exe: 6.1.7601.18229 >= 6.1.7601.17888 (True)
    01:00.950: INFO:    Checking for correct version of C:\WINDOWS\Fonts\segoeui.ttf.
    01:00.950: INFO:    Version Check for (KB2786081) of C:\WINDOWS\System32\taskhost.exe: 6.1.7601.17514 >= 6.1.7601.18010 (False)
    01:00.966: INFO:    Version Check for (KB2888049) of C:\WINDOWS\System32\drivers\tcpip.sys: 6.1.7601.18203 >= 6.1.7601.18254 (False)
    01:00.981: INFO:    Version Check for (KB2882822) of C:\WINDOWS\System32\tdh.dll: 6.1.7600.16385 >= 6.1.7601.18247 (False)
    01:05.084: INFO:    Download for KB2834140 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=303935 -> KB2834140_amd64.MSU.
    01:05.084: INFO:    Download for KB2670838 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=272391 -> KB2670838_amd64.CAB.
    01:05.084: INFO:    Download for KB2729094 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=258385 -> KB2729094_amd64.MSU.
    01:05.084: INFO:    Download for KB2786081 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=273751 -> KB2786081_amd64.CAB.
    01:05.084: INFO:    Download for KB2888049 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=324542 -> KB2888049_amd64.MSU.
    01:05.100: INFO:    Download for KB2882822 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=324541 -> KB2882822_amd64.MSU.
    01:05.100: INFO:    Waiting for 6 prerequisite downloads.
    03:05.298: INFO:    Prerequisite download processes have completed. Starting Installation of 6 prerequisites.

    00:00.000: ====================================================================
    00:00.000: Started: 2014/08/06 (Y/M/D) 12:37:22.735 (local)
    00:00.000: Time Format in this log: MM:ss.mmm (minutes:seconds.milliseconds)
    00:00.000: Command line: C:\Windows\Temp\IXP000.TMP\IE-REDIST.exe  /ieak-full:C:\Windows\Temp\IXP000.TMP\ /no-default /quiet /norestart
    00:00.000: INFO:    Setup installer for Internet Explorer: 11.0.9600.16428
    00:00.000: INFO:    Previous version of Internet Explorer: 9.0.8112.16555
    00:00.000: INFO:    Checking if iexplore.exe's current version is between 11.0.9600.0...
    00:00.000: INFO:    ...and 11.1.0.0...
    00:00.000: INFO:    Maximum version on which to run IEAK branding is: 11.1.0.0...
    00:00.000: INFO:    iexplore.exe version check success. Install can proceed.
    00:00.000: INFO:    Operating System: Windows Workstation: 6.1.7601 (Service Pack 1)
    00:00.047: INFO:    IEAKPRXY>>[BEGIN] Call to IEAKInitialize()
    00:00.047: INFO:    IEAKPRXY>>IEAK_DLL: Date:8/6/2014 (M/D/Y) Time:12:37:22

    00:00.047: INFO:    IEAKPRXY>>IEAK_DLL: Install Engine - download directory set to C:\Windows\Temp\IXP000.TMP

    00:00.047: INFO:    IEAKPRXY>>IEAK_DLL: SetLocalCif :C:\Windows\Temp\IXP000.TMP\IESetup.CIF:

    00:00.063: INFO:    IEAKPRXY>>IEAK_DLL: IEAKInitialize : Successfully Inited
    00:00.063: INFO:    IEAKPRXY>>[END] Call to IEAKInitialize()
    00:00.063: INFO:    IEAKPRXY>>[BEGIN] Call to IEAKSetConfiguration()
    00:00.063: INFO:    IEAKPRXY>>IEAK_DLL: IEAKSetConfiguration: Successfully Set Configured
    00:00.063: INFO:    IEAKPRXY>>[END] Call to IEAKSetConfiguration(), return value: TRUE
    00:00.063: INFO:    Trying to extract ID: SetupDownloadList.txt (0) as "SetupDownloadList.txt"
    00:00.063: INFO:    Trying to extract ID: HardwareBlockingList.xml (0) as "HardwareBlockingList.xml"
    00:00.063: INFO:    Trying to extract ID: 7006 (0) as "IE11-neutral.Extracted.cab"
    00:00.219: INFO:    Trying to extract ID: 5501 (1033) as "Spelling_en.msu"
    00:00.219: INFO:    Extracted Spelling dictionary for en to C:\WINDOWS\TEMP\IE13DC.tmp\Spelling_en.msu.
    00:00.219: INFO:    Trying to extract ID: 5502 (1033) as "Hyphenation_en.msu"
    00:00.219: INFO:    Extracted Hyphenation dictionary for en to C:\WINDOWS\TEMP\IE13DC.tmp\Hyphenation_en.msu.
    00:00.219: INFO:    Trying to extract ID: 7128 (1033) as "IE11-support.cab"
    00:00.702: INFO:    PauseOrResumeAUThread: Successfully paused Automatic Updates.
    01:00.794: INFO:    The no reboot policy and supplemental files failed to download correctly. Default installation files will be used. Wait return value was 0x00000102 (258) [The wait operation timed out. ]
    01:00.872: INFO:    Launched program to check hardware: "C:\WINDOWS\TEMP\IE13DC.tmp\IE11-SUPPORT\IEXPLORE.EXE" /CheckHardware "C:\WINDOWS\TEMP\IE13DC.tmp\HardwareBlockingList.xml"
    01:00.919: INFO:    Hardware support check succeeded. Installation will continue.
    01:00.919: INFO:    Windows 7 operating system detected.
    01:00.919: INFO:    Service pack major: 1
    01:00.919: INFO:    Service pack minor: 0
    01:00.919: INFO:    Service pack name:  Service Pack 1
    01:00.934: INFO:    Version Check for (KB2834140) of C:\WINDOWS\System32\d3d11.dll: 6.1.7601.17514 >= 6.2.9200.16570 (False)
    01:00.934: WARNING: Checking version for C:\WINDOWS\System32\api-ms-win-downlevel-user32-l1-1-0.dll.  The file does not exist.
    01:00.934: INFO:    Version Check for (KB2639308) of C:\WINDOWS\System32\Ntoskrnl.exe: 6.1.7601.18205 >= 6.1.7601.17727 (True)
    01:00.950: INFO:    Version Check for (KB2533623) of C:\WINDOWS\System32\api-ms-win-security-base-l1-1-0.dll: 6.1.7601.18229 >= 6.1.7601.17617 (True)
    01:00.950: INFO:    Version Check for (KB2731771) of C:\WINDOWS\System32\conhost.exe: 6.1.7601.18229 >= 6.1.7601.17888 (True)
    01:00.950: INFO:    Checking for correct version of C:\WINDOWS\Fonts\segoeui.ttf.
    01:00.950: INFO:    Version Check for (KB2786081) of C:\WINDOWS\System32\taskhost.exe: 6.1.7601.17514 >= 6.1.7601.18010 (False)
    01:00.966: INFO:    Version Check for (KB2888049) of C:\WINDOWS\System32\drivers\tcpip.sys: 6.1.7601.18203 >= 6.1.7601.18254 (False)
    01:00.981: INFO:    Version Check for (KB2882822) of C:\WINDOWS\System32\tdh.dll: 6.1.7600.16385 >= 6.1.7601.18247 (False)
    01:05.084: INFO:    Download for KB2834140 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=303935 -> KB2834140_amd64.MSU.
    01:05.084: INFO:    Download for KB2670838 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=272391 -> KB2670838_amd64.CAB.
    01:05.084: INFO:    Download for KB2729094 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=258385 -> KB2729094_amd64.MSU.
    01:05.084: INFO:    Download for KB2786081 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=273751 -> KB2786081_amd64.CAB.
    01:05.084: INFO:    Download for KB2888049 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=324542 -> KB2888049_amd64.MSU.
    01:05.100: INFO:    Download for KB2882822 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=324541 -> KB2882822_amd64.MSU.
    01:05.100: INFO:    Waiting for 6 prerequisite downloads.
    03:05.298: INFO:    Prerequisite download processes have completed. Starting Installation of 6 prerequisites.
    03:05.298: ERROR:   Error downloading prerequisite file (KB2834140): 0x800c0005 (2148270085)
    03:05.314: INFO:    PauseOrResumeAUThread: Successfully resumed Automatic Updates.
    03:05.314: INFO:    Setup exit code: 0x00009C47 (40007) - Required updates failed to download.
    03:05.330: INFO:    Scheduling upload to IE SQM server: http://sqm.microsoft.com/sqm/ie/sqmserver.dll
    03:10.337: ERROR:   SQM Upload failed while uploading "C:\Users\Default\AppData\Local\Microsoft\Windows\Temporary Internet Files\SQM\iesqmdata_setup0.sqm" with error: 2147500036
    03:10.337: INFO:    Cleaning up temporary files in: C:\WINDOWS\TEMP\IE13DC.tmp
    03:10.368: INFO:    Unable to remove directory C:\WINDOWS\TEMP\IE13DC.tmp, marking for deletion on reboot.
    03:10.368: INFO:    Released Internet Explorer Installer Mutex


    03:05.314: INFO:    PauseOrResumeAUThread: Successfully resumed Automatic Updates.
    03:05.314: INFO:    Setup exit code: 0x00009C47 (40007) - Required updates failed to download.
    03:05.330: INFO:    Scheduling upload to IE SQM server: http://sqm.microsoft.com/sqm/ie/sqmserver.dll
    03:10.337: ERROR:   SQM Upload failed while uploading "C:\Users\Default\AppData\Local\Microsoft\Windows\Temporary Internet Files\SQM\iesqmdata_setup0.sqm" with error: 2147500036
    03:10.337: INFO:    Cleaning up temporary files in: C:\WINDOWS\TEMP\IE13DC.tmp
    03:10.368: INFO:    Unable to remove directory C:\WINDOWS\TEMP\IE13DC.tmp, marking for deletion on reboot.
    03:10.368: INFO:    Released Internet Explorer Installer Mutex

    I've highlighted the failure sections

    Then on the same machine used the .exe file that was created by IEAK11 and it has worked. So why is the msi failing to download the prerequisites where the exe doesn't?

    Wednesday, August 6, 2014 3:21 AM
  • 01:00.934: INFO:    Version Check for (KB2834140) of C:\WINDOWS\System32\d3d11.dll: 6.1.7601.17514 >= 6.2.9200.16570 (False).

    01:00.950: INFO:    Checking for correct version of C:\WINDOWS\Fonts\segoeui.ttf.
    01:00.950: INFO:    Version Check for (KB2786081) of C:\WINDOWS\System32\taskhost.exe: 6.1.7601.17514 >= 6.1.7601.18010 (False)

    01:05.100: INFO:    Waiting for 6 prerequisite downloads.
    03:05.298: INFO:    Prerequisite download processes have completed. Starting Installation of 6 prerequisites.
    03:05.298: ERROR:   Error downloading prerequisite file (KB2834140): 0x800c0005 (2148270085)
    03:05.314: INFO:    PauseOrResumeAUThread: Successfully resumed Automatic Updates.
    03:05.314: INFO:    Setup exit code: 0x00009C47 (40007) - Required updates failed to download.

    why is the msi failing to download the prerequisites where the exe doesn't?

    I don't understand the flow.  It says it's checking for  segoeui  (a font) and then digresses to check for other OS  support?  Looks like a packaging error to me.  But with an msi won't there be an MSI.log verbose if necessary?  This is another example of where I would be using ProcMon to correlate all diagnostic messages just to help read between the lines.  Filter with Operation Is WriteFile.

    And I still think the case of actually having the proper version of the missing module d3d11.dll should be tested.  It should change the symptom at least.  What happens then?

    Otherwise, another task for ProcMon would be to see if the highlighted code may be bogus.

    http://msdn.microsoft.com/en-us/library/ie/ms775145(v=vs.85).aspx

    <quote>

    INET_E_RESOURCE_NOT_FOUND
    0x800C0005

    The server or proxy was not found.

    </quote>

    E.g. the download was done and the install was being done so why make it look like a download failure?

     

    Good luck



    Robert Aldwinckle
    ---

    Wednesday, August 6, 2014 1:25 PM
    Answerer
  • Any updates on this? If IEAK 11 so broken, can we just get a link to IE11 msi that doesn't require any prepreqs?
    Wednesday, October 8, 2014 11:59 PM
  • I have this same issue. The MSI fails in my case (and I believe in the majority of cases out there in corporate environments) because the msiexec process and child processes (specifically ienrcore.exe) are running in the context of the System account. In my case, the System account is trying to go out directly to the Internet to get the updates but is failing because we are behind a proxy that it cannot reach.

    The EXE on the other hand runs in the context of a user account with Internet access and that is why it succeeds.

    To correct, you need to configure the System Account to use a proxy (or not use a proxy if direct or updated proxy if it has since changed). This can be accomplished a few ways but the most direct method is to use BITSAdmin:

    For example: bitsadmin /util /setieproxy localsystem MANUAL_PROXY MyProxy:8080 "<local>"

    The results are placed in the registry under DefaultConnectionSettings in HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections.

    Afterwards, the MSI ran as expected.

    Thursday, December 4, 2014 7:29 PM