locked
2003 to 2010 smtp relays RRS feed

  • Question

  • I have a 2003 server with a bunch of smtp allow relay ips configured.  I need to move them to the new 2010 server in the same org. How can this be accomplished?
    Thursday, August 18, 2011 2:23 PM

Answers

  • Yes, you just have to create new receive connector and said in below article and put all IP address in allow list. Make sure you are enableing anonymous access on receive conenctor if you want to relay mesage to internet users also.

    How To Allow Relaying in Exchange 2010 and Exchange 2007:

    http://exchangepedia.com/2007/01/exchange-server-2007-how-to-allow-relaying.html


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    • Proposed as answer by Anil K Singh Thursday, August 18, 2011 4:12 PM
    • Marked as answer by OldSchoola Monday, August 29, 2011 7:36 PM
    Thursday, August 18, 2011 4:12 PM

All replies

  • Reference this MS KB to export the Exchange 2003 SMTP Relay list using ipsec.vbs: http://support.microsoft.com/kb/935635. Then, use the Exchange cmdlet New-ReceiveConnector or Set-ReceiverConnector with the -RemoteIPRanges parameter to add the IP expections to Exchange 2010.

    -MatthewBrown

    • Proposed as answer by Anil K Singh Thursday, August 18, 2011 4:12 PM
    Thursday, August 18, 2011 3:59 PM
  • Yes, you just have to create new receive connector and said in below article and put all IP address in allow list. Make sure you are enableing anonymous access on receive conenctor if you want to relay mesage to internet users also.

    How To Allow Relaying in Exchange 2010 and Exchange 2007:

    http://exchangepedia.com/2007/01/exchange-server-2007-how-to-allow-relaying.html


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    • Proposed as answer by Anil K Singh Thursday, August 18, 2011 4:12 PM
    • Marked as answer by OldSchoola Monday, August 29, 2011 7:36 PM
    Thursday, August 18, 2011 4:12 PM
  • Do i put a receive connector on each ht server? i have a cas/array with the ht role installed on 2 servers. at each location, primary and DR, so do i create 4 receive connectors?

    Also what do i configure in the network, and authentication tabs?

    Sunday, August 21, 2011 3:52 PM
  • i created the smtp connector and i am still not able to send emails out via it.

    i am allowing anonymous users and exchange servers under the permissions tab.

    and i have TLS and Externally secured checked off under the AUTHENTICATION tab.

     

    I also ran these 2 powershells

    Get-ReceiveConnector "Fax/Printer" | Add-ADPermission -User "NT Authority\Anonymous Logon" -AccessRights ExtendedRight -ExtendedRights ms-exch-bypass-anti-spam

     

    Get-ReceiveConnector "Fax/Printer" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient"

     

    Yet i still cannot send out email via this relay from scanners.  Is there anyway to test this, or anyone have an idea wahts going on?

    Friday, August 26, 2011 7:16 PM
  • OldSchoola,
    You will find the answer in the link Anil provided.
    Hint: ms-Exch-SMTP-Accept-Any-Recipient

     


    Martina Miskovic
    Friday, August 26, 2011 8:12 PM
  • Yes, you just have to create new receive connector and said in below article and put all IP address in allow list. Make sure you are enableing anonymous access on receive conenctor if you want to relay mesage to internet users also.

    How To Allow Relaying in Exchange 2010 and Exchange 2007:

    http://exchangepedia.com/2007/01/exchange-server-2007-how-to-allow-relaying.html


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    Agreed
    --------Abhi----------------- Exchange Specialist------------- ------------------ Please remember to click “Mark as Answer” on the post that helps you. This can be beneficial to other community members reading the thread.
    Saturday, August 27, 2011 3:19 AM
  • The users configuring the device to work through this connector are saying its not working still.  

    I am able to telnet to it and create an email if i add the ip of my computer to the list, otherwise it says not authenticated and doesnt let me send the email. 

    Is there any other way to test this?

    Monday, August 29, 2011 1:46 PM
  • Have you added ms-Exch-SMTP-Accept-Any-Recipient now or not?
    Martina Miskovic
    Monday, August 29, 2011 1:48 PM
  • i added both of these

    Get-ReceiveConnector "Relays" | Add-ADPermission -User "NT Authority\Anonymous Logon" -AccessRights ExtendedRight -ExtendedRights ms-exch-bypass-anti-spam

    Get-ReceiveConnector "Relays" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient"

    and restarted the transport, when i send the email via telnet, the test email goes through.

    Monday, August 29, 2011 3:09 PM
  • Ok, so it works as it should when you use Telnet but not for the hosts that need so be able to relay.

    Turn on verbose logging on all your Receive Connectors and check the logs. Im sure the logs will tell you why it doesn´t work...


    Martina Miskovic
    Monday, August 29, 2011 3:15 PM
  • turn the logging on all connectors? not just the one i created for this relaying?

    and did you mean the PROTOCOL LOGGING LEVE?

     

    Monday, August 29, 2011 3:52 PM
  • turn the logging on all connectors? not just the one i created for this relaying?

    Yes, all of them.
    That way you will see if the hosts connects to the wrong connector. Could be the reason why they are not able to relay.
    Martina Miskovic
    Monday, August 29, 2011 3:54 PM
  • i know they are on the rigth connector because of teh banner thats displayed as well as when i remove the test pc ip from the allow list it doesnt let me connect.

     

    Monday, August 29, 2011 3:57 PM
  • also where am i looking in teh logs for information? i checked app and event and dont really see anything.
    Monday, August 29, 2011 4:10 PM
  • Check the logs in --> \Exchange Server\V14\Transport Roles\Logs\ProtocolLog\smtpreceive
    Martina Miskovic
    Monday, August 29, 2011 4:12 PM