none
Slow file transfer between VM and any of the machines in the networkHi Support, RRS feed

  • Question

  • Hi Support,

    I have just installed a new server Windows 2019 as a host and as a VM.  This is a new HP DL380, 32 GB ram and raid 5, 15k drives, server and everything is updated. everything looks good in the VM, I have dynamic memory and 10 core cpu in the settings.  the issue is any file transferred between the vm and other machines is extremely slow.  the issue does not exist for the host.  The server does not use the Broadcom network card. There are no applications only an RMM agent, Bit Defender antivirus and Datto backup agent.  The size of the VM is 800 GB.   I appreciate any help. 

    thanks,

    Jamshid

    Friday, November 8, 2019 1:55 AM

All replies

  • Hi Support,

    Do I need to disable the RSC on the virtual switch?  If yes what is the procedure.  Thanks for your help.

    Jamshid

    Friday, November 8, 2019 8:12 PM
  • I am trying to run these commands:

    1. You can disable a client's RSC for IPv4 traffic using PowerShell: Disable-NetAdapterRsc -Name $nic -IPv4.

    2. You can check a Hyper-V vSwitch's current RSC status using PowerShell: Get-VMSwitch -Name $vSwitch | Select *RSC*.

    3. You can disable a Hyper-V vSwitch's RSC in full using PowerShell: Set-VMSwitch -Name $vSwitch -EnableSoftwareRsc:$FALSE. This will not impact existing vSwitch connections.

    What is the -Name in the command? my virtual switch is called HyperV.  What is the proper command?

    I appreciate your help.

    Jamshid

    Saturday, November 9, 2019 12:59 AM
  • Hi Jamshid


    Set-VMSwitch -Name "HyperV" -EnableSoftwareRsc $false


    Disable-NetAdapterRsc "NetAdapterName" -IPv4 -IPv6

    Repeat for all Adapter

     

    To see status

    Get-VMSwitch -Name HyperV | Select-Object *RSC*

    Best regards 
    Kenneth

    Saturday, November 9, 2019 9:37 AM
  • Thank you Kenneth,

    i ran this command as is and i got no errors  Set-VMSwitch -Name "HyperV" -EnableSoftwareRsc $false

    i ran the Disable-NetAdapterRsc "NetAdapterName" -IPv4 -IPv6 command using this command to find the netAdaptername which is Hyper-V and i got the attached screenshot) error.

    what am i doing wrong?

    I appreciate your help.

    Jamshid

    Saturday, November 9, 2019 6:28 PM
  • Hej Jamshid

    Try this
    Disable-NetAdapterRsc "vEthernet (HyperV)" -IPv4 -IPv6

    Best regards
    Kenneth

    Sunday, November 10, 2019 8:07 AM
  • Thank you Kenneth, 

    This worked. But the copying is slightly better.  not as fast as it should be.  

    45 M takes about 5 minutes.  What do you recommend?

    i appreciate your help.

    Thanks

    Jamshid

    Sunday, November 10, 2019 3:25 PM
  • Sorry forgot to add this. 
    Sunday, November 10, 2019 3:33 PM
  • Hi Jamshid

    Have you done it on all the network adapters on the physical host?

    Is Real Time protection enabled?
    If so try and disable it.

    Best regardsKenneth


    Sunday, November 10, 2019 8:30 PM
  • Hi Kenneth,

    i only have one VM.  what is the real time protection?  how do I disable it.

    Thanks for your support.

    Jamshid

    Monday, November 11, 2019 12:28 AM
  • the server HP Proliant DL380  has 4 network cards and  3 of them disabled.  I use Bit Defender as part of the RMM agent and have disabled that.  Not sure what else I need to do..

    Thanks for your support.

    Jamshid

    Monday, November 11, 2019 12:42 AM
  • if you mean by Real time protection Windows defender, i disabled it still slow copy (transfer rate).  i appreciate your help.

    Thanks,

    Jamshid

    Monday, November 11, 2019 1:15 AM
  • Hi Jamshid,

    Please run the following command to do a test:

    Netsh int tcp set global chimney=disabled

    Netsh int tcp set global netdma=disabled

    netsh int tcp set global rss=disabled

    And then run the following commands on your adapter.

    Disable-NetAdapterChecksumOffload -Name "XXX"

    Disable-NetAdapterRss -name "XXX"

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   


    Monday, November 11, 2019 9:15 AM
  • Hi Candy,

    I appreciate your help.  Do I run this on the host or VM?

    I will do it on the host.  Thanks

    Jamshid

    Monday, November 11, 2019 4:13 PM
  • Hi Candy,

    this command Netsh int tcp set global chimney=disabled errors out on the host.  'chimney' is not a valid argument for this command.  The other two commands were o.k. 

    Please let me know what to do.  Can I run the other two commands? 

    Disable-NetAdapterChecksumOffload -Name "XXX"

    Disable-NetAdapterRss -name "XXX"

    what is xxx.  is this the adapter name? 

    I appreciate your help.

    Jamshid

    Monday, November 11, 2019 5:31 PM
  • Hi Support,

    I created another Ethernet switch and pointed the VM to it and everything works now.  I need to know what else I should do?  Do I still need to apply any of the commands and disable network adapters?  I appreciate your help

    Jamshid

    Tuesday, November 12, 2019 12:40 AM
  • Hi ,

    >>I created another Ethernet switch and pointed the VM to it and everything works now.

    Did you mean that file transfer speed is fine now?

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Tuesday, November 12, 2019 1:28 AM
  • yes. All the disabling and power shell commands did not work. After creating another ethernet switch the speed is o.k. now.  Do I need to do anything else?

    Thanks,

    Jamshid

    Tuesday, November 12, 2019 8:57 PM
  • Hi Jamshid,

    >>After creating another ethernet switch the speed is o.k. now.  Do I need to do anything else?

    If everything works fine now, you don't have to do anything. And you could mark the useful reply as answer to end this thread up.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,
    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Wednesday, November 13, 2019 1:49 AM