locked
Warning Message + Login prompt when create a new document .. RRS feed

  • Question

  • Hi, 

    I've been searching for days to solve this problem but i don't understand what's wrong...

    When a user wants to create a new document in a library using the library template a message appears saying that "some files could be dangereous for the computer and we shouldn't open it if we don't where it comes from". (1)

    Then, the login prompt appears again and user has to re-authenticate to be able to save the new doc (2).

    So, i read that most of the time, this appears when the IE intranet zone is not set properly.

    IE seems to be correctly configured (by GPO) but it doesn't work.

    Does anyone know how to solve this ? 
    Thank you
    Regards.

    Thursday, October 18, 2012 8:13 AM

Answers

  • So,

    I got the answer, in my case we needed to add this new registry key AuthForwardServerList under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

    Need a reboot or restart webclient (service)

    Check this KB for more information : http://support.microsoft.com/kb/943280/en

    • Marked as answer by infoada33 Wednesday, October 24, 2012 10:55 AM
    Wednesday, October 24, 2012 10:55 AM

All replies

  • Is the user logged on on the same domain with his/ her workstation or is he/ she working outside the domain (like at home connected through the internet to your intranet)?

    Re-authentication occurs when there is a cross-domain situation. If this is the situation, let the user try this when working at the office/ on your domain and see if the problem is still there.


    My SharePoint Blog: www.spstech.net | Twitter: http://www.twitter.com/marceldenouden

    Thursday, October 18, 2012 9:35 AM
  • We all are on the same domain.

    One very important thing ... i forgot to mention that i tried to switch the alternate access mapping but whatever the configuration i choose, if i use the server name to access the intranet i don't have the prompt login issue (wich is the most annoying thing):

    http://sp2010-fw-prod Default http://sp2010-fw-prod
    http://intranet.contoso.com Intranet http://intranet.contoso.com

    or 

    http://sp2010-fw-prod Intranet http://sp2010-fw-prod
    http://intranet.contoso.com default http://intranet.contoso.com

    It works fine only on this url : http://sp2010-fw-prod/..

    Weird...

    Thursday, October 18, 2012 10:09 AM
  • Hi,

    What if you close the login prompt, will the document be opened properly?

    You can try to disable the IE Enhanced Security Configuration to see whether it works.

    For more information ,please refer to these sites:

    It works only using IP!, Alternate Access Mapping error?: http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/540c8004-15c1-4d8a-b90d-bb95e3ddd2bd/

    SharePoint requires re-authentication accessing documents from Office: http://social.technet.microsoft.com/Forums/en-ZA/sharepointadmin/thread/c7c566b6-2f55-45ef-9bb9-c7ef679b681e

    Thanks,

    Entan Ming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contacttnmff@microsoft.com.


    Entan Ming

    TechNet Community Support

    Friday, October 19, 2012 5:34 AM
    Moderator
  • - If you close the login prompt, you can still read the document but if you want to  save it, sharepoint will show you you local computer, not the current library ...
    - IE Enhanced Security is disabled on sharepoint server.

    I read the topic you mentionned but I already added the sharepoint url in the local intranet zone... So when i navigate on my sharepoint site IE says that we are in intranet zone - Protected Mode disabled

    IE displays the exact same settings when i navigate through this url : http://sp2010-fw-prod but i don't have any prompt.

    That's driving me crazy...

    Someone who had the same problem said it solved it this way : (i have the same config bu doesn't work for me)

    HI All

    i had this problem from long time . finally we solved and the problem was on Host header configuration during create web application, you shouldn't PUT THE FQDN never that was the main problem

    Ex. Sharepoint.contoso.local with prompt for Authentication or re-authenticate 

    Ex2.Sharepoint only and you creat Canme for you dns point to the IP address  that will work

    to change the Host Header or Site URL after creation follow this :

    to make it simple, please follow the following steps to configure AAM (alternate access mapping)

    1. On the Alternate Access Mappings page, click Edit Public URLs .

    2. If the mapping collection that you want to modify is not specified, then choose one. 
      In the Alternate Access Mapping Collection section, 
      click Change alternate access mapping collection on the Alternate Access Mapping Collection menu.

    3. On the Select an Alternate Access Mapping Collection page, click a mapping collection.

    4. In the Public URLs section, you may add new URLs or edit existing URLs in any of the following text boxes:Default, Intranet, or you can change the Default from  http:// Sharepoint.contoso.local  tohttp://Sharepoint
    5. Click Save .

    Now you’ll have to switch over to your DNS server.

    1. Within the DNS Management Console and Under Forward Lookup Zones:
      Add a new Primary Zone with your new domain name.
      Add a new Host (A) to the records for http://Sharepoint and point the IP Address to the sharepoint server

    DON'T Ever Make any modifications from IIS make all from Central Administration

    Cheers,

    Monday, October 22, 2012 10:24 AM
  • So,

    I got the answer, in my case we needed to add this new registry key AuthForwardServerList under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

    Need a reboot or restart webclient (service)

    Check this KB for more information : http://support.microsoft.com/kb/943280/en

    • Marked as answer by infoada33 Wednesday, October 24, 2012 10:55 AM
    Wednesday, October 24, 2012 10:55 AM