locked
Search is not working after SSP Database restoration RRS feed

  • Question

  • Hi All,

    In one activity i have restored all the Production DB's to Test DB's in that i have restored SSP DB also. After restoration, Search is not working and it is showing the following error in the Event Log...

    Event ID: 6482

    Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (3932bc0d-e7c8-452f-b874-b09691ae49db).

    Reason: Object reference not set to an instance of an object.

    Techinal Support Details:

    System.NullReferenceException: Object reference not set to an instance of an object.

    at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.InstallGathererApplicationIf()

    at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()

    at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

    and when on any of the below links in Search Administration page

    Content Sources,  Default Content Access Account

    then i am getting following error...

    "The search service is currently offline. Visit the Services on Server page in SharePoint Central Administration to verify whether the service is enabled. This might also be because an indexer move is in progress."

    But i checked the "Services on Server" page in Central Admin and i could find all services are running in both the app servers (we have 2 app servers).

    I have tried restarting the services, but no luck :(

    Can anybody help me out, where i am going wrong...

    Thanks in advance.


    Success is not to be pursued; it is to be attracted by the person we become.
    Thursday, September 29, 2011 2:02 PM

Answers

  • Ok.

    Have you tried creating a new SSP?. Don't delete the existing SSP. Once you create a new SSP, try to add 2 sites to it. Run a full crawl in new SSP. Try to search and see if it works. If this works then only mysites DB you need to migrate.

    Thanks,

    Friday, September 30, 2011 2:24 PM

All replies

  • Hi,

    Please verify below items.

    Do you have only one Shared Service OR TWO. If two, are they both working??

    1) Delete the current index and recreate it again.

    2) Start and stop the search service from central admin. Make sure to select both the check boxes at top while restarting the service.

    3) Can you see Items are getting crawled with out errors?

    Update me, I will try to help you further.

    Thanks,

    Thursday, September 29, 2011 4:27 PM
  • Hi Raja,

    we have only 1 Shared service.

    Actually Index Server was also not tagged to the SSP initially, i have tagged it afterwords.

    Please suggest....

     


    Success is not to be pursued; it is to be attracted by the person we become.
    Thursday, September 29, 2011 4:48 PM
  • Hi,

    Go to Central Administration > Application Management > Manage this Farm's Shared Services

    EDit the properties of your SSP. Check if all properties are added properly.

    Click on OK and then start crawling it should work.

    I hope this will help you out.

     


    Thanks, Rahul Rashu
    Thursday, September 29, 2011 5:36 PM
  • Please run below command to stop and start Osearch

    stsadm -o osearch -action stop

    stsadm -o osearch -action start

    Then it ask you to reassign indexer. Assign indexer then go to SSP admin page -> search settings. Reset all crawled content and start full crawl.

    let me know the results.

    Thanks

    Thursday, September 29, 2011 5:38 PM
  • I have tried with the above stsadm commands but no luck. :(
    Success is not to be pursued; it is to be attracted by the person we become.
    Friday, September 30, 2011 7:08 AM
  • Ok.

    Have you tried creating a new SSP?. Don't delete the existing SSP. Once you create a new SSP, try to add 2 sites to it. Run a full crawl in new SSP. Try to search and see if it works. If this works then only mysites DB you need to migrate.

    Thanks,

    Friday, September 30, 2011 2:24 PM