locked
(SOLVED) How to move WSUS Content to network Share on Server 2012R2 RRS feed

  • General discussion

  • Symptom: WSUS Clients detect updates but will not download them after moving content folder to network share.  Error in EventViewer and WindowsUpdate.log is WSUS Content folder not found.

    Assuming a working WSUS setup using local WsusContent before beginning these steps.

    I wanted to share my WSUS conversion solution switching from local storage to a network share to prove it is it possible. I also moved my SUSDB database to a SQL Cluster, but that should not be required to move the Content folder.

    • Run WSUS Postinstall again. My example is:

    go to directory where wsusutil is:  cd "\Program Files\Update Services\Tools"

    Run command: 

    wsusutil postinstall content_dir=\\backup\Windows_Updates  sql_instance_name=sql\db  (this is my SQL cluster)

    At this point WSUS clients can check for and discover updates but not download them. The next steps fix downloading of updates.

    • Next edit the registry: HKLM\System\CurrentControlSet\Services\LanmanServer\Shares\WsusContent Change WsusContent REG_MULTI_SZ from D:\WsusContent to \\Backup\Windows_Updates\WsusContent  

    •  In the same place, Change UpdateServicesPackages to new location as well. Mine was \\Backup\Windows_Updates\UpdateServicesPackages

    • The postinstall not only missed the registry changes above, it also messes up the IIS Content virtual directory.  To fix, open IIS Manager, expand Sites, find site with Content folder. Right-click Content, Manage virtual directory, Advanced Settings and change Physical Path to \\backup\windows_updates\wsusContent\ – The leading backslashes were missing on mine.

    • In this same spot, also set permissions to the network share to use proper credentials, I used domain admin.  Right click Content -> Manage Virtual Directory -> Advanced Settings…   Physical Path Credentials, click “…” on right side.  Select specific user, click Set… add something you know will work on the network share.

    • Reboot WSUS server and updates should start downloading to clients.


    • Edited by DonSchaefer1 Friday, July 15, 2016 3:42 PM formatting
    Friday, July 15, 2016 3:38 PM

All replies

  • Hi Don,

    I tried it: changing the path from a local path to a share on another machine inside a share definition.

    after the reboot the share was gone, though the entry in the registry was here. trying to use that share gives error 53 as expected.

    Windows Server 2008 R2 btw.

    type=0 in the entry means 'drive' and there don't seem a type for a network device. 

    changing the virtual directory physical path may work, since IIS should not have problems to access network drives if running under a domain account.

    regards, Robert

    PS: I don't who uses the shares, but it's not the wuauclt. from the log:

    Downloading from http://w2008r2v1.gloeckner.local:8530/Content/3D/D1B6A5DBE79391A94A8A596DB8F07A9B61AA173D.cab to C:\Windows\SoftwareDistribution


    Sunday, August 14, 2016 4:41 PM