DPM 2012 R2 - Extreme amount of warnings in DPMRA.errlog RRS feed

  • Question

  • Hi,

    DPM 2012 R2 running on Windows 2008 R2. 

    DPM was upgraded from 2010 to 2012 R2 a couple of days ago.

    The server creates a lot of DPMRAxxx-logfiles in C:\Program Files\Microsoft DPM\DPM\Temp. 
    A vast majoity of the warnings in the logfiles says:

    WARNING [0x1b561580] Not able to apply security settings for \\?\Volume{fc9c5a30-0b93......
    WARNING Failed: Hr: = [0x80070005] : Encountered Failure: : lVal : ::SetKernelObjectSecurity( m_hFile, si, m_pSD)

    It seems to be one warning for every file protected. It affects all kinds of protection groups (SQL, file, etc)

    I´m also seeing warnings like:
    WARNING Failed: Hr: = [0x80070002] : GetFileAttributes failed for \\?\Volume{a4161096-a440-11e1-a6b1-001b21c942d8}\a8d09ded-4819-428c-8ecd-013e48e61a34\Incremental\181ebb88-4757-4b81-a88b-7fcc9fd77354\S-Vol\MSSQL\

    All PGs except one (there are 51 total) report ok in DPM gui, but I´m having some serious trust issues now when the server is spitting out log files filled with warnings.

    Looking for the warning messages in 11 files (randomly picked in powershell) resulted in the following number of warning/errors:
    "Not able to apply security settings for" : 146364
    "Encountered Failure: : lVal : ::SetKernelObjectSecurity" : 146364
    "GetFileAttributes failed for" : 1898

    Now, that´s from 11 logs created in less than 1 hour.

    Anyone out there that has an DPM 2012 R2 that can have a look in C:\Program Files\Microsoft DPM\DPM\Temp and see if you have a lot of DPMRAxx-logs? If it weren´t for the problems I´m having with one PG (another case/thread) I would probably have missed this since the GUI reports everyting as ok.

    Regards, Per

    Tuesday, November 19, 2013 9:04 AM

All replies

  • Hi Per,

    This feels like a R2 bug. We're experiencing exactly the same problem. We recently upgraded from DPM 2012 SP1 to R2, and have now found hundreds of similar errors in the DPMRA-error logs - only for one single volumes of a file server. Have opened a MS case as this is quite critical for us, so I would be very interested in any reply to this thread.


    Tuesday, November 19, 2013 7:25 PM
  • I'm experiencing the same issue. Both on our primary Server with a clean installation and our secondary with an upgrade installation.
    Wednesday, November 20, 2013 12:17 PM
  • I'm experiencing the exact same issue.  

    Logs are showing: WARNING Failed: Hr: = [0x80070005] : Encountered Failure: : lVal : ::SetKernelObjectSecurity( m_hFile, si, m_pSD)

    For each and every file the touched by the DPMRA process.  

    After 1hour 20min, DPMRA consistency check fails with: The protection agent on D( was temporarily unable to respond because it was in an unexpected state. (ID 60 Details: Internal error code: 0x809909B0)

    I'm totally at a loss.  We've initiated a support case, but MS doesn't seem to have any clue either.  At this point, i'm considering starting over and moving back to 2012 SP1.    R2 seems utterly broken.

    Wednesday, December 4, 2013 8:33 PM
  • Do you have a secondary DPM Server? Interestingly, shutting down the secondary DPM and waiting for completion of the first Recovery Point on the primary server solved the unexpected state problem for me. Might be worth a try.
    Thursday, December 5, 2013 6:16 AM
  • I do not have a second DPM Server.   Just the one.  It's a clean install.

    Clean install of Windows Server 2012 R2, SCDPM 2012 R2, and local clean install of SQL Server 2012.

    Everything is fully patched and updated.  No hardware issue at all. 

    This is VERY frustrating. 

    • Edited by Terafloppy Friday, December 6, 2013 5:21 PM
    Thursday, December 5, 2013 5:02 PM
  • Same issue with a new installation...

    Fresh clean installation of W2k12 Server and SCDPM 2k12R2

    Friday, December 6, 2013 1:22 AM
  • This problem was solved?
    Thursday, December 26, 2013 7:42 AM
  • I am having the exact same issue.

    I have a case open now.

    If a solution presents itself I'll update this thread accordingly.

    Good luck everyone.

    Thursday, December 26, 2013 4:22 PM
  • Evidently there is a private hotfix for this issue.

    It'll apparently be rolled into update rollup 1.

    If you cant wait for it then contact MS and open a ticket. 

    Thursday, December 26, 2013 4:45 PM
  • i did open a ticket with MS and they have yet to fix it.  Just keep telling me "A fix is being tested".

    No, I can't wait.  Did they actually give you the fix, or is this just a rumor? 

    Thursday, December 26, 2013 4:54 PM
  • They did give me a dll to overwrite.

    It didnt work however.  I am back in the same boat as you. 

    Friday, December 27, 2013 12:09 PM
  • @ Commoner31

    Same here.  I finally received the Private fix.  dsmfs.dll

    No change.  Log is still full of errors and my replications fail if they take more than 1hour and 20 minutes to run.  MS doesn't seem to have any idea why.

    At this point, i'm probably going to have to move to linux and BackupPC

    Friday, January 10, 2014 7:49 PM
  • Right, that's the same fix we received ourselves a couple of days ago. However, it solved the problems in our environment so now everything seems to work again.


    Friday, January 10, 2014 8:01 PM
  • Hello,

    We have released the fix in UR1.

    Issues that are fixed in System Center 2012 R2 Data Protection Manager Update Rollup 1

    Carlos (MSFT)

    Carlos Carrolo

    Wednesday, January 29, 2014 1:59 PM
  • Hello,

    We have released the fix in UR1.

    Issues that are fixed in System Center 2012 R2 Data Protection Manager Update Rollup 1

    Carlos (MSFT)

    Carlos Carrolo

    This does not fix the issue.

    Any other solutions?

    Friday, April 4, 2014 12:26 PM
  • Any update on this? We have the rollup installed also, but still receive the error messages


    Thursday, October 16, 2014 7:50 PM
  • The most recent version doesn't have this issue for me anymore.  However, I had to NOT install SQL on the same box as DPM.  Rather, I pointed it at our main SQL box and created an instance of it's own.  After that, things are fine.
    Thursday, October 16, 2014 8:46 PM