none
Error when installing R clien RRS feed

  • Question

  • The installation of Microsoft R client ended prematurely.  ( windows 7, 64 bit)

    Is it because of the antivirus program ?

    I cannot disable the Antivirus Symantec Endpoint protection as it is always enabled by a group policy.

    Any suggestion that may help me solving this issue will be highly appreciated.

    Thank you so much

    Tuesday, October 18, 2016 6:46 PM

All replies

  • Hi, same system, same problem. The installer worked fine when I took my machine home and ran it while connected to my home network. The MSI package doesn't seem to be picking up my workplace's firewall settings correctly. I don't usually have this problem with msi packages from other sources, so it has to be a bug in the installer.

    • Proposed as answer by dba_cabuloso Wednesday, May 8, 2019 1:00 PM
    • Unproposed as answer by dba_cabuloso Wednesday, May 8, 2019 1:00 PM
    Saturday, October 22, 2016 7:55 AM
  • The installer will work on Windows 7 systems, but your observation regarding firewalls is interesting.

    Can you please attach the following two installation log files from your install of Microsoft R Client to this forum thread?

    1).  Open Windows Explorer and type '%TEMP%' in the file dialog. This will take you to the Windows 'temp' directory on your system.

    2). In that directory you should find the following installation log files. Attach them to this forum post. This should help us pinpoint the installation problem:

    RClient_<DATETIME>.log

    RClientSetup_<DATETIME>.log

    Thanks!

    Stephen Weller

    Microsoft R Product Support

    Tuesday, October 25, 2016 10:23 PM
  • Hi Stephen, 

    I can't find any logs with those names in %TEMP%, or anywhere else on the machine.

    Wednesday, October 26, 2016 1:52 AM
  • Hi Stephen,

    I am having the same problem, the installer hits a certain point (during the MKL step) and then rolls back

    There are no R client logs in the Temp directory

    Trying to install on Windows 10

    Thanks

    Friday, November 4, 2016 11:05 AM
  • Can you please right-click on the RClient installer executable in File Explorer and goto 'Properties --> Details' and let me know what version of Rclient you are trying to install?

    Thanks.

    Stephen Weller

    Monday, November 7, 2016 3:40 PM
  • Can you please right-click on the RClient installer executable in File Explorer and goto 'Properties --> Details' and let me know what version of Rclient you are trying to install?

    Thanks.

    Stephen Weller

    Monday, November 7, 2016 3:40 PM
  • Hi Stephen,

    the version that's giving the error is 3.3.1 (microsoft-r-open-3.3.1)

    I was able to install MRO-3.3.0 no problem.

    Thanks

    Monday, November 7, 2016 3:52 PM
  • Can you please attach the following two installation log files from your install of Microsoft R Client to this forum thread?

    1).  Open Windows Explorer and type '%TEMP%' in the file dialog. This will take you to the Windows 'temp' directory on your system.

    2). In that directory you should find the following installation log files. Attach them to this forum post. This should help us pinpoint the installation problem:

    RClient_<DATETIME>.log

    RClientSetup_<DATETIME>.log

    I'm trying to install microsoft-r-open-3.3.1.msi on a Windows Server 2012 R2 and the setup also fails and rolls back. I can't find these log files on my system, not in the temp-directory or elsewhere on the system drive.

    I would also try to install v3.3.0 but I can't find the download link for this version.

    Thank you

    Monday, November 14, 2016 12:39 PM
  • Did you guys have the problem solved?

    I encountered the same issue. The installation of Microsoft R client (microsoft-r-open-3.3.1) ended prematurely.  ( windows 7, 64 bit)

    No RClient_<DATETIME>.log, RClientSetup_<DATETIME>.log found in %TEMP%, or anywhere else on the machine.

    Thursday, November 17, 2016 7:00 PM
  • @Mia, how are you installing Microsoft R Client ... from what source? Did you get it from here (https://msdn.microsoft.com/en-us/microsoft-r/r-client-install) and follow the instructions (particularly ... Log in to the machine with administrator privileges)?  Do you get this folder (C:\Program Files\Microsoft\R Client\R_SERVER) during the install?

    SOTATS, Inc.


    Sunday, November 20, 2016 4:43 PM
  • Hi Stephen,

    I am getting the same issues. The installation fails here:

    MSI (s) (54:C4) [16:00:44:487]: Created Custom Action Server with PID 2944 (0xB80).
    MSI (s) (54:D0) [16:00:44:533]: Running as a service.
    MSI (s) (54:D0) [16:00:44:533]: Hello, I'm your 32bit Elevated Non-remapped custom action server.
    CAQuietExec:  Reading registry value HKCU\SOFTWARE\Microsoft\RSetup\MROPKGS_DownloadUrl
    CAQuietExec:  Registry value: 
    CAQuietExec:  Starting download: https://go.microsoft.com/fwlink/?LinkId=831676&clcid=1033
    CAQuietExec:  Error making request: Unable to connect to the remote server
    CAQuietExec:  Download failed: https://go.microsoft.com/fwlink/?LinkId=831676&clcid=1033 
    CAQuietExec:  Error 0x8007b0bc: Command line returned an error.
    CAQuietExec:  Error 0x8007b0bc: QuietExec Failed
    CAQuietExec:  Error 0x8007b0bc: Failed in ExecCommon method
    CustomAction InstallMroPkgs returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (54:E4) [16:01:06:828]: User policy value 'DisableRollback' is 0
    MSI (s) (54:E4) [16:01:06:828]: Machine policy value 'DisableRollback' is 0
    Action ended 16:01:06: InstallFinalize. Return value 3.

    Looks like something to do with the proxy. I was able to download the following file from that url:

    SRS_8.0.3.16000_1033.cab

    Tuesday, November 22, 2016 8:25 AM
  • Thank you for your analysis! I'm behind a proxy too, it accepts Windows (domain) credentials.

    Tuesday, November 22, 2016 8:44 AM
  • Hi

    is there any update on this ?

    I presume Microsoft R Client is failing to install because it automatically installs Microsoft R Open and there's a problem with the latest install (3.3.1) ?

    Tuesday, November 29, 2016 5:38 PM
  • @BernyPurcell, I successfully installed Microsoft R Client 3.3.1 on Windows 10 without any issues which shows that there is not a problem with latest install.

    SOTATS, Inc.

    Tuesday, November 29, 2016 7:19 PM
  • My temp is in C:\Users\myuser\AppData\Local\Temp

    The error seems to be in the download

    CAQuietExec:  RSetup.exe version: 9.3.0.24
    CAQuietExec:  Starting download: https://go.microsoft.com/fwlink/?LinkId=867186&clcid=1033
    CAQuietExec:  Error making request: Unable to connect to the remote server
    CAQuietExec:  Download failed: https://go.microsoft.com/fwlink/?LinkId=867186&clcid=1033 
    CAQuietExec:  Error 0x80073b72: Command line returned an error.
    CAQuietExec:  Error 0x80073b72: QuietExec Failed
    CAQuietExec:  Error 0x80073b72: Failed in ExecCommon method
    CustomAction DownloadSRO returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

    If I try to download via Internet Explorer it does work. But the installation keeps returning error. Does anyone know any workaround for this?

    Lucas Benevides


    DBA Cabuloso

    Wednesday, May 8, 2019 12:21 PM
  • I finally found a workaround. 

    The package allows offline installation, in a command-line install. It is explained here.

    Then you have to download your cab files and refer to it, in the command line, using the parameter mediadir.

    Then the installation does not have to download anything and the process flows.

    Lucas Benevides


    DBA Cabuloso

    • Proposed as answer by dba_cabuloso Wednesday, May 8, 2019 1:03 PM
    Wednesday, May 8, 2019 1:03 PM