Pen input over RDS Remote App


  • We have a client-server application. We want to move it to RemoteApp. It is heavily reliant on handwriting using the Microsoft Ink framework.

    The pen input for handwriting is very poor. We have tweaked many things but are not seeing any improvement that would make the software usable in this environment.

    We setup everything with Server 2012. Windows 7/8 clients.

    Any suggestions on this topic would be greatly appreciated.

    Thank you.

    Wednesday, June 19, 2013 7:32 PM


All replies

  • Hi,

    This issue is hard to diagnose in the forum.I suggest you confer with your application vendor to see whether they can provide you with any suggestions.

    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedbackhere.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, June 20, 2013 9:08 AM
  • Hi,

    We are the application vendor, we build the software and are trying to find a solution to this problem.

    We have found some information that indicates that stylus integration is not supported in RDS.

    In addition, we've found that the stylus is not recognized as a pen but as a mouse input. Just like on a regular desktop.

    At this time, we are trying to find a way to either have the sytlus detected as a stylus and write normally.

    Or to have the mouse style of input from the pen work better. We've slowed down the mouse speed per an article, this helped quite a bit. But, there is still some significant issues, especially where the pen is lifted continuously as in printing vs. cursive writing.

    Friday, June 28, 2013 12:51 PM
  • I have not tried this yet, but I'm looking for the same solution for eClinicalWorks. I'll report back and let you know if it work for me.



    Monday, July 01, 2013 8:01 PM
  • Solved by moving to citrix.
    • Marked as answer by rd_bigdog Friday, June 13, 2014 9:00 PM
    Friday, June 13, 2014 9:00 PM